ワクワクメーカー（JS対応）

WakuwakuMaker_JS
ワクワクメーカー（JS対応）

EVANCE_JS3のラウンドの石枠を設計します。

操作方法:

  1. ダイアログボックスに、数値を入力して、石枠作成、つめの作成のボタンを押します。

    数値を変えて、シミュレーションしてみましょう。

  2. 設定が、決まったら、リングサイズが合っているか確認して、石枠をブールボタンを押すと、ダイアログボックスが終了します。

EVANCE_JS >WakuwakuMaker_JS


ラウンドダイヤを仮セット

RoundDiaSet
ラウンドダイヤを仮セット

サーフェス上に、ダイヤオブジェクトを配置します。

操作方法:

  1. ダイヤオブジェクトを配置するサーフェスをクリックします。
  2. 直径を入力して、Enterキーを押すと、サーフェス上にダイヤが現れますので、場所を決めて、マウスボタンを左クリックします。

    ダイヤの直径を変更するには、希望の数字を打ち込んで、Enterキーを押すと変更されます。

    コマンドオプションから反転、サーフェスから浮かせる距離を選択できます。

EVANCE_JS >RoundDiaSet


爪を直接配置

ArrayEvancePlong
爪を直接配置

⇒

(ポリ)サーフェス上に、爪を配置します。

操作方法:

  1. 爪を配置するサーフェス、または、ポリサーフェスをクリックします。
  2. 直径を入力して、Enterキーを押すと、サーフェス上に爪が現れますので、場所を決めて、マウスボタンを左クリックします。

    コマンドオプションから反転、爪の直径、長さ、テーパー係数、先端の丸め具合、シングルサーフェスで出力かどうか、シングルサーフェスで出力する場合は、エッジ部分の丸め具合をリアルタイムで変更可能です。

    Tips:

    プロモーション用のJSのコマンドですが、実用性が高いため、使いやすさを更に向上させました。

    普通のモデリングにも十分使えるコマンドです。

EVANCE_JS >ArrayEvancePlong


リング断面曲線を配置

ArrayRingProfiles
リング断面曲線を配置

⇒

リングの円周上に、断面曲線を配置します。

図のように、断面曲線はワールド平面上に水平に配置しておきます。

操作方法:

  1. リングサイズを入力します。
  2. 断面曲線を選択します。

    コマンドオプションから断面の数を変更できます。(デフォルトでは6です)

    Tips:

    リングアームをロフトコマンドで作るための補助コマンドです。

EVANCE_JS >ArrayRingProfiles


曲線のキンクをデリート

DeleteCurveKinks_Rebuild
曲線のキンクをデリート

選択された曲線から、キンクを取り除きます。

次数が３までの曲線のみ機能します。中に、直線や、円弧などの三次以下の曲線が含まれている場合は、三次曲線にリビルドします。

新バージョンでは、上の図のように丸くならずに、そのままの形状を保ちます。

さらには、「JSの断面として最適化」オプションを選ぶことで、"JS2"、"JS3"コマンドで使用した場合エッジを立てたままの断面でリング生成がサーフェスとして可能にするリング断面線として最適化されます。

操作方法:

  1. キンクを取り除く曲線を選択します。
  2. 次数が３以下の曲線を含んでいた場合、その部分のコントロールポイントの数はデフォルトでは、'4'になっています。コマンドオプションからCVPoint数を変更できますが新バージョンでは、特殊な場合を除いて必要ありません。

EVANCE_JS >DeleteCurveKinks_Rebuild


曲線のキンクをデリート RRAP対応

DeleteCurveKinksForRRAP
曲線のキンクをデリート RRAP対応

選択された曲線から、キンクを取り除きます。

次数が３までの曲線のみ機能します。中に、直線や、円弧などの三次以下の曲線が含まれている場合は、三次曲線にリビルドします。

旧"DeleteCurveKinks_Rebuild"コマンドでは、一次曲線、二次曲線の組み合わせだときれいに変換できましたが、そこに三次曲線の部分が混じるとキンクを外したためにテンションが弱くなりその周りが膨らんでしまうという問題がありましたが、それを高度な計算を加えることで解決しました。

それに加えて全体のコントロールポイントの数も均一になるように配置されます。

操作方法:

  1. キンクを取り除く曲線を選択します。
  2. 次数が３以下の曲線を含んでいた場合、その部分のコントロールポイントの数はデフォルトでは、'５'になっていますが、コマンドオプションからCVPoint数を変更して元の曲線との異差を確認することができます。 「ｻﾝﾌﾟﾘﾝｸﾞするﾎﾟｲﾝﾄ数」は、元の曲線により近づけるためにサンプリングする曲線上のﾎﾟｲﾝﾄ数です。デフォルトでは、'1000'ですが必要があれば変更してください。

EVANCE_JS >DeleteCurveKinksForRRAP（右クリック）


サーフェスのコントロール点を列ごとに徐々に回転

RotateSurfacePointsGradually
サーフェスのコントロール点を列ごとに徐々に回転

サーフェスの制御点をひとつだけ選択して、影響範囲を指定して初めに選択した制御点の列を中心にひねりを入れることが出来ます。

操作方法:

  1. 基点となるコントロールポイントをひとつだけ選択して、Enterキーを押します。
  2. まわりの何列めのまで回転させるか、数字で入力して、Enterキーを押して、CPlane上をクリックして、マウスを動かすと、起点に選んだポイントを含む列から、選択された数の列が少しずつひねるように回転します。

    45の倍数の数値入力をすると、正確にひねることが出来ます。

    Tips:

    これらのコントロールポイントを編集するコマンド群は、前提として"JS2"、"JS3"コマンドで、断面線を"DeleteCurveKinks_Rebuild"コマンドでキンクを取り除き、結果として生成されるシングルサーフェスのリング腕を想定しています。

    これらのコマンドを使わないで作ったリング腕などのサーフェスを利用される場合は、UV方向などをこれらで作ったサーフェスと合わせる必要があります。

    また、このコマンドは、平らかなリング腕を想定しているので、Ｙ軸方向に曲がりの強いリングの場合は、うまく機能しません。

    そういった場合は、まず、このコマンドでひねりを入れてから、、Ｙ軸方向に曲がりをつけるといいでしょう。

EVANCE_JS >RotateSurfacePointsGradually


サーフェス点をワールドＹ軸方向に移動

MoveSurfacePointGradually_W_Y
サーフェス点をワールドＹ軸方向に移動

サーフェスの制御点をひとつだけ選択して、影響範囲を指定して初めに選択した制御点の列を中心にワールド座標のY軸方向に移動させます。

操作方法:

  1. 基点となるコントロールポイントをひとつだけ選択して、Enterキーを押します。
  2. 何列となりのコントロールポイントのセットまで、移動させるか、数字で入力して、Enterキーを押して、CPlane上をクリックして、マウスを動かす基点を決めてマウスを移動すると、起点に選んだポイントを含む列から、選択された数の列が少しずつ移動量を少なくしながらワールド座標のY軸方向に移動します。数値入力も可能です。

    Tips:

    これらのコントロールポイントを編集するコマンド群は、前提として"JS2"、"JS3"コマンドで、断面線を"DeleteCurveKinks_Rebuild"コマンドでキンクを取り除き、結果として生成されるシングルサーフェスのリング腕を想定しています。

    これらのコマンドを使わないで作ったリング腕などのサーフェスを利用される場合は、UV方向などをこれらで作ったサーフェスと合わせる必要があります。

EVANCE_JS >MoveSurfacePointGradually_W_Y


サーフェス点を指定点の方向に移動(JS対応)

MoveSurfacePointsToPoint2D_JS
サーフェス点を指定点の方向に移動(JS対応)

⇒

選択された制御点群をリング基準で移動できます。

たとえば、基準点をゼロポイントに採れば、サンプルピクチャーのようにリングアームの交差などに利用します。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。
  2. CPlane上をクリックして、基点を決めてマウスを動かすと、シミュレーションが始まるので、イメージに合った移動位置のところでクリックします。数値入力も可能です。

    Tips:

    これらのコントロールポイントを編集するコマンド群は、前提として"JS2"、"JS3"コマンドで、断面線を"DeleteCurveKinks_Rebuild"コマンドでキンクを取り除き、結果として生成されるシングルサーフェスのリング腕を想定しています。

    これらのコマンドを使わないで作ったリング腕などのサーフェスを利用される場合は、UV方向などをこれらで作ったサーフェスと合わせる必要があります。

EVANCE_JS >MoveSurfacePointsToPoint2D_JS


サーフェス点をワールドＹ方向にスケール

ScaleSurfacePointsWorld_Y
サーフェス点をワールドＹ方向にスケール

選択された制御点群をセットごとに、ワールド座標のY軸方向に拡大・縮小します。

具体的には、リング腕の太さを調整したりするのに使用します。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。
  2. CPlane上をクリックして、基点を決めてマウスを動かすと、シミュレーションが始まるので、イメージに合った移動位置のところでクリックします。

    数値入力も可能です。

    Tips:

    これらのコントロールポイントを編集するコマンド群は、前提として"JS2"、"JS3"コマンドで、断面線を"DeleteCurveKinks_Rebuild"コマンドでキンクを取り除き、結果として生成されるシングルサーフェスのリング腕を想定しています。

    これらのコマンドを使わないで作ったリング腕などのサーフェスを利用される場合は、UV方向などをこれらで作ったサーフェスと合わせる必要があります。

EVANCE_JS >ScaleSurfacePointsWorld_Y


リングサイズに合わせてサーフェス点をスケール

ScaleSurfacePoints_RingSize
リングサイズに合わせてサーフェス点をスケール

選択された制御点群をセットごとに、ワールド座標のY軸の放射線方向に拡大・縮小します。

具体的な動作としては、選択した部分の腕の厚みを調整するのに使用します。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。
  2. まずリングサイズを指定して、Enterキーを押します。

    通常は、デフォルトのままでいいはずですが、もし違っていたら、正しいリングサイズを入力してください。

    次に、リングの号数から動かさないコントロールポイントの距離を入力します。これも、デフォルト値のままで、通常は差し支えないでしょう。

    もし、変更する場合は、リングの号数から動かしたくないコントロールポイントの距離を数字入力してEnterキー、そのままでいい場合は、Enterキーを押します。

    CPlane上をクリックして、基点を決めてマウスを動かすと、シミュレーションが始まるので、イメージに合った移動位置のところでクリックします。

    数値入力も可能です。

    3. Tips:

    これらのコントロールポイントを編集するコマンド群は、前提として"JS2"、"JS3"コマンドで、断面線を"DeleteCurveKinks_Rebuild"コマンドでキンクを取り除き、結果として生成されるシングルサーフェスのリング腕を想定しています。

    これらのコマンドを使わないで作ったリング腕などのサーフェスを利用される場合は、UV方向などをこれらで作ったサーフェスと合わせる必要があります。

EVANCE_JS >ScaleSurfacePoints_RingSize


サーフェス点をリングサイズに揃える

MoveSurfacePointsToRingSizeBM
サーフェス点をリングサイズに揃える

⇒

選択したコントロールポイント群をリングサイズにアタッチします。

サンプルピクチャーのように、複数のサーフェスのコントロールポイントを同時に選択して、移動することが可能です。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。複数のサーフェスのコントロールポイントを選んでも、OKです。
  2. まずリングサイズを指定して、Enterキーを押します。

    通常は、デフォルトのままでいいはずですが、もし違っていたら、正しいリングサイズを入力してください。

    Tips:

    これらのコントロールポイントを編集するコマンド群は、前提としてシングルサーフェスで製作された石枠や爪を想定しています。

    通常の、ポリサーフェスで作ったオブジェクトでは、コントロールポイントが編集できないため機能しません。

EVANCE_JS >MoveSurfacePointsToRingSizeBM


リングサイズ内側のサーフェス点をリングサイズに揃える

MoveSurfacePointsToRingSize_M
リングサイズ内側のサーフェス点をリングサイズに揃える

⇒

選択したコントロールポイント群をリングサイズの仮想の円柱にアタッチします。

"RotateSurfacePointsGradually"コマンドなどで、基本的に四角い断面のサーフェスを捻ると、上の左の図のようにリングサイズの内側までサーフェスが入り込んできてしまいますが、これを修正します。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。

    影響が無いため、関係のないところまで、多めに選んでも差し支えありません。

  2. まずリングサイズを指定して、Enterキーを押します。

    通常は、デフォルトのままでいいはずですが、もし違っていたら、正しいリングサイズを入力してください。

    その次に、コントロールポイント群の端っこの列以外をサーフェスから何ミリ浮かせるかを設定します。

    たいていの場合は、デフォルト値でいいはずですが、それでは不自然な場合は、数値を設定してEnterキーを押してください。

    尚、EVANCE_JS2で作った閉じたサーフェスの場合は、次の設定の、「先端の形状を選択」で、「クローズ」を選択してください。

    Tips:

    これらのコントロールポイントを編集するコマンド群は、前提として"JS2"、"JS3"コマンドで、断面線を"DeleteCurveKinks_Rebuild"コマンドでキンクを取り除き、結果として生成されるシングルサーフェスのリング腕を想定しています。

    これらのコマンドを使わないで作ったリング腕などのサーフェスを利用される場合は、UV方向などをこれらで作ったサーフェスと合わせる必要があります

EVANCE_JS >MoveSurfacePointsToRingSize_M（右クリック）


サーフェス点を平面上に移動

SetSurfacePointsPlan
サーフェス点を平面上に移動

⇒

選択したコントロールポイントの、U方向、または、V方向のコントロールポイントのセットを平面上に配置します。

操作方法:

  1. 移動させるコントロールポイントのUV列の中のポイントをひとつ選択して。Enterキーを押します。

    二列選択するのであれば、二つ選択するということです。

  2. UV方向をコマンドオプションから選択します。

    デフォルトでは、U方向になっています。

    Enterキーを押して、確定します。

    Tips: この機能を使えば、選択したコントロールポイントの列が平らかになるので、キャップが可能なサーフェスが出来ます。

EVANCE_JS >SetSurfacePointsPlan


レールに沿って回転の軸を設定

SearchCurveCenterPoint
レールに沿って回転の軸を設定

⇒

曲線または、サーフェスエッジから、中心点と、その中心点と曲線の始点(サーフェスエッジの始点)および終点をつなぐ直線を抽出します。

さらには、選択された曲線または、サーフェスエッジから、たとえそれらが平面上にない場合でも、自動的に全体の向きを計算して、"RailRevolve"コマンドを使うときの軸となる直線を作成します。

操作方法:

  1. サーフェスエッジ、または、曲線を選択してEnterキーを押します。複数選択が可能です。

    Tips:

    この線とポイントを使って"RailRevolve"コマンドをかければ、元のサーフェスにマージ可能なキャップが製作できます。

    閉じた曲線(サーフェスエッジ)の場合、始点と終点が同じなので、出来る直線は一本だけになります。

EVANCE_JS >SearchCurveCenterPoint


断面曲線の縦横サイズを合わせる

SetProfileCurvesWidthAndHight
断面曲線の縦横サイズを合わせる

⇒

適当に描いた断面を、一括して、左右、上下のピッチを合わせます。

操作方法:

  1. 左右、上下のピッチを合わせる断面を選択します。

    複数選択が可能です。

  2. 幅、高さを入力して、それぞれ、Enterキーで確定します。

    Tips:

    "EVANCE_JS3"コマンドでリングにしたときに、左右の腕がバランスよく仕上がるように大きさの調整が一度で可能です。

EVANCE_JS >SetProfileCurvesWidthAndHight


ダイヤのカラット数を指定してスケール

SetDiaCarat
ダイヤのカラット数を指定してスケール

⇒

ダイヤオブジェクトをカラットを指定して変更します。

操作方法:

  1. まず、カラット数を変更するダイヤモンドを選択、次に、セットになる石枠や爪を選択して、Enterキーを押します。
  2. 現在のカラット数が表示されますので、変更したいカラット数を打ち込んで、Enterキーを押します。

EVANCE_JS >SetDiaCarat


石のサイズを設定

SetStoneSize
石のサイズを設定

⇒

ダイヤモンドなど宝石オブジェクトを、縦幅、横幅、厚みをサイズ指定して、スケール変更します。

操作方法:

  1. まず、サイズを変更するダイヤモンドなどのストーンを選択、次に、セットになる石枠や爪があれば選択して、Enterキーを押します。
  2. 現在の縦幅、横幅、厚みがそれぞれ表示されますが、変更したい長さをそれぞれを打ち込んで、Enterキーを押します。

    Tips:

    そのまま、変更したくない場合は、Enterキーを押します。

    また、特にその項目の指定のない場合は、キャラクター(a,b,cなどのアルファベット)キーを押して、Enterキーを押すと、他のファクターから、自動的にのバランスを考えて設定されるファジーモードになります。

EVANCE_JS >SetStoneSize（右クリック）


リングサイズの円柱を製作

AddRingBaseCylinder
リングサイズの円柱を製作

指定したリングサイズのシリンダーサーフェスを追加します。

操作方法:

  1. リングサイズを入力して、Enterキーを押します。

    "JS2"、"JS3"コマンドでリング生成した場合は、自動的にそのサイズが設定されます。

    デフォルトのままで、いい時は、そのままEnterキーを押します。

    縦幅を変更する場合、コマンドオプションから変更できます。

EVANCE_JS >AddRingBaseCylinder


２本の曲線から立体パーツを製作

MakePartsFrom2Curves
２本の曲線から立体パーツを製作

⇒

２本の曲線から、立体サーフェスをリアルタイムに作成します。

操作方法:

  1. ２本の曲線を選択します。
  2. CPlane上の適当なところをクリックして、基点を決めます。マウスを動かすと、ラインが立ち上がるので、適当なところで、左クリックします。数値入力も可能です。元の２本のラインの両端の間隔が狭い、または、端点が重なっている場合、それを考慮した形状になりますが、オプションから「両端をｵｰﾌﾟﾝ」を選択することで元の２本のラインの両端の間隔が狭い、または、端点が重なっている場合でも、全くそれを考慮せず、同じ高さに立ち上がる設定にすることも可能です。

    Tips:

    このコマンドは、"AvarageCurveEx_Loft"と類似していますが、"AvarageCurveEx_Loft"が上下両方向に起ち上がるのに対して、上下どちらか片側にのみ起ち上がり、反対側は、丸くスムーズにつながる感じで処理されます。

EVANCE_JS >MakePartsFrom2Curves


レジスタ

EVANCE_JS_REGISTER
レジスタ

コンストラクション・プレーン上にある地金の重さや、ダイヤモンド等の宝石のカラット数を計算することが出来ます。

それぞれの単価を入力すると、トータルの材料費も算出することも出来ます。

操作方法:

  1. ダイアログボックスが現れるので、測定するサーフェス、または、ポリサーフェスを選択して、該当する項目の設定をして、ボタンを押します。

    新しいバージョンでは、メッシュオブジェクトも選択できるようになりました。

    ソリッド・オブジェクトになっていなくても、機能するように設計されていますが、ライノでボリュームが計測できない形状の場合は、同様に計量出来ないことがあります。

EVANCE_JS >EVANCE_JS_REGISTER


リングサイズダイアログ

RingSizeDialog
リングサイズダイアログ

日本基準のリングサイズ円を生成します。(ダイアログボックス使用)

サイズは、小数点以下も入力可能で、簡単なリングのシミュレーションも出来ます。

操作方法:

  1. ダイアログボックスの入力欄の数値を設定して、プレビューボタンを押します。
  2. シミュレーションされたものが、イメージどおりになったら、ＯＫボタンで、確定します。

    Tips: OKボタンの代わりに、マウスの右クリックや、、Enterキーは無効です。

    必ず、OKボタンを使用してください。

EVANCE_JS >RingSizeDialog


リングサイズ

RS
リングサイズ

日本基準のリングサイズ円を生成します。(ダイアログボックス不使用)

サイズは、小数点以下も入力可能です。

操作方法:

  1. リングサイズを数値入力しス、Enterキーを押します。

    Option:デザイナーズモード、造型モードに切り替えが出来ます。

EVANCE_JS >RingSize(右クリック)


リングコントロール曲線

RingControlCurve
リングコントロール曲線

⇒

サーフェス、またはポリサーフェスのリングを編集する曲線のケージ点を自動的に設定します。

操作方法:

  1. 編集する、サーフェスまたは、ポリサーフェスで作られているリングを選択します。
  2. オプションからリングの先端が閉じられたデザインか、上の例図のような開いたリングデザイン

    かを選択し、コントロールポイントの数を設定します。

    開いたリングデザインの場合は、右、左の先端の中心部分をクリックして指定します。

    幅の広いリングの場合、片側がクラッシュしてしまうケースがありますが、その場合はオプションの「コントロールのタイプ」を「曲線」ではなく「サーフェス」に設定することで回避できます。

    「コントロールのタイプ」を「サーフェス」にすることにより、リング幅の変更も可能になります。

    また、コントロールポイントのあるところの断面線も抽出できるオプションもついているので、必要な場合には利用してください。

    Tips: 開いたリングデザインの場合でも、敢えてオプションで「リングの先端が閉じられたデザイン」を選ぶことによって、リングアームの両端が連動するように編集することも可能ですのでお試しください。

EVANCE_JS >RingControlCurve


リングコントロールサーフェス（Ｙ軸方向）

RingControlSurfaceY_axis
リングコントロールサーフェス（Ｙ軸方向）

⇒

サーフェス、またはポリサーフェスのリングをY軸方向から編集するリングのサイズに合わせたコンロールサーフェスを自動的に設定します。

これにより、簡単にリングの厚み調整が可能になります。

操作方法:

  1. 編集する、サーフェスまたは、ポリサーフェスで作られているリングを選択します。
  2. オプションからコンロールサーフェスのUVそれぞれの方向のコントロール点の数を設定できます。コントロール点をドラッグして編集してください。

    Tips:一度設定したコンロールサーフェスのUV方向のコントロール点の数は、アタッチした状態のまま「ｺﾝﾄﾛｰﾙｻｰﾌｪｽをﾘﾋﾞﾙﾄﾞ」コマンドで変更可能です。

EVANCE_JS >RingControlSurfaceY_axis(右クリック)


コントロール曲線をリビルド

RebuildControlCurve
コントロール曲線をリビルド

⇒

サーフェス、またはポリサーフェスのリングを編集するコントロール曲線をキャプチャー状態

を維持したままリビルトできます。

操作方法:

  1. リビルトする、コントロール曲線を選択します。
  2. 新しいコントロールポイント数を入力してエンターキーを押します。

EVANCE_JS >RebuildControlCurve


コントロールサーフェスをリビルド

RebuildControlSurface
コントロールサーフェスをリビルド

⇒

サーフェス、またはポリサーフェスのリングを編集するコントロールサーフェスをキャプチャー状態

を維持したままリビルトできます。

操作方法:

  1. リビルトする、コントロールサーフェスを選択します。
  2. UV方向それぞれに、新しいコントロールポイント数を入力してエンターキーを押します。

EVANCE_JS >RebuildControlSurface(右クリック)


リングサイズ直し

RingResize
リングサイズ直し

⇒

サーフェス、またはポリサーフェスのリングを自動でサイズ直しできます。

操作方法:

  1. サイズ直しをするリングを選択します。
  2. つぎに石や爪など付随するものがあれば選択します。ここで選択したものは位置はサイズ直ししたリング上に置き換えられますが、形状は維持されます。（変形されません）
  3. 自動的にサイズが入力されますが、修正するときは数値入力、そのままでいい場合はEnterで確定します。
  4. 新しいサイズを入力します。オプションで「ﾚｰﾙ曲線のｵﾌｾｯﾄ距離」を指定できます。
  5. 2レールスイープコマンドがかかった状態になるので、必要ならダイアログボックスで編集してください。

EVANCE_JS >RingResize


クローズドリングを製作

EVANCE_JS_2
クローズドリングを製作

リング前面が連続したシンプルなデザインリングを、ミキシングコンソールを操作するように、デザインできます。

断面を自作することが自在に出来るので、自由度の高いコマンドに仕上がっています。

操作方法:

  1. 断面線を選択して、サイズを入力、腕の形状を選択して、あとは、ミキシング・コンソールのつまみをつまんで、直感的にデザインできます。セーブボタンで、つまみの位置をファイルに記憶させ、ロードボタンで読み込むことも出来ます。

    Tips:

    モデリング中は、断面線を選び続ける必要があります。断面は、断面は、ワールドの座標軸上では、どこに描いてもかまいません。

    右側が、表側になります。

    また、このコマンドを使うときは、スタートファイルに設定された3dmファイルか、それを元に編集したファイルを使用してください。そうでないと、レンダリングのレイヤーや、レンダリングモードでも曲線を描写するという、このコマンドを行うのに必要な設定になりません。

EVANCE_JS >EVANCE_JS_2


クローズドリング・コントロールパネル

RingSurfaceControllerYDirJS2
クローズドリング・コントロールパネル

EVANCE_JS_2で製作したモデルをさらに細かい設定を、精密なミキシング・コンソールを使って、修正できます。

操作方法:

  1. リングのサーフェスを選んで、ミキシング・コンソールのつまみを操作します。

    メモ: シングルサーフェスである限り、どのタイミングで操作しても、有効です。

EVANCE_JS >JS_2 ControllerYDir（右クリック）


オープンリングを製作

EVANCE_JS_3
オープンリングを製作

上面に石枠を載せるタイプのリングをミキシング・コンソールのつまみを操作する感覚で、直感どおりにデザインできます。

左右で、別々の断面を使うことが出来、その場で描いた断面をすぐに使うことも可能です。

操作方法:

  1. 断面を選択して、サイズ、腕の後ろの形状を決めて、ミキシング・コンソールのつまみを操作します。

    Tips:

    モデリング中は、断面線を選び続ける必要があります。断面は、ワールドの座標軸上では、どこに描いてもかまいません。

    右側が、表側になります。

EVANCE_JS >EVANCE_JS_3


オープンリング・コントロールパネル

RingSurfaceControllerYDirJS3
オープンリング・コントロールパネル

EVANCE_JS_3で製作したモデルをさらに細かい設定を、精密なミキシング・コンソールを使って、修正できます。

操作方法:

  1. リングのサーフェスを選んで、ミキシング・コンソールのつまみを操作します。

    Tips: シングルサーフェスである限り、どのタイミングで操作しても、有効です。

EVANCE_JS >JS_3 ControllerYDir（右クリック）


マルチプルブール演算：和

MultipleBooleanUnion_Ultima
マルチプルブール演算：和

サーフェスモデラーであるライノのもっとも大きな欠点のひとつに、ブーリアンがたびたびかからないという点が挙げられます。

多くの場合多少ずらすことによって、出来るようになるケースが多いのですが、それを自動的にやってくれるというコマンドです。

ライノの、全体を一度にトリムして、要らない側を削除、残りをジョインするというブールと違って、一つずつ、次々にブールしていき、、出来ない場合は、指定した距離だけずらし、それでもだめな場合は、違う方向にまた指定した距離の範囲でずらし、指定した範囲でスケールもかけながらブールを試みるというものです。

それの足し算バージョンです。

最大の美点は、ブーリアンされたあとのオブジェクトのチェック機能がついている点です。

ひとつずつブーリアンするごとに、出来たものが、壊れてないか、ノンマニホールドが出来ていないかチェックして、もし、エラーがあった場合は、さらに移動させて、やり直すというものです。

従いまして、このコマンドでブーリアンされたものは、絶対にエラーがないという保障つきです。

ブールに失敗しても、どこで失敗したか、選択して示してくれる機能もついています。

操作方法:

  1. ブールしたいサーフェス、または、ポリサーフェスを、選択したものの順番が、接点があるように、順に選択していき、選び終えたら、Enterキーを押します。

    出来ない場合に引く側のオブジェクトを移動させる距離を入力して、Enterキーを押します。

    デフォルトでは、0.01mmに設定されています。

    位置をずらしても出来ない場合に、スケール倍率をずらす数値を入力します。

    デフォルトでは、0.01に設定されています。

    これは、元の大きさを「1」としたときに、「0.99」か、「1.01」の大きさになるという意味です。

    Tips: ブールが失敗して、失敗したオブジェクトを選択していても、いくら、チェックしても、そのオブジェクトに全く悪いところがない場合があります。

    そういう場合は、その前のブールでブール演算の結果、ブールされたものがなくなってしまったというケースがあるので、疑ってみてください。

    選択されているオブジェクトとブールされるものがないので、失敗して、結果として、現在のオブジェクトを選択しているというケースがあります。

Evance'sAnalyze>MultipleBooleanUnion_Ultima


マルチプルブール演算：差

MultipleBooleanDif_Ultima
マルチプルブール演算：差

サーフェスモデラーであるライノのもっとも大きな欠点のひとつに、ブーリアンがたびたびかからないという点が挙げられます。

多くの場合多少ずらすことによって、出来るようになるケースが多いのですが、それを自動的にやってくれるというコマンドです。

ライノの、全体を一度にトリムして、要らない側を削除、残りをジョインするというブールと違って、一つずつ、次々にブールしていき、、出来ない場合は、指定した距離だけずらし、それでもだめな場合は、違う方向にまた指定した距離の範囲でずらし、指定した範囲でスケールもかけながらブールを試みるというものです。

それの引き算バージョンです。

最大の美点は、ブーリアンされたあとのオブジェクトのチェック機能がついている点です。

ひとつずつブーリアンするごとに、出来たものが、壊れていないか、ノンマニホールドが出来ていないかチェックして、もし、エラーがあった場合は、さらに移動させて、やり直すというものです。

従いまして、このコマンドでブーリアンされたものは、絶対にエラーがないという保障つきです。

ブールに失敗しても、どこで失敗したか、選択して示してくれる機能もついています。

操作方法:

  1. マイナス演算される引かれる側のサーフェス、または、ポリサーフェスを選択します。

    このコマンドでは、引かれる側のものは、一つしか選択できません。

  2. 引く側のサーフェス、または、ポリサーフェスを選択して、Enterキーを押します。

    出来ない場合に引く側のオブジェクトを移動させる距離を入力して、Enterキーを押します。

    デフォルトでは、0.01mmに設定されています。

    位置をずらしても出来ない場合に、スケール倍率をずらす数値を入力します。

    デフォルトでは、0.01に設定されています。

    これは、元の大きさを「1」としたときに、「0.99」か、「1.01」の大きさになるという意味です。

    Tips: ブールが失敗して、失敗したオブジェクトを選択していても、いくら、チェックしても、そのオブジェクトに全く悪いところがない場合があります。

    そういう場合は、その前のブールでブール演算の結果、ブールされたものがなくなってしまったというケースがあるので、疑ってみてください。

    選択されているオブジェクトとブールされるものがないので、失敗して、結果として、現在のオブジェクトを選択しているというケースがあります。

    引き算の結果、出来たオブジェクトが二つ以上に分かれたときは、一番大きなものだけ残して、残りは、削除して、プログラムを続行します。

Evance'sAnalyze>MultipleBooleanDif_Ultima


マルチプルブール演算：差（演算の結果が２個以上になる場合仕様）

TwoObjectsBooleanDif_Ultima
マルチプルブール演算：差（演算の結果が２個以上になる場合仕様）

"MultipleBooleanDif_Ultima"コマンドは、引き算の結果、出来たオブジェクトが二つ以上に分かれたときは、一番大きなものだけ残して、残りは、削除して、プログラムを続行します。

それが、不都合な場合に使用します。

ブーリアン引き算の結果が二つ以上に分かれて、そのどれもが必要な場合に使用します。

但し、引くものは、一つしか選択できません。

操作方法:

  1. マイナス演算される引かれる側のサーフェス、または、ポリサーフェスを選択します。

    このコマンドでは、引かれる側のものは、一つしか選択できません。

  2. 引く側のサーフェス、または、ポリサーフェスを選択します。

    このコマンドでは、引くオブジェクトは、一つしか選択できません。

    出来ない場合に引く側のオブジェクトを移動させる距離を入力して、Enterキーを押します。

    デフォルトでは、0.01mmに設定されています。

    位置をずらしても出来ない場合に、スケール倍率をずらす値を入力します。

    デフォルトでは、0.01に設定されています。

    これは、元の大きさを「1」としたときに、「0.99」か、「1.01」の大きさになるという意味です。

Evance'sAnalyze>TwoObjectsBooleanDif_Ultima(右クリック)


体積を表示（全部）

VolumeDisplay
体積を表示（全部）

画面にあるオブジェクトの重さを、シルバー、ゴールド、プラチナに換算して、一覧表示します。

さらには、そのオブジェクトにエラーがある場合は、エラーのあるオブジェクトを選択された状態にして、エラーの内容を表示します。

操作方法:

  1. 何も選択されていない状態で、コマンドを実行します。

Evance'sAnalyze>VolumeDisplay(右クリック)


体積を表示（選択されているもの）

VolumeDisplaySelected
体積を表示（選択されているもの）

選択したオブジェクトの重さを、シルバー、ゴールド、プラチナに換算して、一覧表示します。

さらには、そのオブジェクトにエラーがある場合は、エラーのあるオブジェクトを選択された状態にして、エラーの内容を表示します。

操作方法:

  1. 計測するサーフェス、ポリサーフェスを選択して、コマンドを実行します。

Evance'sAnalyze>VolumeDisplaySelected


体積があるかチェック

SelVolumeProblemObjects
体積があるかチェック

VolumeDisplayコマンドに似ていますが、画面表示はせず、エラーのあるオブジェクトの選択と、その個数だけコマンドラインに表示します。

操作方法:

  1. 何も選択されていない状態で、コマンドを実行します。

    Tips:さらなる問題を検出するには、"Check"コマンド、"Volume"コマンドおよび、"SelBadObjects""ExtractBadSrf"などが有効です。

Evance'sAnalyze>SelectVolumeProblemObjects


厚みをライブ表示

DisplayTickness
厚みをライブ表示

⇒

原型作りには欠かせない、厚み測りコマンドです。

リアルタイムにサーフェス間の最短距離を測定し、表示します。

クリックすると、その値を確定して、固定表示します。

操作方法:

  1. 厚みを計測するサーフェスを１枚選んで、Enterキーを押すか、または、２枚選択します。
  2. 左クリックするごとに、厚みの表示を確定します。

    Tips: サーフェスを２枚選んだ場合は、マウスポインタの選択している側からの最短距離、一枚選択の場合は、マウスポインタの位置からのサーフェスの垂直方向の断面の厚みを計測します。

    従いまして、サーフェスを２枚選んだ場合は、理論上正確な最短距離となりますが、一枚選択の場合は、多少数字が大きめに出るので、目安と考えていただいたほうがよいでしょう。

Evance'sAnalyze>DisplayTickness


自己交差曲線を検出

SelfIntersectionCurveCheck
自己交差曲線を検出

⇒

テキストオブジェクトコマンドなどを使って配置した曲線が、その曲線自身が絡まっていて、後々問題を引き起こすということがよくあります。

このコマンドを調べたい曲線を選択して実行すると、たちどころに問題のある部分を教えてくれます。

問題のある曲線を選択し、具体的に絡まっている部分にポイントが打たれます。

操作方法:

  1. チェックしたい曲線を選択して、Enterキーを押します。

Evance'sAnalyze>SelfIntersectionCurveCheck


Brepをアナライズ

AnalyzeBrep
Brepをアナライズ

⇒

ライノのサーフェスやポリサーフェスは、B-repという概念を用いて、構成されています。

そのB-repを、点や、線や、サーフェスなどの構成要素をすべて暴き出すコマンドです。

このコマンドによって、複雑なライノの真の姿を垣間見ることが出来るでしょう。

これを知ることによってライノの理解も深まります。

その目的だけのためにあるのではなく、便利な利用の仕方もあるコマンドです。

操作方法:

  1. 分析したい、サーフェス、または、ポリサーフェスを選択して、Enterキーを押します。

    2. Tips: 分析という本来の機能のほかに、すべての使用されているサーフェスを一度にトリム解除するコマンドと考えることも出来ます。

    因みに、ワールド座標軸のCPlane上に展開される曲線群が、トリムカーブです。

    ライノでは、この二次元の曲線を三次元サーフェスにマッピングして、トリムを行っているのです。

Evance'sAnalyze>AnalyzeBrep


パラム点を取得

GetParametersPoint
パラム点を取得

⇒

ライノの曲線やサーフェスには、param点というものが存在します。

曲線やサーフェスのコントロールポイントの本来の基点と考えても、ほぼ間違いではないでしょう。

それを表示するコマンドです。

操作方法:

  1. 分析したい曲線、またはサーフェスのコントロールポイントを選択して、Enterキーを押します。

    2. Tips: 時々コマンドがとんでもない結果になることがありますが、それはこのパラム点が予想外のところにあることに起因することがあるのですが、このコマンドでその検証が可能になります。

Evance'sAnalyze>GetParametersPoint


コントロール点を交換

ExchangeCVPoints
コントロール点を交換

⇒

点や面のコントロールポイントを入れ替えてしまうコマンドです。

２本の線または異なる２つのサーフェス間でも正確に作動します。

また、サーフェスでは、トリムした状態のままで作動します。

操作方法:

  1. 入れ替えるコントロールポイントをワンセット、クリックして、選択します。

    Tips: セットで選択するときは、ExchangeCVPointsSetSelectコマンドを使用します。

Evance'sEditCurvePoints>ExchangeCVPoints


コントロール点をセットで交換

ExchangeCVPointsSetSelect
コントロール点をセットで交換

⇒

複数のコントロールポイントのセット同士丸ごと入れ替えてしまうというコマンド。

２本の線または異なる２つのサーフェス間でも正確に作動します。

操作方法:

  1. 入れ替えたいコントロールポイントのはじめのセットを順番にクリックし、Enterキーを押します。
  2. 次のセットを、入れ替える順番の通りに、クリックして、選択します。

Evance'sEditCurvePoints>ExchangeCVPointsSetSelect（右クリック）


コントロール点をセットで交換（自動選択）

ExchangeCVPtSetSelectHyper
コントロール点をセットで交換（自動選択）

⇒

複数のコントロールポイントのセット同士丸ごと入れ替えてしまうというコマンド。

片方のコントロールポイントセットを選択すると、対応させるコントロールポイントのセットのうち一点だけを選択すれば、それに対応するコントロールセットを自動で選択します。

ただし、このコマンドは、同一のサーフェス上、UVどちらか一列ずつのコントロールポイントにしか対応していません。

操作方法:

  1. 入れ替えたいコントロールポイントのはじめのセットを順番にクリックし、Enterキーを押します
  2. 次のコントロールポイント・セットのうちの一点だけをクリックして、選択します。

Evance'sEditCurvePoints>ExchangeCVPtSetSelectHyper


曲線を平面上に設定

flattenCurvesSimple
曲線を平面上に設定

選択した曲線を、自動的に平面上にプロジェクトした曲線を作ります。コントロールポイントの数は、変更がありません。

平面は、自動設定しますので、意図的に平面の向きを設定したいときは、別途、任意の平面を作って、プロジェクトしてください。

操作方法:

  1. 平らにしたい曲線を選択します。

Evance'sEditCurvePoints>flattenCurvesSimple


作業平面を２レールスイープの断面線に設定

SetCPlanFor2RailSweep
作業平面を２レールスイープの断面線に設定

⇒

２レールスイープの断面線をもっとも望ましい角度で、描けるようにCPlanの向きを自動的に設定します。

さらには、端点から端点まで描きやすいようにポイントを挿入し、しかもそれを編集が楽なようにＸ軸上になるよう配置します。

操作方法:

  1. レールになる２本の線を選択します。
  2. 断面線を挿入したいポイントをそれぞれの線上でクリックして、選択します。

    １本目のレール線上のポイントを選択するときに、オプションのセレクションをクリックして、Autoモードにすると、はじめの点だけ選ぶと、二点目は、そのポイントの２本目のレールとの最短距離のポイントに自動的に設定されます。

    Tips: 自動的に点を打つので、そこを断面線の両端に設定すると、ぴったり２レールに収まる断面が描くことができます。

Evance'sEditCurvePoints>SetCPlanFor2RailSweep


作業平面を３レール以上の断面線に設定

SetCPlanToCrossSectionCurve
作業平面を３レール以上の断面線に設定

⇒

ネットワークサーフェスなどのコマンドのために、三本以上のレール曲線に対応した断面線を編集するのに最も適したＣＰｌａｎ(コンストラクション・プレーン)設定します。

操作方法:

  1. ３本以上のレール線を選択し、Enterキーを押します。
  2. それぞれの線上のポイントを順番に選択します。

    3. Tips:向きが斜めになってしまう場合は、「作業平面を回転(Z)」コマンドで調整してください。

Evance'sEditCurvePoints>SetCPlanToCrossSectionCurve(右クリック)


曲線のＺ方向の値をコピー

SetCurvesZFactor
曲線のＺ方向の値をコピー

⇒

２本の曲線の片方の曲線のワールドのＺ軸上の数値を、もう一方の曲線にコピーします。

上のようなケースの場合、２本とも編集するよりも、片側だけを、編集して、このコマンドでコピーしたほうが、効率が上がります。

操作方法:

  1. 編集したい曲線を選択します。
  2. リファレンスとなる曲線を選択します。

    Tips: なるべく、リビルトコマンドで、２本のコントロールポイントの数を揃えてから利用することをお勧めします。

    そうでない場合は、自動的にリビルドしてコントロールポイントの数を揃えます。

Evance'sEditCurvePoints>SetCurvesZFactor


曲線の長さを画面表示（マルチプル）

DisplayCurveLengths
曲線の長さを画面表示（マルチプル）

選択した複数の曲線の長さを一斉に画面上に表示します。

操作方法:

  1. 長さを表示させたい曲線を選択して、Enterキーを押します。

Evance'sEditCurvePoints>DisplayCurveLengths


曲線のノット情報を画面表示

DisplayCurveKnotInfomation
曲線のノット情報を画面表示

⇒

選択した曲線のノット情報を表示します。

この情報は、プロパティコマンドを見ても表示されない情報です。

改良版では、ノットのある位置を点で示す仕様になりました。

ライノコマンドの"Domain"コマンドと併用すると、興味深い事実が判明するでしょう。

操作方法:

  1. ノット情報を表示させたい曲線を選択して、Enterキーを押します。

    すると、コマンドライン上部に列記されます。

    ノットのある位置に点が打たれて、位置を確認できます。

Evance'sEditCurvePoints>DisplayCurveKnotInfomation（右クリック）


曲線の端点以外のコントロール点をマルチプル選択

MultipleSelPointsInvertEndEx
曲線の端点以外のコントロール点をマルチプル選択

⇒

選択した曲線の端点から、指定した数だけ外して、それ以外のコントロールポイントを一括選択してくれるコマンドです。

複数の曲線を一度に選択することができます。

操作方法:

  1. コントロールポイントの真ん中に近いポイントだけ選択したい曲線を選択します。
  2. 両端から、選択からはずしたいコントロールポイントの数を数値入力して、Enterキーを押します。

    Tips: "MoveCVPointsFromCVPintsCenter"コマンドや、"MoveCVPointsFromCenter2D"コマンドなどと、併用すると、おもしろい効果が狙えます。

    たとえば連続して配置された複数の断面線の中央部分のコントロールポイントを一括選択するなど、使い道は応用次第でいろいろと考えられるでしょう。

Evance'sEditCurvePoints>Select CurvePoint Invert End MultipleEx


曲線の端点のコントロール点を選択（マルチプル）

SelectCurveEndPoints
曲線の端点のコントロール点を選択（マルチプル）

選択した曲線の端点のコントロールポイントを一括選択してくれるコマンドです。

複数の曲線を一度に選択することができます。

操作方法:

  1. 端点のコントロールポイントを選択したい曲線を選択してEnterキーを押します。

Evance'sEditCurvePoints>SelectCurvePointInvertEnd MultipleEx（右クリック）


曲線をマルチプル回転

RotateCurve3D
曲線をマルチプル回転

⇒

複数の曲線同時に回転させることが出来ます。

開いた曲線の場合は図のように短点の二点間を軸に、閉じた曲線の場合は、始点(終点)と中点を軸に回転します。

リアルタイムで、回転の様子をシミュレーションすることができます。

回転角度もリアルタイムで表示され、数値入力も可能です。

操作方法:

  1. 回転させたい曲線を選択して、Enterキーを押します。
  2. CPlane上の適当なところをクリックして、起点にします。

    そこから、マウスを動かすと、動かす方向と距離によって、曲線の回転する様子がシミュレーションされます。

    イメージに合ったところで、クリックすると、確定されます。

    また、回転角度を入力して、Ｅｎｔｅｒキーで確定すると、数値入力として、作動します。

    Tips: このコマンドは、閉じた曲線の場合は、端点(始点と終点が同じ位置になります)と中間点を軸に作動します。

Evance'sEditCurvePoints>RotateCurve3D


パス曲線上の断面線を移動、編集（移動モード）

MoveAndEditCurveAroundPass
パス曲線上の断面線を移動、編集（移動モード）

移動ﾓｰﾄﾞ

⇒

曲線を選択して、パスカーブに対して、自在に移動させることが出来ます。

リアルタイムで、移動の様子をシミュレーションすることができます。

移動距離（直線距離です。）もリアルタイムで表示されます。

操作方法:

  1. パス曲線を選択して、Enterキーを押します。
  2. パス曲線に対して、移動させたい曲線を選択して、Enterキーを押します。

    マウスを動かすと、動かす方向と距離によって、曲線の移動する様子がシミュレーションされます。

    クリックすると、確定されます。オプションでコピーも出来ます。

    Tips: このコマンドは、直線や、極端な三次元曲線など、平面を確定しづらい曲線の場合は、パス曲線の基準点を選定する精度が下がりますので、注意してください。

Evance'sEditCurvePoints>MoveAndEditCurveAroundPass(移動モード)


パス曲線上の断面線を移動、編集（スケールモード）

MoveAndEditCurveAroundPass
パス曲線上の断面線を移動、編集（スケールモード）

拡大縮小ﾓｰﾄﾞ

⇒

曲線を選択して、パスカーブに対して、自在に拡大・縮小させることが出来ます。

リアルタイムで、拡大・縮小の様子をシミュレーションすることができます。

拡大・縮小したサイズもリアルタイムで表示され、数値入力も可能です。

操作方法:

  1. パス曲線を選択して、Enterキーを押します。
  2. パス曲線に対して、拡大・縮小させたい曲線を選択して、Enterキーを押します。

    マウスを動かすと、動かす方向と距離によって、曲線の拡大・縮小する様子がシミュレーションされます。

    クリックすると、確定されます。

    数値入力も可能です。オプションでコピーも出来ます。

    Tips: このコマンドは、直線や、極端な三次元曲線など、平面を確定しづらい曲線の場合は、パス曲線の基準点を選定する精度が下がりますので、注意してください。

Evance'sEditCurvePoints>MoveAndEditCurveAroundPass(拡大縮小モード)（右クリック）


パス曲線上の断面線を移動、編集（回転モード）

MoveAndEditCurveAroundPass
パス曲線上の断面線を移動、編集（回転モード）

回転ﾓｰﾄﾞ

⇒

曲線を選択して、パスカーブに対して、自在に回転させることが出来ます。

リアルタイムで、回転の様子をシミュレーションすることができます。

回転角度もリアルタイムで表示され、数値入力も可能です。

操作方法:

  1. パス曲線を選択して、Enterキーを押します。
  2. パス曲線に対して、回転させたい曲線を選択して、Enterキーを押します。

    マウスを動かすと、動かす方向と距離によって、曲線の回転する様子がシミュレーションされます。

    イメージに合ったところで、クリックすると、確定されます。

    回転角度を指定して数値入力も可能です。オプションでコピーも出来ます。

    Tips: このコマンドは、直線や、極端な三次元曲線など、平面を確定しづらい曲線の場合は、パス曲線の基準点を選定する精度が下がりますので、注意してください。

Evance'sEditCurvePoints>MoveAndEditCurveAroundPass(回転モード)


パス曲線上の断面線を移動、編集（リングパス上を移動モード）

MoveAndEditCurveAroundPass
パス曲線上の断面線を移動、編集（リングパス上を移動モード）

リングパス上を移動モード

⇒

リングﾞ基準円のようなパス曲線に沿って、曲線を自在に移動させることが出来ます。

このコマンドは、ワールド座標のＹ軸を軸とするリングパスに特化して、移動の際に、不要な回転や、チルトをしないように設計されています。

リアルタイムで、移動の様子をシミュレーションすることができます。

移動距離（直線距離です。）もリアルタイムで表示されます。

操作方法:

  1. パス曲線を選択して、Enterキーを押します。
  2. パス曲線に対して、移動させたい曲線を選択して、Enterキーを押します。

    マウスを動かすと、動かす方向と距離によって、曲線の移動する様子がシミュレーションされます。

    クリックすると、確定されます。オプションでコピーも出来ます。

    Tips:直線や、極端な三次元曲線など、平面を確定しづらい曲線の場合は、パス曲線の基準点を選定する精度が下がりますので、注意してください。

Evance'sEditCurvePoints>MoveAndEditCurveAroundPass(ﾘﾝｸﾞﾞﾊﾟｽ上を移動モード)


パス曲線上の断面線を移動、編集（リングパス上を移動(フリーフォーム)モード）

MoveAndEditCurveAroundPass
パス曲線上の断面線を移動、編集（リングパス上を移動(フリーフォーム)モード）

リングパス上を移動(フリーフォーム)モード

⇒

リングﾞ基準円のようなパス曲線に沿って、曲線を自在に移動させることが出来ます。

このコマンドは、ワールド座標のＹ軸を軸とするリングパスに特化して、移動の際に、不要な回転をしないように設計されています。

FFは、フリーフォームの略で、MoveCrvAroundRingPassとの違いは、パス曲線に合わせてチルトするということです。

リアルタイムで、移動の様子をシミュレーションすることができます。

移動距離（直線距離です。）もリアルタイムで表示されます。

操作方法:

  1. パス曲線を選択して、Enterキーを押します。
  2. パス曲線に対して、移動させたい曲線を選択して、Enterキーを押します。

    マウスを動かすと、動かす方向と距離によって、曲線の移動する様子がシミュレーションされます。

    クリックすると、確定されます。オプションでコピーも出来ます。

    Tips:

    直線や、極端な三次元曲線など、平面を確定しづらい曲線の場合は、パス曲線の基準点を選定する精度が下がりますので、注意してください。

Evance'sEditCurvePoints>MoveCrvAroundRingPassFF(ﾘﾝｸﾞﾊﾟｽ上を移動(ﾌﾘｰﾌｫｰﾑ)モード)（右クリック）


曲線をオフセット（マルチプル）

OffsetCurveMultiple
曲線をオフセット（マルチプル）

選択した曲線をインタラクティブにオフセットします。

サンプルピクチャーのように、複数の曲線を同時に選択して、オフセットすることが可能です。

操作方法:

  1. 曲線を選択して、Enterキーを押します。複数の曲線を選んでも、OKです。
  2. CPlane上の適当なところをクリックすると、そこを基点となり、マウスを動かすと、リアル

    タイムで曲線の変形されている結果がシミュレーションされます。

    イメージに合ったところで、左クリックして確定します。

    オフセット距離の数値入力も可能ですが、どちらの方向が、その場合はプラス方向か、

    マイナス方向か、オフセットされる方向に注意してください。

Evance'sEditCurvePoints>OffsetCurveMultiple


曲線を拡大縮小（マルチプル）

ScaleCurveMultiple
曲線を拡大縮小（マルチプル）

選択した曲線をインタラクティブにスケーリングします。

サンプルピクチャーのように、複数の曲線を同時に選択して、それぞれ曲線の中心点(曲線上の中心点ではありません)ごとにスケールリングすることが可能です。

操作方法:

  1. 曲線を選択して、Enterキーを押します。複数の曲線を選んでも、OKです。
  2. CPlane上の適当なところをクリックすると、そこを基点として、マウスを動かすと、リアル

    タイムに曲線の変形されている結果がシミュレーションされます。

    イメージに合ったところで、左クリックして確定します。

    スケール倍率の数値入力も可能です。

Evance'sEditCurvePoints>ScaleCurveMultiple(右クリック)


サーフェスのセンターパス曲線

MakeSurfaceCenterPass
サーフェスのセンターパス曲線

⇒

選択したサーフェスのﾊﾟｽ曲線を逆算して抽出します。

操作方法:

  1. サーフェスを選択して、Enterキーを押します。
  2. UVどちらかの方向を指定します。

    この際、白い矢印でUV、それぞれの方向が示されるので参考にしてください。

    Tips: このコマンドは、閉じた曲線の場合は、端点(始点と終点が同じ位置になります)と中間点を軸に作動します。

Evance'sEditCurvePoints>MakeSurfaceCenterPass


複数のエッジ曲線からセンターパス曲線

TotalAvarageCurve
複数のエッジ曲線からセンターパス曲線

⇒

ポリサーフェスのエッジ線からパス曲線を逆算して抽出します。

操作方法:

  1. 同じ向きのエッジ線をバランスに配慮して何本か選択して、Enterキーを押します。

Evance'sEditCurvePoints>TotalAvarageCurve（右クリック）


曲線にキンクを追加（高度なオプション）

EvanceInsertCurveKink
曲線にキンクを追加（高度なオプション）

⇒

曲線にキンクを追加します。

左のサンプルピクチャーのように、既存のノットの位置を表示し、ノットにアタッチする数値差の設定値

より近くなると、既存のノットと、現在のキンク追加位置を示すポイントが赤くなり、そのことを示します。

操作方法:

  1. 曲線を選択します。
  2. 曲線上をクリックすると、そこにキンクを追加します。

    既存のノット位置にノットにアタッチする数値差の設定値より近づくと、双方のポイントが赤く変わりますが、この状態で左クリックすると、既存のノット位置にキンクが追加されます。

    ノットにアタッチする数値差の設定値、および、前後にノットをずらす値もインタラクティブに設定変更が可能です。

Evance'sEditCurvePoints>EvanceInsertCurveKink


サーフェスのコントロール点のナンバーを表示

NumberSurfaceCVIndices
サーフェスのコントロール点のナンバーを表示

⇒

実は、ライノセロスは、サーフェスのコントロールポイントに、内部的に、番号を振り当てています。

これは、その番号の振り分けを表示するコマンドです。

これを見ることによって、サーフェスのUV方向や、昇順を知ることが出来ます。

上級者のモデリングをするには、是非とも知っておきたい内部データを知ることが出来るコマンドです。

操作方法:

  1. コントロールポイントのナンバリングをするサーフェスを選択して、Enterキーを押します。

    複数選択が可能です。

    Tips: ナンバーは、ドットオブジェクトとして、配置されます。

    このコマンドの右クリックは、ドットオブジェクトをデリートするコマンドになっています。

Evance'sEditSurfacePoints>NumberSurfaceCVIndices


サーフェスのコントロール点のナンバーを表示（コントロール点選択）

NumberGripOwnersCVIndices
サーフェスのコントロール点のナンバーを表示（コントロール点選択）

⇒

"NumberSurfaceCVIndices"コマンドは、サーフェスを指定しますが、このコマンドは、コントロールポイントを選択して、コマンドを実行します。

選択したコントロールポイントのナンバーのドットオブジェクトが選択された状態で表示されます。

操作方法:

  1. ナンバーを知りたいコントロールポイントを選択して、Enterキーを押します。

    Tips: ナンバーは、ドットオブジェクトとして、配置されます。

    このコマンドの右クリックは、現在のコントロールポイントの選択されている状態に更新するというコマンドになっています。

Evance'sEditSurfacePoints>NumberGripOwnersCVIndices


サーフェスのコントロール点をエッジ付近を除外して選択

SelSurfacePointsInvertEndEx
サーフェスのコントロール点をエッジ付近を除外して選択

⇒

サーフェスの端のほうから指定されたポイント数以外のポイントを選択します。

具体的な使い方としては、サーフェスの内側だけのポイントを、瞬時に選択するのに使用します。

操作方法:

  1. サーフェスを選択して、端のほうから選ばないコントロールポイントの列の数を数値入力します。

    （デフォルトは、「１」になっています。）

    Tips: "MoveSurfacePointsPartlyNormal"コマンド、"MoveSurfacePointsGradually"コマンドなどと併用すると、便利な使い方ができるでしょう。

Evance'sEditSurfacePoints>SelSurfacePointsInvertEndEx


隣接点をマルチプル選択

SelectNeighborGripsMultiple
隣接点をマルチプル選択

⇒

選択しているサーフェスポイントの拡張選択をいくつはなれた列まで選択するのか、数字を入れて、一発選択が可能なコマンドです。

新バージョンでは、ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 基準になるコントロールポイントを選択して、、Enterキーを押します。
  2. 何列周りまで選択するか、数字入力をして、Enterキーを押します。

    Tips: "MoveSurfacePointsPartlyNormal"コマンドなどと組み合わせて使うと有効でしょう。

Evance'sEditSurfacePoints>SelectNeighborGripsMultiple


隣接点のみをマルチプル選択

SelectOnlyNeighborGrips
隣接点のみをマルチプル選択

⇒

"SelSurfacePointsInvertEndEx"コマンドより、このコマンドのほうが、面白い使い道がいろいろ考えられるでしょう。

基本的に、"SelSurfacePointsInvertEndEx"コマンド同様、ポイントの拡張選択をするのですが、このコマンドは、もともと選んでいたポイントは、選択から外します。

操作方法:

  1. 基準になるコントロールポイントを選択して、、Enterキーを押します。
  2. 何列周りまで選択するか、数字入力をして、Enterキーを押します。

    Tips: "MoveSurfacePointsPartlyNormal"コマンドなどと組み合わせて使うと有効でしょう。

Evance'sEditSurfacePoints>SelectOnlyNeighborGrips（右クリック）


サーフェスのコントロール点を法線方向に移動（参照サーフェス指定）

MoveSrfPointsPN_RS
サーフェスのコントロール点を法線方向に移動（参照サーフェス指定）

⇒

サーフェスのコントロールポイントをサーフェスの法線方向、すなわち、サーフェスの垂直方向ではなく、別に選択したサーフェスの法線方向を使って、移動させます。

サーフェスの変化がリアルタイムでシミュレーションされます。

上の図では、下に配置したサーフェスの法線方向にコントロールポイントを移動させています。

新バージョンでは、ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 移動させるコントロールポイントを選択して、Enterキーを押します。
  2. つぎに、法線を利用するサーフェスを選択して、CPlane上の適当なところをクリックして、基点を決めます。

    マウスを動かすと、コントロールポイントとサーフェスの変化がリアルタイムでシミュレーションされ、移動距離もリアルタイム表示されます。

    イメージに合ったところで、クリックして、確定します。

    数値入力も可能です。

    Tips: 移動の方向が、プラス、マイナスがありますが、サーフェスの性格によって、上方向がプラスとは限りません。

    数値入力する場合は、シミュレーションしてみて、プラス、マイナスの方向がどうなっているか、確認してください。

Evance'sEditSurfacePoints>MoveSrfPointsPN_RS（右クリック）


サーフェスのコントロール点を法線方向に移動

MoveSrfPTsPartlyParamNormal
サーフェスのコントロール点を法線方向に移動

⇒

選択されだサーフェスのコントロールポイントをサーフェスの垂直方向に移動します。

"MoveSurfacePointsPartlyNormal"と違って、サーフェスのパラム値を使用するので

数多くのコントロールポイントを選択した場合でも動作が軽くスピーディです。

新バージョンでは、ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 移動させるサーフェスコントロールポイントを選択します。
  2. マウスでコンストラクションプレーンの適当なところをクリックして、そのままマウスを移動させるとインタラクティブにコントロールポイントが移動するのでクリックして確定します。

    数字入力も可能です。

Evance'sEditSurfacePoints>MoveSrfPTsPartlyParamNormal


サーフェスのコントロール点を法線方向に徐々に移動

MoveSurfacePointsGradually
サーフェスのコントロール点を法線方向に徐々に移動

⇒

選択したサーフェスポイントだけでなく、その周りのポイントも、いくつはなれたところまで影響を与えるか選択が可能で、選択した範囲のポイントまで、自身のサーフェスの垂直方向にポイント移動させます。

もちろん、周りの、離れたポイントになればなるほど、移動距離は、"Gradually"の名の通り、徐々に少なくなるように設定されています。

新バージョンでは、ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 移動させるコントロールポイントを選択して、Enterキーを押します。
  2. CPlane上の適当なところをクリックして、基点を決めます。

    オプションから影響を及ぼすコントロールポイントの数(但し100個まで)、ｽｹｰﾙｱﾚﾝｼﾞ係数(基準は'1'ですがこれより大きな数字を入れると膨らんだ感じになり、それより小さい数字ではシャープな変形になります)を指定します。

    このオプションは途中で変更可能です。

    マウスを動かすと、コントロールポイントとサーフェスの変化がリアルタイムでシミュレーションされ、移動距離もリアルタイム表示されます。

    イメージに合ったところで、クリックして、確定します。

    数値入力も可能です。

Evance'sEditSurfacePoints>MoveSurfacePointsGradually


サーフェスのコントロール点を法線方向に徐々に移動（参照サーフェス指定）

MoveSrfPointsGradually_RS
サーフェスのコントロール点を法線方向に徐々に移動（参照サーフェス指定）

⇒

サーフェスのコントロールポイントをサーフェスの法線方向、すなわち、サーフェスの垂直方向ではなく、別に選択したサーフェスの法線方向を使って、移動させますが、選択したサーフェスポイントだけでなく、その周りのポイントも、いくつはなれたところまで影響を与えるか選択が可能で、選択した範囲のポイントまで、別に選択したサーフェスの垂直方向にポイント移動させます。

サーフェスの変化がリアルタイムでシミュレーションされます。

上の図では、下に配置したサーフェスの法線方向にコントロールポイントを移動させています。

新バージョンでは、ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 移動させるコントロールポイントを選択して、Enterキーを押します。
  2. つぎに、法線を利用するサーフェスを選択して、何列目まで周囲のコントロールポイントに影響を与えるか、数値入力をして、、Enterキーを押します。

    CPlane上の適当なところをクリックして、基点を決めます。

    マウスを動かすと、コントロールポイントとサーフェスの変化がリアルタイムでシミュレーションされ、移動距離もリアルタイム表示されます。

    イメージに合ったところで、クリックして、確定します。

    数値入力も可能です。

Evance'sEditSurfacePoints>MoveSrfPointsGradually_RS（右クリック）


サーフェスのコントロール点を法線方向に移動（総合した１方向に）

MoveSurfacePointsAVector
サーフェスのコントロール点を法線方向に移動（総合した１方向に）

⇒

サーフェスのコントロールポイントをサーフェスの法線方向、すなわち、サーフェスの垂直方向に移動します。

それも、ばらばらの方向ではなく、すべての法線方向を総合した単一方向にコントロールポイントを移動します。

サーフェスの変化がリアルタイムでシミュレーションされます。

新バージョンでは、ケージ点(コントロールにサーフェスを選んだ場合)にも対応していますので、サーフェスのコントロールポイントだけでなく、ケージ点でも有効です。

操作方法:

  1. 移動させるコントロールポイントを選択して、Enterキーを押します。
  2. CPlane上の適当なところをクリックして、基点を決めます。

    マウスを動かすと、コントロールポイントとサーフェスの変化がリアルタイムでシミュレーションされ、移動距離もリアルタイム表示されます。

    イメージに合ったところで、クリックして、確定します。

    数値入力も可能です。

Evance'sEditSurfacePoints>MoveSurfacePointsAVector


コントロール点群を中心に移動

SetCVPointsBetween
コントロール点群を中心に移動

⇒

選択したサーフェスのコントロールポイントを一気にその中心を自動算出して、一点にに纏めてしまう。というコマンドです。

操作方法:

  1. 一点に集約するコントロールポイントを選択して、Enterキーを押します。

    Tips: 端のコントロールポイントの一列分を、纏めた場合だけは、コントロールポイントは、一つに集約されますが、そのほかの場合では、ただコントロールポイントが同じ位置に移動するだけのことです。"NumberSurfaceCVIndices"コマンド、"NumberGripOwnersCVIndices"コマンドを使って、コントロールポイントのナンバーの変化を確認すると、大変興味深い発見があるはずです。これは、エヴァンスユーザーでなければなかなか、知りえないであろう特権です。

Evance'sEditSurfacePoints>SetCVPointsBetween


コントロール点群を中心に移動（指定したコントロール点群の中心に）

SetCVPointsBetweenEx
コントロール点群を中心に移動（指定したコントロール点群の中心に）

⇒

選択したサーフェスのコントロールポイントを一気にその中心を自動算出して、別のコントロールポイント群の中心点に纏めてしまう。というコマンドです。

操作方法:

  1. 一点に集約するコントロールポイントを選択して、Enterキーを押します。
  2. つぎに、集約させたいポイントの周りのコントロールポイント群を選択して、Enterキーを押します。

    Tips: 端のコントロールポイントの一列分を、纏めた場合だけは、コントロールポイントは、一つに集約されますが、そのほかの場合では、ただコントロールポイントが同じ位置に移動するだけのことです。"NumberSurfaceCVIndices"コマンド、"NumberGripOwnersCVIndices"コマンドを使って、コントロールポイントのナンバーの変化を確認すると、大変興味深い発見があるはずです。これは、エヴァンスユーザーでなければ、決して、知りえないであろう特権です。

Evance'sEditSurfacePoints>SetCVPointsBetweenEx（右クリック）


オープンサーフェスをクローズ

SetCVPointsBetweenMultiple
オープンサーフェスをクローズ

⇒

ライノセラスのオフセットコマンドは、閉じたサーフェスだったものを特異点をばらけさせてオープンサーフェスにしてしまうことがままあります。

そういう場合などにこのコマンドは特に有効です。

UV方向を指定して一発で閉じたサーフェスに戻します。

操作方法:

  1. 両端のコントロール点の列を特異点にしたいサーフェスを選択します。

  2. UV方向を指定してエンターキーを押します。

    3. Tips: 端のコントロールポイントの一列分を、纏めた場合だけは、コントロールポイントは、一つに集約されますが、そのほかの場合では、ただコントロールポイントが同じ位置に移動するだけのことです。"NumberSurfaceCVIndices"コマンド、"NumberGripOwnersCVIndices"コマンドを使って、コントロールポイントのナンバーの変化を確認すると、大変興味深い発見があるはずです。これは、エヴァンスユーザーでなければなかなか、知りえないであろう特権です。

RRAP>SetCVPointsBetweenMultiple


サーフェスのコントロール点をセンターパス曲線を軸に回転

RotateSurfacePointsUV
サーフェスのコントロール点をセンターパス曲線を軸に回転

⇒

選択したサーフェスのコントロールポイントを自身のサーフェスのUまたは、V方向に中心点、および、回転軸をコントロールポイントの列毎に自動設定して、回転させるというコマンドです。

サーフェスのコントロールポイントだけでなく、ケージ点でも有効です。

操作方法:

  1. 回転させるコントロールポイントを選択します。
  2. オプションで、U,Vの切り替えがありますので、必要があれば、クリックして、切り替えます。

    切り替える必要がない場合は、そのまま、Enterキーを押します。

    CPlane上の適当なところをクリックして、基点を決めます。

    マウスを動かすと、コントロールポイントとサーフェスの変化がリアルタイムでシミュレーションされ、回転角度もリアルタイム表示されます。

    イメージに合ったところで、クリックして、確定します。

    回転角度の数値入力も可能です。

Evance'sEditSurfacePoints>RotateSurfacePointsUV


サーフェスのコントロール点を列ごとに回転

RotateSurfacePointsFlat
サーフェスのコントロール点を列ごとに回転

⇒

"RotateSurfacePointsUV"コマンドでは、パス曲線(自動的に計算されます)を軸にして回転させてしまうので、上の図のようなパス曲線に対して斜めになっているコントロールポイント列ではイメージと違う結果が生じてしまいます。

このコマンドでは、コントロールポイントの列ごとに平行にいくつものコントロールポイントの列を同時に回転させることが出来ます。

サーフェスのコントロールポイントだけでなく、ケージ点でも有効です。

操作方法:

  1. 回転させるコントロールポイント列からひとつづつコントロールポイントを選択します。
  2. オプションで、U,Vの切り替えがありますので、必要があれば、クリックして、切り替えます。

    切り替える必要がない場合は、そのまま、Enterキーを押します。

    CPlane上の適当なところをクリックして、基点を決めます。

    マウスを動かすと、コントロールポイントとサーフェスの変化がリアルタイムでシミュレーションされ、回転角度もリアルタイム表示されます。

    イメージに合ったところで、クリックして、確定します。

    回転角度の数値入力も可能です。

Evance'sEditSurfacePoints>RotateSurfacePointsFlat


サーフェスのコントロール点をセンターパス曲線を軸にスケール

ScaleSurfacePointsUV
サーフェスのコントロール点をセンターパス曲線を軸にスケール

⇒

選択したサーフェスのコントロールポイントを自身のサーフェスのUまたは、V方向に沿って、原点をコントロールポイントの列毎に自動設定して、拡大・縮小させるというコマンドです。

サーフェスのコントロールポイントだけでなく、ケージ点でも有効です。

操作方法:

  1. 拡大・縮小させるコントロールポイントを選択します。
  2. オプションで、U,Vの切り替えがありますので、必要があれば、クリックして、切り替えます。

    切り替える必要がない場合は、そのまま、Enterキーを押します。

    CPlane上の適当なところをクリックして、基点を決めます。

    マウスを動かすと、コントロールポイントとサーフェスの変化がリアルタイムでシミュレーションされ、スケールファクター（スケール倍率）もリアルタイム表示されます。

    イメージに合ったところで、クリックして、確定します。

    スケール倍率の数値入力も可能です

Evance'sEditSurfacePoints>ScaleSurfacePointsUV


サーフェスのコントロール点を列ごとに徐々にスケール

ScaleSurfacePointsGradually
サーフェスのコントロール点を列ごとに徐々にスケール

⇒

選択したサーフェスのコントロールポイントを自身のサーフェスのUまたは、V方向に沿って、原点をコントロールポイントの列毎に自動設定して、指定したコントロールポイント列だけ徐々に拡大・縮小させるというコマンドです。

サーフェスのコントロールポイントだけでなく、ケージ点でも有効です。

操作方法:

  1. 拡大・縮小させるコントロールポイントの中心の点をひとつ選択します。
  2. オプションで、U,Vの切り替えがありますので、必要があれば、クリックして、切り替えます。

    切り替える必要がない場合は、そのまま、Enterキーを押します。

    CPlane上の適当なところをクリックして、基点を決めます。

    オプションから影響を及ぼすコントロールポイントの列の数(但し片側50個まで)、ｽｹｰﾙｱﾚﾝｼﾞ係数(基準は'1'ですがこれより大きな数字を入れると反った感じになり、それより小さい数字では膨らんだ感じになります)を指定します。

    このオプションは途中で変更可能です。

    マウスを動かすと、コントロールポイントの変化がリアルタイムでシミュレーションされ、スケールファクター（スケール倍率）もリアルタイム表示されます。

    イメージに合ったところで、クリックして、確定します。

    スケール倍率の数値入力も可能です。

Evance'sEditSurfacePoints>ScaleSurfacePointsGradually


コントロール点を中心に向かって移動

MoveCVPointsToPointsCenter
コントロール点を中心に向かって移動

⇒

選択したコントロールポイント群を、選択したコントロールポイント群の中心を自動的に計算して、そこを基点として、選択したコントロールポイント群を移動させます。

サンプルピクチャーのように、複数のサーフェスポイントを同時に選択して、移動することが可能です。

サーフェスポイントのみでなく、曲線のポイントにも有効です。

ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。複数のサーフェス曲線のコントロールポイントを選んでも、OKです。
  2. CPlane上の適当なところをクリックし、そこを基点にします。このときに、「Z軸方向は無視」というオプションを選ぶことが出来ます。これを「はい」にすると、ワールド座標のZ軸方向は無視するので、平行移動する感じで移動します。

    マウスを動かすと、リアルタイムでコントロールポイントの移動結果がシミュレーションされます。イメージに合ったところで、左クリックして確定します。

    移動距離の数値入力も可能ですが、どちらの方向が、プラスなのか、マイナスなのかに注意してください。

Evance'sEditSurfacePoints>MoveCVPointsToPointsCenter


コントロール点を中心に向かって移動（オプジェクト毎）

MoveCVPtsToPtsCenter1DirEachObj
コントロール点を中心に向かって移動（オプジェクト毎）

⇒

選択したコントロールポイント群を、選択したコントロールポイント群の中心を自動的に計算して、そこを基点として、選択したコントロールポイント群を移動させます。

サンプルピクチャーのように、複数のサーフェスポイントを同時に選択して、移動することが可能です。

このコマンドは、"MoveCVPointsToPointsCenter"コマンドと違い、それぞれのコントロール点が中心に対して移動するのではなく、オブジェクト単位でコントロール点が移動しますので、形状が変化しません。

サーフェスポイントのみでなく、曲線のポイントにも有効です。

ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。複数のサーフェス曲線のコントロールポイントを選んでも、OKです。
  2. CPlane上の適当なところをクリックし、そこを基点にします。このときに、「Z軸方向は無視」というオプションを選ぶことが出来ます。これを「はい」にすると、ワールド座標のZ軸方向は無視するので、平行移動する感じで移動します。

    マウスを動かすと、リアルタイムでコントロールポイントの移動結果がシミュレーションされます。イメージに合ったところで、左クリックして確定します。

    移動距離の数値入力も可能ですが、どちらの方向が、プラスなのか、マイナスなのかに注意してください。

Evance'sEditSurfacePoints>MoveCVPtsToPtsCenter1DirEachObj(右クリック)


コントロール点をオプジェクト毎の中心に向かってに向かって移動

MoveCVPtsToPtsCenterEachObj
コントロール点をオプジェクト毎の中心に向かってに向かって移動

⇒

選択したコントロールポイント群を、選択したコントロールポイント群の中心を自動的に計算して、そこを基点として、選択したコントロールポイント群を移動させます。

サンプルピクチャーのように、複数のサーフェスポイントを同時に選択して、移動することが可能です。

このコマンドは、オブジェクト単位でそれぞれのコントロール点が中心に対して移動します。

サーフェスポイントのみでなく、曲線のポイントにも有効です。

ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。複数のサーフェス曲線のコントロールポイントを選んでも、OKです。
  2. CPlane上の適当なところをクリックし、そこを基点にします。このときに、「Z軸方向は無視」というオプションを選ぶことが出来ます。これを「はい」にすると、ワールド座標のZ軸方向は無視するので、平行移動する感じで移動します。

    マウスを動かすと、リアルタイムでコントロールポイントの移動結果がシミュレーションされます。イメージに合ったところで、左クリックして確定します。

    移動距離の数値入力も可能ですが、どちらの方向が、プラスなのか、マイナスなのかに注意してください。

Evance'sEditSurfacePoints>MoveCVPtsToPtsCenterEachObj


コントロール点を点に向かって移動

MoveCVPointsToPoint
コントロール点を点に向かって移動

選択したコントロールポイント群を、指定したポイントに対して移動させます。

サンプルピクチャーのように、複数のサーフェスのコントロールポイントを同時に選択して、移動することが可能です。

曲線のコントロールポイントでも同様に作動します。

ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。複数のサーフェス(曲線)のコントロールポイントも同時に選択可能です。
  2. マウスを左クリックして、コントロールポイント群を移動させるための原点を選びます。

    このときに、「Z軸方向は無視」というオプションを選ぶことが出来ます。これを「はい」にすると、ワールド座標のZ軸方向は無視するので、平行移動する感じで移動します。

    次に、CPlane上の適当なところをクリックすると、そこを基点として、マウスを動かすと、リアルタイムでコントロールポイントの移動結果がシミュレーションされます。イメージに合ったところで、左クリックして確定します。

    移動距離の数値入力も可能ですが、どちらの方向が、プラスなのか、マイナスなのかに注意してください。

Evance'sEditSurfacePoints>MoveCVPointsToPoint


コントロール点を点に向かって移動（オプジェクト毎）

MoveCVPointsToPoint1DirEachObj
コントロール点を点に向かって移動（オプジェクト毎）

⇒

選択したコントロールポイント群を、指定したポイントに対して移動させます。

このコマンドは、"MoveCVPointsToPoint"コマンドと違い、それぞれのコントロール点が指定した点に対して移動するのではなく、オブジェクト単位でコントロール点が移動しますので、形状が変化しません。

サンプルピクチャーのように、複数のサーフェスのコントロールポイントを同時に選択して、移動することが可能です。

曲線のコントロールポイントでも同様に作動します。

ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. 移動させるコントロールポイント群を選択して、Enterキーを押します。複数のサーフェス(曲線)のコントロールポイントも同時に選択可能です。
  2. マウスを左クリックして、コントロールポイント群を移動させるための原点を選びます。

    このときに、「Z軸方向は無視」というオプションを選ぶことが出来ます。これを「はい」にすると、ワールド座標のZ軸方向は無視するので、平行移動する感じで移動します。

    次に、CPlane上の適当なところをクリックすると、そこを基点として、マウスを動かすと、リアルタイムでコントロールポイントの移動結果がシミュレーションされます。イメージに合ったところで、左クリックして確定します。

    移動距離の数値入力も可能ですが、どちらの方向が、プラスなのか、マイナスなのかに注意してください。

Evance'sEditSurfacePoints>MoveCVPointsToPoint1DirEachObj(右クリック)


左右対称にコントロール点を移動（Ｙ軸を中心に）

MoveSurfacePointSymmetry
左右対称にコントロール点を移動（Ｙ軸を中心に）

⇒

選択した片側のサーフェスポイントを移動させると、ミラーをかけたように、左右反対のポイントをもシンメトリーに移動させるというコマンドです。

ポイントの選択を終えると、コンストラクションプレーンが、見ているままの向きに自動的に設定されるので、見たままのイメージで、左右対称にサーフェスのコントロールポイントを移動させることが出来ます。

操作方法:

  1. 移動させるコントロールポイントを選択して、Enterキーを押します。
  2. CPlaneが、見た目に垂直に設定されるので、そのまま、CPlane上の適当なところをクリックして、基点を決めます。

    マウスを移動させると、コントロールポイントが移動して、編集しているサーフェスもリアルタイムに変化するので、イメージが合ったところで、クリックして、確定します。

Evance'sEditSurfacePoints>MoveSurfacePointSymmetry


サーフェスのコントロール点のインデックスを表示

DisplaySurfaceCVIndex
サーフェスのコントロール点のインデックスを表示

選択されたサーフェスのコントロールポイントのU、V方向それぞれの番号を表示します。

操作方法:

  1. サーフェスのコントロールポイントを選択してEnterキーを押します。

    複数選択が可能です。

Evance'sEditSurfacePoints>DisplaySurfaceCVIndex


サーフェスのコントロール点をインデックスから選択

SearchSurfaceCVPoint
サーフェスのコントロール点をインデックスから選択

サーフェスのコントロールポイントのU、V方向それぞれの番号を指定して、その番号を持つサーフェスの

コントロールポイントを選択します。

操作方法:

  1. 指定するサーフェスのコントロールポイントが含まれるコントロールポイント群を選択します
  2. "i"番号(U方向)、"j"番号(V方向)を入力します。

Evance'sEditSurfacePoints>SearchSurfaceCVPoint(右クリック)


コントロール点を左右対称にミラーリング（Ｙ軸を中心に）

MirrorSurfaceCVPoints
コントロール点を左右対称にミラーリング（Ｙ軸を中心に）

⇒

ワールド軸で中心に作られた球体などのコントロールポイントを編集したサーフェスを左右対称にします。

元が球体などU方向のエッジがワールドＹ軸上にないもの、次数が３ではないものでは、うまく機能しませんので、ご注意ください。

操作方法:

  1. サーフェスを選択します。
  2. コピー方向を選択します。デフォルトでは、サンプルピクチャーのように右から左にコピーされます。

Evance'sEditSurfacePoints>MirrorSurfaceCVPoints


ＵまたはＶ方向をすべて選択（どっち？）

SelUorV
ＵまたはＶ方向をすべて選択（どっち？）

⇒

ライノセラスの「U方向をすべて選択」、「V方向をすべて選択」というコマンドをよく使うのですが、事前に「方向を分析」コマンドでUV方向を確かめておかないと、どっちだかわからなくて、適当にかけて違ったら、もともと選択していたポイントもわからなくなる。・・・という使いづらさを解消します。

新バージョンでは、トリムサーフェスはもちろん、ケージ点(コントロールにサーフェスを選んだ場合)にも対応しています。

操作方法:

  1. いくつかのコントロールポイントを選択します。
  2. UV方向をコマンドオプションから選択します。

    矢印で方向が示されるので、迷うことなく選ぶことが出来ます。

    Tips:

    このコマンドでは、UV方向が矢印で示されるので、間違うことなく選択できます。

    何気に便利なコマンドです。

    「分かっている」、エヴァンスならではのコマンドでしょう。

Evance'sEditSurfacePoints>SelUorV　コマンドの途中での割り込み可。

Evance'sEditSurfacePoints>SelUorV(右クリック)　かかっていたコマンドを中止して実行。


ポリサーフェスをサーフェス化

ReturnToSurface
ポリサーフェスをサーフェス化

⇒

ポリサーフェスを一気にシングルサーフェスにします。

ただし、当然ですが、トリムサーフェスなどマージできる条件に無いサーフェスの組み合わせでは、マージできません。

前バージョンでは、ライノの「ｻｰﾌｪｽをﾏｰｼﾞ」コマンドが一発でかからないときのように、どこのエッジをマージするのか自動判定できないときはマージできませでしたが、新バージョンでは、どんなに複雑なポリサーフェスでも自動的にサーフェス化できる部分はサーフェス化するように機能強化されました。

さらには、複数のポリサーフェスを同時に処理できる仕様になりました。

操作方法:

  1. ポリサーフェスを選択します。
  2. コマンドオプションからライノの「ｻｰﾌｪｽをﾏｰｼﾞ」コマンドと同様に、「丸み」「フィット許容差」を0から1の間で選ぶことが出来ます。

    また、「ｻﾌﾞｻｰﾌｪｽをﾅﾝﾊﾞﾘﾝｸ」を「はい」にすると、サーフェスのポリサーフェスの中での順番付けを見ることが出来ます。

    Tips:

    コントロールポイントを編集中にコントロールポイントが消滅するケース(つまりポリサーフェスになってしまったということ)に、またエクスブロードして、マージしなおすのは面倒なものです。そういう場合にこのコマンドを使うと多くの場合、サーフェスに戻りコントロールポイントがついている編集状態になるので、そのまま編集が続けられます。立方体など二通り以上の方向の組み合わせが可能な場合は、ライノ内部で決定されたサーフェスの順番で決定します。この順番は「ｻﾌﾞｻｰﾌｪｽをﾅﾝﾊﾞﾘﾝｸ」を「はい」にする事で見ることができます。

    意図しない組み合わせでサーフェス化されてしまう場合は、間違わないように面を削除するか、"MergeBreps"コマンドで必要な面だけを選択するかしてください。

    サーフェス化できないサーフェスはトリム解除された状態でコマンド終了します。

Evance'sEditSurfacePoints>ReturnToSurface


サーフェスとポリサーフェスを一括マージ

MergeBreps
サーフェスとポリサーフェスを一括マージ

⇒

ポリサーフェス、サーフェス混ぜこぜの状態で、サーフェス化できる部分をを一気にシングルサーフェスにします。

ただし、当然ですが、トリムサーフェスなどマージできる条件に無いサーフェスの組み合わせでは、マージできません。

前バージョンでは、ライノの「ｻｰﾌｪｽをﾏｰｼﾞ」コマンドが一発でかからないときのように、どこのエッジをマージするのか自動判定できないときはマージできませでしたが、新バージョンでは、どんなに複雑なポリサーフェスでも自動的にサーフェス化できる部分はサーフェス化するように機能強化されました。

さらには、複数のポリサーフェスを同時に処理できる仕様になりました。

操作方法:

  1. サーフェスおよび、ポリサーフェスを選択します。
  2. コマンドオプションからライノの「ｻｰﾌｪｽをﾏｰｼﾞ」コマンドと同様に、「丸み」「フィット許容差」を0から1の間で選ぶことが出来ます。

    また、「ｻﾌﾞｻｰﾌｪｽをﾅﾝﾊﾞﾘﾝｸ」を「はい」にすると、サーフェスのポリサーフェスの中での順番付けを見ることが出来ます。

    Tips:

    サーフェスもポリサーフェスもすべてサーフェスの集合体として一括に処理するので、元のレイヤーは保存されません。

    計算が複雑化するので、"ReturnToSurface"コマンドより処理が遅くなります。サーフェスを選択する必要がないときは、"ReturnToSurface"コマンドの方が処理が速くなります。サーフェス化できるところがひとつもない場合、何の処理も行いません。サーフェス化できるところがあった場合、できないサーフェスはトリム解除された状態でコマンド終了します。

Evance'sEditSurfacePoints>MergeBreps(右クリック)


サーフェスにエッジを生成（列ごと）

GetNeighborGripsTogetherSL
サーフェスにエッジを生成（列ごと）

⇒

サーフェスのコントロールポイントの列に沿ってエッジを作ります。

次数3のサーフェスでは、特に有効に機能します。

操作方法:

  1. サーフェスのエッジを作りたいところのコントロールポイントの列からひとつだけ選択します。
  2. コマンドオプションからエッジを作る方向を選択し、Enterキーを押します。

    Tips:

    "SL"は、"Select Line"の略です。この場合の"Line"は、CADで言う直線の意味ではなく、方向、流れを示す曲線の意味で使っています。

    コントロールポイントを選択して実行する同様の機能の"GetNeighborGripsTogether"コマンドと併用すると使い道が広がります。

Evance'sEditSurfacePoints>GetNeighborGripsTogetherSL


サーフェスにエッジを生成（ポイント単位）

GetNeighborGripsTogether
サーフェスにエッジを生成（ポイント単位）

⇒

サーフェスのコントロールポイントの列に沿ってエッジを作ります。

"GetNeighborGripsTogetherSL"コマンドでは、一列連続したエッジを作りますが、このコマンドでは、コントロールﾎﾟｲﾝﾄ単位でエッジを作るところを選択できます。

次数3のサーフェスでは、特に有効に機能します。

操作方法:

  1. サーフェスのエッジを作りたいところのコントロールポイントを選択します。
  2. コマンドオプションからエッジを作る方向を選択し、Enterキーを押します。

    Tips:

    コントロールポイントを選択して実行する同様の機能の"GetNeighborGripsTogetherSL"コマンドと併用すると使い道が広がります。

Evance'sEditSurfacePoints>GetNeighborGripsTogether(右クリック)


サーフェスをＵＶ両方向にスムーズ化

SmoozingCVPointsLooserUVDir
サーフェスをＵＶ両方向にスムーズ化

ライノセラスの「UVN移動コマンド」の「スムーズ化」の代替コマンドで、機能も基本的には同じです。

デフォルトのコマンドが、作用させるサーフェスのUV方向が閉じたシームの場合、有効に機能しないのでその代替として製作しました。

操作方法:

  1. スムーズ化させたい曲線、またはサーフェスのコントロールポイントを選択します。

    サーフェスの場合は、ＵＶ方向を選択します。

  2. マウスを移動させるとコントロールポイントが移動するのでいいところで左クリックして確定します。

    連続してコマンドを実行できますが、終了する場合は、マウスを右クリックするかEnterキーを押します。

Evance'sEditSurfacePoints>SmoozingCVPointsLooserUVDir


ヘリカルを編集

ImproveHelix
ヘリカルを編集

⇒

ヘリカルのピッチを変更します。

操作方法:

  1. ヘリカルを選択して、CPlane上の適当なところをクリックして、基点を決めます。

    マウスを移動させると、ピッチがリアルタイム時変更されるのが、シミュレーションされます。

    イメージに合ったところで、クリックして、確定します。

    Tips:

    ヘリカルは、どこにあっても構いませんが、ワールド座標のＸ軸に並行に置かれていないと、思ったような結果が得られません。

Evance'sEditCurvePoints>ImproveHelix>ImproveHelix


ヘリカルを編集（リング用Ｙ方向メイン）

ImproveHelix_Y_RingUse
ヘリカルを編集（リング用Ｙ方向メイン）

⇒

ヘリカルの中心から、両端に向かって、ワールド座標のＹ軸方向のピッチを、中心部分をピークに、徐々に、太くしていきます。

操作方法:

  1. ヘリカルを選択して、CPlane上の適当なところをクリックして、基点を決めます。

    マウスを移動させると、ピッチがリアルタイムに変更されるのが、シミュレーションされます。

    イメージに合ったところで、クリックして、確定します。

    Option:

        Direction <BothSide>:デフォルトでは、Ｙ軸の下側にしかピッチが太くなりませんか、このオプションを選択すると、両方向に太くなります。

    Tips:

    ヘリカルは、どこにあっても構いませんが、ワールド座標のＸ軸に並行に置かれていないと、思ったような結果が得られません。

Evance'sEditCurvePoints>ImproveHelix>ImproveHelix_Y_RingUse


ヘリカルを編集（リング用Ｙ方向サブ）

ImproveHelix_Y_RingUse_Ex
ヘリカルを編集（リング用Ｙ方向サブ）

⇒

ImproveHelix_Y_RingUseコマンドでできたヘリカルは、直線的に中高になってしまうのでそれを補正するコマンドです。

ヘリカルの中心から端っこの中心を中心として、ワールド座標のＹ軸方向にピッチを太くします。

操作方法:

  1. ヘリカルを選択して、CPlane上の適当なところをクリックして、基点を決めます。

    マウスを移動させると、ピッチがリアルタイム時変更されるのが、シミュレーションされます。

    イメージに合ったところで、クリックして、確定します。

    Option:

        Direction <BothSide>:デフォルトでは、Ｙ軸の下側にしかピッチが太くなりませんか、このオプションを選択すると、両方向に太くなります。

    Tips:ヘリカルは、どこにあっても構いませんが、ワールド座標のＸ軸に並行に置かれていないと、思ったような結果が得られません。

Evance'sEditCurvePoints>ImproveHelix>ImproveHelix_Y_RingUse_Ex（右クリック）


ヘリカルを編集（リング用ＹＺ方向メイン）

ImproveHelix_YZ
ヘリカルを編集（リング用ＹＺ方向メイン）

⇒

ヘリカルの中心から、両端に向かって、ワールド座標のＹ軸とＺ軸方向のピッチを、中心部分をピークに徐々に、太くしていきます。

操作方法:

  1. ヘリカルを選択して、CPlane上の適当なところをクリックして、基点を決めます。

    マウスを移動させると、ピッチがリアルタイム時変更されるのが、シミュレーションされます。

    イメージに合ったところで、クリックして、確定します。

    Option:

        Direction <BothSide>:デフォルトでは、Ｙ軸の下側にしかピッチが太くなりませんか、このオプションを選択すると、両方向に太くなります。

    Tips:ヘリカルは、どこにあっても構いませんが、ワールド座標のＸ軸に並行に置かれていないと、思ったような結果が得られません。

Evance'sEditCurvePoints>ImproveHelix>ImproveHelix_YZ


ヘリカルを編集（リング用ＹＺ方向サブ）

ImproveHelix_YZ_Ex
ヘリカルを編集（リング用ＹＺ方向サブ）

⇒

ImproveHelix_YZコマンドでできたヘリカルは、直線的に中高になってしまうのでそれを補正するコマンドです。

ヘリカルの中心から端っこの中心を中心として、ワールド座標のＹ軸と、Ｚ軸方向にピッチを太くします。

操作方法:

  1. ヘリカルを選択して、CPlane上の適当なところをクリックして、基点を決めます。

    マウスを移動させると、ピッチがリアルタイム時変更されるのが、シミュレーションされます。

    イメージに合ったところで、クリックして、確定します。

    Option:

        Direction <BothSide>:デフォルトでは、Ｙ軸の下側にしかピッチが太くなりませんか、このオプションを選択すると、両方向に太くなります。

    Tips:ヘリカルは、どこにあっても構いませんが、ワールド座標のＸ軸に並行に置かれていないと、思ったような結果が得られません。

Evance'sEditCurvePoints>ImproveHelix>ImproveHelix_YZ_Ex（右クリック）


ヘリカルを編集（リング用Ｚ方向メイン）

ImproveHelix_Z
ヘリカルを編集（リング用Ｚ方向メイン）

⇒

ヘリカルの中心から、両端に向かって、ワールド座標のＺ軸方向のピッチを、中心部分をピークに徐々に、太くしていきます。

操作方法:

  1. ヘリカルを選択して、CPlane上の適当なところをクリックして、基点を決めます。

    マウスを移動させると、ピッチがリアルタイム時変更されるのが、シミュレーションされます。

    イメージに合ったところで、クリックして、確定します。

    Tips:ヘリカルは、どこにあっても構いませんが、ワールド座標のＸ軸に並行に置かれていないと、思ったような結果が得られません。

Evance'sEditCurvePoints>ImproveHelix>ImproveHelix_Z


ヘリカルを編集（リング用Ｚ方向サブ）

ImproveHelix_Z_Ex
ヘリカルを編集（リング用Ｚ方向サブ）

⇒

ImproveHelix_Zコマンドでできたヘリカルは、直線的に中高になってしまうのでそれを補正するコマンドです。

ヘリカルの中心から端っこの中心を中心として、ワールド座標のＺ軸方向にピッチを太くします。

操作方法:

  1. ヘリカルを選択して、CPlane上の適当なところをクリックして、基点を決めます。

    マウスを移動させると、ピッチがリアルタイム時変更されるのが、シミュレーションされます。

    イメージに合ったところで、クリックして、確定します。

    Tips:ヘリカルは、どこにあっても構いませんが、ワールド座標のＸ軸に並行に置かれていないと、思ったような結果が得られません。

Evance'sEditCurvePoints>ImproveHelix>ImproveHelix_Z_Ex（右クリック）


ロックされたオブジェクトをハイド

HideLockedObjects
ロックされたオブジェクトをハイド

ロックされているオブジェクトをそのままハイドします。

操作方法:

  1. コマンドを実行します。

    Tips:

    ロックされているオブジェクトが目障りなとき、ハイドするには、一度アンロックしなければならないので、意外に面倒です。

    細かいことですが、スピードアップと気分よく使えるということが、EVANCEのコンセプトなので、対応しました。

EvanceShading >HideLockedObjects


選択したオブジェクトをシェーディング表示

ShadingIndividualObjects
選択したオブジェクトをシェーディング表示

⇒

選択したオブジェクトを画面の描画モードに関係なくシェードします。

TOPなどの画面の描画モードを変更しても無視してシェードし続けます。

操作方法:

  1. シェードしたいオブジェクトを選択して、Enterキーを押します。

EvanceShading >ShadingIndividualObjects


選択したオブジェクト以外をシェーディング表示

ShadingInvertSelectObjects
選択したオブジェクト以外をシェーディング表示

⇒

選択したオブジェクト以外のオブジェクトを画面の描画モードに関係なくシェードします。

TOPなどの画面の描画モードを変更しても無視してシェードし続けます。

このコマンドはロックされた状態のオブジェクトにも有効です。

操作方法:

  1. シェードしたくないオブジェクトを選択して、Enterキーを押します。

EvanceShading >ShadingInvertSelectObjects（右クリック）


選択したオブジェクトをワイヤーフレーム表示

UnshadingIndividualObjects
選択したオブジェクトをワイヤーフレーム表示

⇒

選択したオブジェクトを画面の描画モードに関係なくワイヤーフレーム表示します。

TOPなどの画面の描画モードを変更しても無視してワイヤーフレーム表示し続けます。

操作方法:

  1. ワイヤーフレーム表示にしたいオブジェクトを選択して、Enterキーを押します。

EvanceShading >UnshadingIndividualObjects


選択したオブジェクト以外をワイヤーフレーム表示

UnshadingInvertSelectObjects
選択したオブジェクト以外をワイヤーフレーム表示

⇒

選択していないオブジェクトを画面の描画モードに関係なくワイヤーフレーム表示します。

TOPなどの画面の描画モードを変更しても無視してワイヤーフレーム表示し続けます。

操作方法:

  1. ワイヤーフレーム表示にしたくないオブジェクトを選択して、Enterキーを押します。

EvanceShading >UnshadingInvertSelectObjects（右クリック）


選択したオブジェクトをレンダリング表示

RenderingIndividualObjects
選択したオブジェクトをレンダリング表示

選択したオブジェクトを画面の描画モードに関係なくレンダリングします。

TOPなどの画面の描画モードを変更しても無視してレンダリングし続けます。

操作方法:

  1. レンダリングしたいオブジェクトを選択して、Enterキーを押します。

EvanceShading >RenderingIndividualObjects


選択したオブジェクト以外をレンダリング表示

RenderingInvertSelectObjects
選択したオブジェクト以外をレンダリング表示

選択したオブジェクト以外のオブジェクトを画面の描画モードに関係なくレンダリングします。

TOPなどの画面をどの描画モードに変更しても無視してレンダリングし続けます。

このコマンドはロックされた状態のオブジェクトにも有効です。

操作方法:

  1. レンダリングしたくないオブジェクトを選択して、Enterキーを押します。

EvanceShading >RenderingInvertSelectObjects（右クリック）


個別の表示設定をクリア

ClearShadingIndividual
個別の表示設定をクリア

EvanceShadingタブセットの中の他のコマンド群で描画モードを個別に設定したオブジェクトの設定を解除して初期設定に戻します。

このコマンドはロックした状態のオブジェクトにも有効です。

操作方法:

  1. コマンドを実行します。

    Tips:他の人に渡すデータは、忘れずにこのコマンドで設定を解除しておきましょう。

    そうでないと、高い確率でクレームが来るかもしれません。

EvanceShading >ClearShadingIndividual


円の中心点

SeekCirclesCenterPoints
円の中心点

⇒

円の中心に点を作成します。

操作方法:

  1. 中心点に点を作る円を選択して。Enterキーを押します。

Evance'sPlugIns >SeekCirclesCenterPoints


指定点を中心に球を配置

ArraySphereAroundPoint
指定点を中心に球を配置

⇒

選択されたポイントを中心に指定したサイズの球を一括生成します。

操作方法:

  1. 球の中心になる点を選択して、Enterキーを押します。

Evance'sPlugIns >ArraySphereAroundPoint


指定円を基準に球を配置

ArraySphereBasedOnCircles
指定円を基準に球を配置

⇒

選択された円と同サイズの球を一括生成します。

操作方法:

  1. 球の基準となる円を選択して、Enterキーを押します。

Evance'sPlugIns >ArraySphereBasedOnCircles


２レールスイープの断面直線

Make2RailCrossSection
２レールスイープの断面直線

２本の曲線間に断面線を指定数生成します。

２レールスイープの断面線を作るのに便利です。

基本的には、断面線は直線で、次数は１になりますが、オプションからまっすぐな曲線(次数3) も選択可能です。

操作方法:

  1. ２本の線を選択します。

    外側、または、長い方の線から選択すると、平均的にきれいに断面線が入ります。

  2. 作りたい断面線の本数を数字入力します。オプションから、まっすぐな曲線(次数3) も選択できます。

    Tips: 始点同士、また、終点同士は、そこが、同じポイントでない限り、必ず二点をつなぐ断面線を作ります。

    調和を乱す断面線が出来ることがありますが、そういう設計によるものです。

    多めの本数で作って、都合の良いところを選んで使うのが上手な使い方です

Evance'sPlugIns>Make2RailCrossSection


２レールスイープを自動生成

Make2RailCrossSectionAuto
２レールスイープを自動生成

⇒

２本の曲線から、まるでロフトカーブのようにサーフェスを作ります。

しかし、名前が示す通り、使用しているコマンドは2レールスイープですので、複雑な曲線を

つないでも破綻しません。

操作方法:

  1. ２本のレール線を選択します。
  2. デフォルトでは、断面線は３本がほぼ等間隔に配置され、サーフェスが作られます。

    オプションから断面線の数、断面線の種類、断面線を表示するか否かを指定することができます。また、断面線を直線以外にも次数3の真っ直ぐな曲線も選択できます。

    デフォルトでは断面線が足りずにきれいなサーフェスが作れない場合には、断面線の数を増やしてその様子をシミュレーションできます。

Evance'sPlugIns>Make2RailCrossSectionAuto


独自のメソッドで中心線を抽出

AverageCurveOfEvance
独自のメソッドで中心線を抽出

日本の曲線間にアベレージ曲線を生成します。

ライノセラスの「2つの曲線間をﾄｩｲｰﾝ」コマンドと同様の機能ですが、「EVANCE EDITION」では、すでに以前のバージョンから入っていました。

ライノにデフォルトで入ったので、同じようなコマンドは廃止しましたが、これは、違う発想で、アベレージ曲線を作ります。

ライノの「2つの曲線間をﾄｩｲｰﾝ」コマンドでは、うまくいかないS字などでも破綻しません。

操作方法:

  1. ２本の線を選択します。

    外側、または、長い方の線から選択すると、平均的にきれいに断面線が入ります。

  2. コントロールポイントの数を指定する場合は、数値入力して、Enterキーを押します。

    デフォルトでは、２本の基になる曲線のうち、多いほうに合わせます。

    Tips: ライノの「2つの曲線間をﾄｩｲｰﾝ」コマンドでは、望む結果が得られない場合にお試しください。

Evance'sPlugIns>AverageCurveOfEvance


中心線を上下に立ち上げてロフト

AvarageCurveEx_Loft
中心線を上下に立ち上げてロフト

⇒

このコマンドは、ただのアベレージカーブではなく、それに指定された高さをつけたアベレージカーブを作ります。

元の２本のカーブが、閉じたり、狭くなっている場合も、自然に仕上がります。

さらには、一気にロフトしたサーフェスを自動生成します。

出来上がったサーフェスが気に入らなかったときのために、編集しなおすための曲線も同時に生成します。

操作方法:

  1. ２本の曲線を選択します。

    外側に位置するほう、または、長いほうを先に選択すると、きれいに出来ます。

  2. コントロールポイントの数を入力して、Enterキーを押します。

    デフォルトでは、２本の線のうち、多いほうに設定されます。

    元の２本のラインの両端の間隔が狭い、または、端点が重なっている場合、それを考慮した形状になりますが、オプションから「両端をｵｰﾌﾟﾝ」を選択することで元の２本のラインの両端の間隔が狭い、または、端点が重なっている場合でも、全くそれを考慮せず、同じ高さに立ち上がる設定にすることも可能です。

    その後、CPlane上の適当なところをクリックして、基点を決めて、マウスを動かすと、新しいロフト線が立ち上がります。

    位置を決めて、クリックすると、確定します。

    数値入力も可能です。

    Tips: このコマンドは、２本の曲線のアベレージカーブを立ち上げて、一気にロフトすると言うコマンドです。

    ロフトされたサーフェスがイメージに合わなかった場合はサーフェスを削除して、同時に生成されている曲線を編集して、サーフェスを張りなおすといいでしょう。

Evance'sPlugIns >AvarageCurveEx_Loft


レール曲線にフィットするように２本の曲線をスケール

ScaleCurves1DAlong2RailCurves
レール曲線にフィットするように２本の曲線をスケール

ハート形状のような外側内側の長さが異なる基準曲線に対応する内外２本の曲線を基準曲線の長さの差に応じてテーパーをつけ、曲線を自動編集、一気にサーフェスも同時生成します。

抜き型を使ってレール爪などを構成する場合に威力を発揮します。

操作方法:

  1. 図のような、カーブした２本のレール線上に内側、外側、同じ幅のサーフェスが、配置されているケースで、２本のレール線を選択します。(サーフェスエッジでも可。)
  2. 補正地を数値入力して、Enterキーを押します。

    デフォルトは、「１」になっていますが、それより大きい数字を入れると、大小のメリハリが強くつくようになります。

    「１」より小さい数字では、メリハリが弱めになります。

    ２本のレール線にまたがるように配置されているサーフェスエッジ、または、曲線を、内側、外側という風に、サーフェス毎にセットで選択していくと、つぎつぎにアレンジされたサーフェスが生成されていきます。

    Tips: このコマンドは、元の２レールの曲率が安定していないと、上手く機能しないので、リビルドコマンドなどで、その曲線のコントロールポイントのピッチをできるだけ均一にしておくことをお勧めします。(レール線は目安に使っているだけなので、本来のレール線から位置が多少ずれても全く問題ありませんのでなるべくスムーズな曲線をリファレンス曲線として使ってください。)

Evance'sPlugIns >ScaleCurves1DAlong2RailCurves


エヴァンスで生成された爪を編集

EditEvancePlong
エヴァンスで生成された爪を編集

⇒

エヴァンスのコマンドで製作した爪に対して、デフォルト設定で制御点４、次数３のコントロール曲線を生成し、爪倒しなどの変形が可能になります。(基準にするサーフェス、ポリサーフェスは不要です)

操作方法:

  1. 編集する、エヴァンスのコマンドで作った爪を選択します。
  2. コントロールの次数、コントロールポイントの数を必要があれば、変更します。

    そのままでよければ、Ｅｎｔｅｒキーを押します。

Evance'sPlugIns >EditEvancePlong


ベースBrepの法線方向にコントロールをアタッチ

EditObjectsOnBrepND
ベースBrepの法線方向にコントロールをアタッチ

⇒

サーフェス、ポリサーフェス上に配置されたオブジェクト(サーフェス、ポリサーフェス)に対して、デフォルト設定で制御点４、次数３のコントロール曲線を生成し、爪倒しなどの変形が可能になります。(基準にするサーフェス、ポリサーフェスが必要です)

操作方法:

  1. 編集する、サーフェス、または、ポリサーフェスを選択します。
  2. ベースとなるサーフェス、または、ポリサーフェスをクリックして、選択します。

    続いて、コントロールの次数、コントロールポイントの数を必要があれば、変更します。

    Tips: このコマンドは、ベースのサーフェス部分ががトリムされていて、存在しなかった場合、うまく機能しません。

    その場合は、、EditObjectsOnSurfaceNDを使用します。

Evance'sPlugIns >EditObjectsOnBrepND


ベースサーフェスの法線方向にコントロールをアタッチ

EditObjectsOnSurfaceND
ベースサーフェスの法線方向にコントロールをアタッチ

⇒

サーフェス上に配置されたオブジェクト(サーフェス、ポリサーフェス)に対して、デフォルト設定で制御点４、次数３のコントロール曲線を生成し、爪倒しなどの変形が可能になります。(基準にするサーフェスが必要です)

。

操作方法:

  1. 編集する、サーフェス、または、ポリサーフェスを選択します。
  2. ベースとなるサーフェスをクリックして、選択します。

    続いて、コントロールの次数、コントロールポイントの数を必要があれば、変更します。

    Tips: このコマンドは、ベースのサーフェス部分ががトリムされていて、存在しなかった場合でも、そこにサーフェスがあるかのように機能します。

Evance'sPlugIns >EditObjectsOnSurfaceND（右クリック）


ソリッドサーフェスにコントロールをアタッチ

EditSolidSurfaces
ソリッドサーフェスにコントロールをアタッチ

⇒

新バージョンではエヴァンスの作り出す爪は、デフォルトで閉じたシングルサーフェスで出力

される仕様に変更になりました。

このコマンドは、その閉じられたサーフェスに自動的にケージ点を設定します。

たとえば、"EditEvancePlong"コマンドでは、爪が直線的であることを想定してケージ点が

付きますが、すでに曲げてしまって、ケージコントロールの曲線もない場合には対応できません。

そういう場合にこのコマンドを使用すると、曲がったサーフェスに対応したケージ点を設定します。

操作方法:

  1. 編集する、閉じたサーフェスを選択します。
  2. コントロールの次数、コントロールポイントの数を必要があれば、変更します。

    そのままでよければ、Ｅｎｔｅｒキーを押します。

Evance'sPlugIns >EditSolidSurfaces


複数の曲線（エッジ）の中心線にコントロールをアタッチ

EditObjectByCenterPassCurve
複数の曲線（エッジ）の中心線にコントロールをアタッチ

⇒

新バージョンではエヴァンスの作り出す爪は、デフォルトで閉じたシングルサーフェスで出力

される仕様に変更になりました。

このコマンドは、その閉じられたサーフェスに自動的にケージ点を設定します。

たとえば、"EditEvancePlong"コマンドでは、爪が直線的であることを想定してケージ点が

付きますが、すでに曲げてしまって、ケージコントロールの曲線もない場合には対応できません。

そういう場合にこのコマンドを使用すると、曲がったサーフェスに対応したケージ点を設定します。

操作方法:

  1. 編集する、サーフェスまたは、ポリサーフェスを選択します。
  2. 複数のエッジ線もしくは、アイソパラム線などを合成される曲線のバランスに配慮して何本か

    選択して、Enterキーを押します。

    オプションからｺﾝﾄﾛｰﾙ曲線の次数、ｺﾝﾄﾛｰﾙﾎﾟｲﾝﾄ数、先端を検出するｾﾝｻｰの長さを設定

    可能です。

Evance'sPlugIns >EditObjectByCenterPassCurve(右クリック)


サーフェス上でオフセット（マルチプル）

OffsetCrvOnSrfMultiple
サーフェス上でオフセット（マルチプル）

⇒

ライノの"OffsetCrvOnSrf"の機能を高性能化したコマンドです。

複数の曲線を選択でき、それぞれ両方向にオフセットします。

リアルタイム表示も可能ですが、本数が多くなると、動作が重くなるのでなるべく、数値入力で使用することをお勧めします。

操作方法:

  1. オフセットする曲線を選択します。
  2. ベースとなるサーフェスを選択します。

  3. CPlan上の適当なところをクリックするか、数値入力する場合はオフセット距離を入力してEnterキーを押します。
  4. 数値入力を選ばなかった場合は、マウスを移動してクリックします。ここで数値入力する場合はオフセット距離を入力してEnterキーを押します。

Evance'sPlugIns>OffsetCrvOnSrfMultiple


丸く押し出し

EvanceExtrudeCrv
丸く押し出し

マージ可能な性質を持った丸い角を持ったサーフェスを立ち上げます。

V方向の次数は３になります。キャップの代用としても利用できます。

操作方法:

  1. 平面上にある閉じた曲線を選択します。閉じたサーフェスエッジであれば、 平面状になくてもOKですがその場合は、起ち上げる方向はベースの曲線から自動検出した方向になります。
  2. 方向と高さをマウスでピックします。数値入力も可能です。

    3. Tips:

    ベースの曲線にキンクがあるとポリサーフェスになってしまうので、"DeleteCurveKinks_Rebuild"コマンドをかけておくとコントロールポイントを操れるシングルサーフェスとして作成することができます。

Evance'sPlugIns>EvanceExtrudeCrv


球状に押し出し

EvanceExtrudeCrvByArc
球状に押し出し

マージ可能な性質を持った丸い円弧の断面を持ったサーフェスを立ち上げます。

V方向の次数は３になります。キャップの代用としても利用できます。

操作方法:

  1. 平面上にある閉じた曲線を選択します。閉じたサーフェスエッジであれば、 平面状になくてもOKですがその場合は、起ち上げる方向はベースの曲線から自動検出した方向になります。
  2. 方向と高さをマウスでピックします。数値入力も可能です。

    3. Tips: ベースの曲線にキンクがあるとポリサーフェスになってしまうので、"DeleteCurveKinks_Rebuild"コマンドをかけておくとコントロールポイントを操れるシングルサーフェスとして作成することができます。

Evance'sPlugIns>EvanceExtrudeCrvByArc（右クリック）


丸く押し出し（リビルド）

EvanceExtrudeCrvRebuild
丸く押し出し（リビルド）

⇒

マージ可能な性質を持った丸い角を持ったサーフェスを立ち上げます。V方向の次数は３になります。

キャップの代用としても利用できます。

このコマンドでは、V方向の制御点数を指定可能です。

操作方法:

  1. 閉じた曲線を選択します。閉じたサーフェスエッジでもOKです。
  2. 方向と高さをマウスでピックします。数値入力も可能です。

    オプションから制御点数を自由に変更できます。

Evance'sPlugIns>EvanceExtrudeCrvRebuild


球状に押し出し（リビルド）

EvanceExtrudeCrvByArcRebuild
球状に押し出し（リビルド）

⇒

マージ可能な性質を持った丸い円弧の断面を持ったサーフェスを立ち上げます。V方向の次数は３になります。

キャップの代用としても利用できます。

このコマンドでは、V方向の制御点数を指定可能です。

操作方法:

  1. 閉じた曲線を選択します。閉じたサーフェスエッジでもOKです。
  2. 方向と高さをマウスでピックします。数値入力も可能です。

    オプションから制御点数を自由に変更できます。

Evance'sPlugIns>EvanceExtrudeCrvByArcRebuild(右クリック)


先鋭的に押し出し（リビルド）

EvanceExtCrvStraightRebuild
先鋭的に押し出し（リビルド）

点で収束するようにテーパしながら曲線のパスをなぞり、サーフェスを作成します。

頂点は、曲線の中心地点から真上に立ち上がります。

操作方法:

  1. 閉じた平面曲線を選択します。閉じた平らなサーフェスエッジでもOKです。
  2. 方向と高さをマウスでピックします。数値入力も可能です。

    オプションから制御点数を自由に変更できます。

Evance'sPlugIns>EvanceExtCrvStraightRebuild


押し出し（閉じた曲線から次数３で）

ExtrudeCrvDegree3
押し出し（閉じた曲線から次数３で）

次数３のサーフェスを押し出します。

操作方法:

  1. 曲線を選択します。押し出す曲線がひとつだけだと方向は、自動で設定します。複数ある場合は、コンストラクションプレーンの方向に立ち上がります。
  2. 方向と高さをマウスでピックします。数値入力も可能です。

オプション

方向

任意の２点を指定することで押し出す方向を指定できます。

  1. 'D'+Enterキーを押します。その後、２点を選択して押し出す方向を決定します。
  2. 方向と高さをマウスでピックします。数値入力も可能です。二点をピックして、方向を確定します。

両方向

両方向の押し出しが可能です。

  1. 'D'+Enterキーを押します。

フラットトップ

押し出された先端の部分を平面にすることができます。

  1. 'T'+Enterキーを押します。

Evance'sPlugIns>ExtrudeCrvDegree3


それぞれの方向に押し出し（閉じた曲線から次数３で）

ExtrudeCrvDegree3MultiDir
それぞれの方向に押し出し（閉じた曲線から次数３で）

⇒

曲線を曲線に垂直にサーフェスに起ち上げます。複数の曲線を同時に選択してもそれぞれの曲線の垂直方向に起ち上げます。

操作方法:

  1. 曲線を選択します。

  2. 方向と高さをマウスでピックします。'B'+Enterで、両方向になります。

    数値入力も可能です。

Evance'sPlugIns>ExtrudeCrvDegree3MultiDir


マルチに法線方向に押し出し（閉じた曲線から次数３で）

ExtrudeCrvD3MultiDirTP
マルチに法線方向に押し出し（閉じた曲線から次数３で）

⇒

曲線をベースの(ポリ)サーフェスの法線方向に起ち上げます。複数の曲線を同時に選択してもそれぞれの曲線のベースの(ポリ)サーフェスの法線方向に起ち上げます。

操作方法:

  1. 曲線を選択します。

  2. 方向と高さをマウスでピックします。

    数値入力も可能です。

Evance'sPlugIns>ExtrudeCrvD3MultiDirTP(右クリック)


エヴァンスキャップ

EvanceCap
エヴァンスキャップ

マージ可能な性質を持ったキャップを作成します。

操作方法:

  1. 閉じた曲線を選択します。閉じたサーフェエッジでもOKです。

    Tips: ライノのキャップコマンドと違い平面上にない曲線でも選択できます。

Evance'sPlugIns>EvanceCap


エヴァンスキャップ（次数３）

EvanceCapDegree3
エヴァンスキャップ（次数３）

マージ可能な性質を持ったキャップを作成します。V方向の次数は３になります。

操作方法:

  1. 閉じた曲線を選択します。閉じたサーフェエッジでもOKです。

    Tips: ライノのキャップコマンドと違い平面上にない曲線でも選択できます。

Evance'sPlugIns>EvanceCapDegree3（右クリック）


２本の曲線間にミルを配置

MillInParallelCrosses
２本の曲線間にミルを配置

⇒

２本の曲線間に(ポリ)サーフェスを可能な限り、同じピッチで配置します。

元来は、ミル打ちコマンドとして作成しましたが、ベースサーフェス上にあるオブジェクトを変更することで、いろいろな形状のものを配置できるように汎用性が高い設計がされています。

曲線間の間隔に関わらず、元のオブジェクトと高さは同じになります。

ベースとなるサーフェスは、基本的にトリムされていない正方形または、長方形の平面を使用してください。

ここに、曲面やトリムされたサーフェスなど複雑なサーフェスを使用すると想像を超える結果になることが多いので避けるのが賢明です。

操作方法:

  1. 配置するサーフェス、またはポリサーフェスを選択します。

    つぎに、ベースとなるサーフェスを選択します。

  2. ２本の曲線を選択します。

    コマンドオプションから、反転、９０度ごとの回転、コマ数の追加、コマ数の削減を選択でき、変更は即座に反映されます。

Evance'sPlugIns>MillInParallelCrosses


ミルを配置（２、３または４エッジ曲線から）

MillOnEdgeSrf
ミルを配置（２、３または４エッジ曲線から）

⇒

2、3、または4個の開いた曲線の間に(ポリ)サーフェスをひとつだけ配置します。

元来は、ミル打ちコマンドの端打ちとして作成しましたが、ベースサーフェス上にあるオブジェクトを変更することで、いろいろな形状のものを配置できるように汎用性が高い設計がされています。

ベースとなるサーフェスは、基本的にはトリムされていない正方形または、長方形の平面を使用してください。

ここに、曲面やトリムされたサーフェスなど複雑なサーフェスを使用すると想像を超える結果になることが多いので避けるのが賢明です。

曲線間の間隔に関わらず、元のオブジェクトと高さは同じになります。

操作方法:

  1. 配置するサーフェス、またはポリサーフェスを選択します。

    つぎに、ベースとなるサーフェスを選択します。

  2. 2、3、または4個の開いた曲線を選択します。

    コマンドオプションから、反転、９０度ごとの回転を選択でき、変更は即座に反映されます。

Evance'sPlugIns>MillOnEdgeSrf（右クリック）


境界曲線を一番近い点まで押し出し

ExtrudeBrepBordersToPoints
境界曲線を一番近い点まで押し出し

⇒

サーフェス、またはポリサーフェスといったBrepオブジェクトのボーダー線から、最短距離にある点を自動的に選択して、(ポリ)サーフェスを押し出し、もとのBrepオブジェクトと結合させてソリッドオブジェクトを作ります。

上の図にあるようにボロノイによって分割されたサーフェスから抜型を作るのを主たる目的として製作しました。

目的が抜型ということでブーリアンする際に都合がいいようにソリッドオブジェクトの位置を内側にずらす機能も併せ持っています。

操作方法:

  1. 配置するサーフェス、またはポリサーフェスを選択します。

  2. 頂点となる点または点群を選択します。オプションから、完成したソリッドオブジェクトの位置を内側にずらす距離を指定できます。

Evance'sPlugIns>ExtrudeBrepBordersToPoints


閉じた曲線を一番近い点まで押し出し

ExtrudeBordersToPoints
閉じた曲線を一番近い点まで押し出し

⇒

閉じた曲線から、最短距離にある点を自動的に選択して、(ポリ)サーフェスを押し出します。

"ExtrudeBrepBordersToPoints"をアレンジしたコマンドで、目的は抜き型を作るのではなく、単純にボーダー線などの閉じた曲線と、頂点をつなぐサーフェス、またはポリサーフェスを生成します。

操作方法:

  1. 閉じた曲線群を選択します。

  2. 頂点となる点群を選択します。

Evance'sPlugIns>ExtrudeBordersToPoints(右クリック)


Brep上で移動、編集（移動モード）

MoveAndEditObjectsOnBrep
Brep上で移動、編集（移動モード）

移動モード

(ポリ)サーフェス上に配置されたオブジェクトを連続して移動することが出来ます。

一度に複数選択することも、グループ選択も可能です。

このコマンドでは、選択したオブジェクト群の、基準点を自動認識します。

さらには、ポリサーフェスを選択した場合、サーフェスの垣根を越えて、移動、または、移動コピーすることもできます。

新バージョンでは、ベースのポリサーフェスのエッジ上、または頂点にも配置できるようになり、ベースのポリサーフェスのエッジ上、または頂点に配置されたオブジェクトも再配置できるようになりました。

操作方法:

  1. 移動させたいオブジェクト（点、曲線、サーフェス、ポリサーフェス）を選択します。
  2. ベースとなるサーフェス、またはポリサーフェスを選択します。

    配置したいオブジェクトがベースのポリサーフェスのエッジ上、または頂点にある場合は、オプションで、「ｵﾝｴｯｼﾞ=はい」にしてオブジェクトがあるエッジまたは頂点を選択します。

    ベースのサーフェスの上をマウスを動かすと、移動のシミュレーションが始まります。

    コマンドオプションからコピーモードと移動モードの切り替えができ、コピーモードのときは、マウスポインタの傍に表示が出ます。

    移動させる位置をマウスがポイントしているときにクリックして、確定します。

    移動させる位置がベースのポリサーフェスのエッジ上、または頂点の場合は、オプションで、「ｵﾝｴｯｼﾞ=はい」にして、エッジまたは頂点を選択します。

    SuperTips: ポリサーフェス内のサーフェスの向きによって、所々、向きが逆になってしまう場合は、Evance'sScriptsツールバー、RRAP Toolsツールバー、Evance'sEditSurfacePointsツールバーなどの中にある"RemoveFlippedNormals"コマンドを、このコマンドの前に実行してください。

    問題が解決されるでしょう。

Evance'sScripts>MoveAndEditObjectsOnBrep 移動モード


Brep上で移動、編集（拡大縮小モード）

MoveAndEditObjectsOnBrep
Brep上で移動、編集（拡大縮小モード）

(ポリ)サーフェス上に配置したオブジェクトをサーフェスと近接位置関係を崩さずに拡大・縮小します。

リアルタイムでスケールがかかった状態と、スケール量も表示されます。

操作方法:

  1. スケールするオブジェクトを選択します。

  2. ベースのサーフェス、またはポリサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。そこからマウスを動かすと、スケールされる様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    数値入力も可能です。

    Tips:

    ポリサーフェスもベースオブジェクトとして、選択できるので便利ですが、スケールをかけるオブジェクトの中心から一番近いところのサーフェス(ポリサーフェスであれば、それに含まれるサーフェス)上の点をスケールの原点に設定し、そこを原点にしてスケールをかけるコマンドなので、移動させるオブジェクトと、ポリサーフェスの位置関係によっては、予想外な方向にスケールがかかる場合があります。

    その場合には、"MoveAndEditObjectsOnSurface"コマンドを、使用してください。

Evance'sScripts>MoveAndEditObjectsOnBrep 拡大縮小モード


Brep上で移動、編集（回転モード）

MoveAndEditObjectsOnBrep
Brep上で移動、編集（回転モード）

(ポリ)サーフェス上に配置したオブジェクト中心を基準にオブジェクトの法線軸上で回転します。

新バージョンでは、ベースのポリサーフェスのエッジ上、または頂点にあるオブジェクトでも、適切に動作します。

操作方法:

  1. 回転させるオブジェクトを選択します。

  2. ベースのサーフェス、またはポリサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。そこからマウスを動かすと、回転する様子がシミュレーションされます。

    ベースのポリサーフェスのエッジ上、または頂点にオブジェクトがある場合は、オプションで、「ｵﾝｴｯｼﾞ=はい」にしてオブジェクトがあるポリサーフェスのエッジ、または頂点を選択します。

    イメージに合ったところで、マウスを左クリックします。

    角度を数値入力することも出来ます。

    Tips:

    ポリサーフェスもベースオブジェクトとして、選択できるので便利ですが、スケールをかけるオブジェクトの中心から一番近いところのサーフェス(ポリサーフェスであれば、それに含まれるサーフェス)上の点をスケールの原点に設定し、そこを原点にしてスケールをかけるコマンドなので、移動させるオブジェクトと、ポリサーフェスの位置関係によっては、予想外な方向にスケールがかかる場合があります。

    その場合には、"MoveAndEditObjectsOnSurface"コマンドを、使用してください。

Evance'sScripts>MoveAndEditObjectsOnBrep 回転モード


Brep上で移動、編集（法線方向にスケール）

MoveAndEditObjectsOnBrep
Brep上で移動、編集（法線方向にスケール）

(ポリ)サーフェス上に配置したオブジェクトをサーフェスとの位置関係を崩さずにベースサーフェスの法線方向に拡大縮小します。

非常に分かりやすく云うと、サーフェス面に対して、太さはそのままに、長く(短く)なるというイメージです。

リアルタイムにスケール状態、スケール倍率を表示します。

数値入力も可能です。

新バージョンでは、ベースのポリサーフェスのエッジ上、または頂点にあるオブジェクトでも、適切に動作します。

操作方法:

  1. 一方向にスケールするオブジェクトを選択します。

  2. ベースのサーフェス、またはポリサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。

    ベースのポリサーフェスのエッジ上、または頂点にオブジェクトがある場合は、オプションで、「ｵﾝｴｯｼﾞ=はい」にしてオブジェクトがあるポリサーフェスのエッジ、または頂点を選択します。

    そこからマウスを動かすと、スケールされる様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    数値入力も可能です。

    Tips:

    移動させるそれぞれのオブジェクトの中心を検出し、そこからの基準のサーフェス上との最短距離地点がスケールの原点となります。

    従って、基準のサーフェスにオーバーラップして在るオブジェクトであれば、いくら小さくしても、基準のサーフェスから離れることはありません。

    ポリサーフェスも基準とするオブジェクトとして、選択できるので、便利ですが、スケールをかけるオブジェクトの中心から一番近いところのサーフェス(ポリサーフェスであれば、それに含まれるサーフェス)上の点をスケールの原点に設定し、そこを原点にしてスケールをかけるコマンドなので、スケールするオブジェクトと、ポリサーフェスの位置関係によっては、想定外な方向にスケールがかかる場合があります。

    その場合には、"MoveAndEditObjectsOnSurface"コマンドを、使用してください。

Evance'sScripts>MoveAndEditObjectsOnBrep 1Dｽｹｰﾙモード


Brep上で移動、編集（ＵＶ両方向にスケール）

MoveAndEditObjectsOnBrep
Brep上で移動、編集（ＵＶ両方向にスケール）

(ポリ)サーフェス上に配置したオブジェクトをサーフェスと位置関係を崩さずにベースサーフェスのUV両方向に2Dスケールします。

2Dスケールとは、基準になるサーフェスのUV両方向にスケールがかかるということです。

非常に分かりやすく云うと、サーフェス面に対して、長さはそのままに、太く(細く)なるというイメージです。

リアルタイムにスケール状態、スケール倍率を表示します。

数値入力も可能です。

新バージョンでは、ベースのポリサーフェスのエッジ上、または頂点にあるオブジェクトでも、適切に動作します。

操作方法:

  1. ２方向にスケールをかけるオブジェクトを選択します。

  2. ベースとなるサーフェス、またはポリサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。

    ベースのポリサーフェスのエッジ上、または頂点にオブジェクトがある場合は、オプションで、「ｵﾝｴｯｼﾞ=はい」にしてオブジェクトがあるポリサーフェスのエッジ、または頂点を選択します。

    そこからマウスを動かすと、スケールされる様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    数値入力も可能です。

    Tips:

    移動させるそれぞれのオブジェクトの中心を検出し、そこからの基準のサーフェス上との最短距離地点がスケールの原点となります。

    従って、基準のサーフェスにオーバーラップして存在するオブジェクトであれば、いくら小さくしても、基準のサーフェスから離れることはありません。

    ポリサーフェスも基準とするオブジェクトとして、選択できるので、便利ですが、スケールをかけるオブジェクトの中心から一番近いところのサーフェス(ポリサーフェスであればそれに含まれるサーフェス)上の点をスケールの原点に設定し、そこを原点にしてスケールをかけるコマンドなので、スケールするオブジェクトと、ポリサーフェスの位置関係によっては、意外な方向にスケールがかかる場合があります。

    その場合には、"MoveAndEditObjectsOnSurface"コマンドを、使用してください。

    Evance'sScripts>MoveAndEditObjectsOnBrep 2Dｽｹｰﾙモード


Brep上で移動、編集（ＵＶどちらかの方向にスケール）

MoveAndEditObjectsOnBrep
Brep上で移動、編集（ＵＶどちらかの方向にスケール）

(ポリ)サーフェス上に配置したオブジェクトをサーフェスと位置関係を崩さずにベースサーフェスのU方向、または、V方向に1Dスケールします。

リアルタイムにスケール状態、スケール倍率を表示します。

数値入力も可能です。

操作方法:

  1. ベースのサーフェスのUV方向に一方向スケールするオブジェクトを選択します。

  2. スケールをかけたいオブジェクトを選択して、Enterキーを押します。

    CPlane上の適当なところを左クリックして、起点にします。そこからマウスを動かすと、スケールされる様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    サーフェスのUV方向はコマンドオプションから切り替えます。

Evance'sScripts>MoveAndEditObjectsOnSurface UVｽｹｰﾙﾓｰﾄﾞ


Brep上で移動、編集（法線方向に移動）

MoveAndEditObjectsOnBrep
Brep上で移動、編集（法線方向に移動）

(ポリ)サーフェスの法線方向(垂直方向)に、オブジェクトを移動します。

数値入力も可能です。

リアルタイムで移動距離も表示されます。

新バージョンでは、ベースのポリサーフェスのエッジ上、または頂点にあるオブジェクトでも、適切に動作します。

操作方法:

  1. 法線方向に移動させるオブジェクトを選択します。

  2. ベースとなるサーフェス、または、ポリサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。

    ベースのポリサーフェスのエッジ上、または頂点にオブジェクトがある場合は、オプションで、「ｵﾝｴｯｼﾞ=はい」にしてオブジェクトがあるポリサーフェスのエッジ、または頂点を選択します。

    そこからマウスを動かすと、移動する様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。数値入力も可能です。

    Tips:

    ポリサーフェスも基準とするオブジェクトとして、選択できるので、便利ですが、移動させるオブジェクトの中心から一番近いサーフェス(ポリサーフェスであれば、それに含まれるサーフェス)上の点を移動の起点に設定し、その法線方向に動くコマンドなので、移動させるオブジェクトと、ポリサーフェスの位置関係によっては、想定外の方向に動く場合があります。

    その場合には、"MoveAndEditObjectsOnSurface"コマンドを、使用してください。

Evance'sScripts>MoveAndEditObjectsOnBrep 法線方向移動モード


Brep上で移動、編集（法線方向で反転）

MoveAndEditObjectsOnBrep
Brep上で移動、編集（法線方向で反転）

(ポリ)サーフェスの法線方向(垂直方向)に、オブジェクトを反転します。

操作方法:

  1. 反転させるオブジェクトを選択します。
  2. ベースとなるサーフェス、または、ポリサーフェスを選択します。

    Tips:

    ポリサーフェスも基準とするオブジェクトとして、選択できるので、便利ですが、移動させるオブジェクトの中心から一番近いサーフェス(ポリサーフェスであれば、それに含まれるサーフェス)上の点を移動の起点に設定し、その法線方向に動くコマンドなので、移動させるオブジェクトと、ポリサーフェスの位置関係によっては、想定外の方向に動く場合があります。

Evance'sScripts>MoveAndEditObjectsOnBrep 反転モード


サーフェス上で移動、編集（移動モード）

MoveAndEditObjectsOnSurface
サーフェス上で移動、編集（移動モード）

移動ﾓｰﾄﾞ

サーフェス上に配置されたオブジェクトを連続して移動することが出来ます。

一度に複数選択することも、グループ選択も可能です。

このコマンドでは、選択したオブジェクト群の、基準点を自動認識します。

操作方法:

  1. 移動させたいオブジェクト（点、曲線、サーフェス、ポリサーフェス）を選択します。
  2. ベースとなるサーフェスを選択します。

    ベースのサーフェスの上をマウスを動かすと、移動のシミュレーションが始まります。

    コマンドオプションからコピーモードと移動モードの切り替えができ、コピーモードのときは、マウスポインタの傍に表示が出ます。

    移動させる位置をマウスがポイントしているときにクリックして、確定します。

    Tips:

    このコマンドは、選択されたオブジェクトサーフェス上の基準点を自動的に検出しますが、自身で設定したいときは、"MoveObjectsToSurface"コマンドを使用します。

Evance'sScripts>MoveAndEditObjectsOnSurface 移動モード(右クリック)


サーフェス上で移動、編集（拡大縮小モード）

MoveAndEditObjectsOnSurface
サーフェス上で移動、編集（拡大縮小モード）

拡大縮小モード

サーフェス上のオブジェクトをサーフェスとの近接位置関係を崩さずにスケールします。

リアルタイムでスケールがかかった状態と、スケール量も表示されます。

数値入力も可能です。

操作方法:

  1. スケールするオブジェクトを選択します。

  2. ベースとなるサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。そこからマウスを動かすと、スケールされる様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    数値入力も可能です。

    Tips:

    移動させるそれぞれのオブジェクトの中心を検出し、そこからの基準のサーフェス上との最短距離地点がスケールの原点となります。

    従って、基準のサーフェスにオーバーラップして在るオブジェクトであれば、いくら小さくしても、基準のサーフェスから離れることはありません。

Evance'sScripts>MoveAndEditObjectsOnSurface 拡大縮小モード(右クリック)


サーフェス上で移動、編集（回転モード）

MoveAndEditObjectsOnSurface
サーフェス上で移動、編集（回転モード）

回転モード

サーフェス上に配置したオブジェクト中心を基準にオブジェクトの法線軸上で回転します。

操作方法:

  1. 回転させたいオブジェクトを選択して、Enterキーを押します。

  2. ベースとなるサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。

    そこからマウスを動かすと、回転する様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックして確定します。

    角度を数値入力することも出来ます。

Evance'sScripts>MoveAndEditObjectsOnSurfacee 回転モード(右クリック)


サーフェス上で移動、編集（法線方向にスケール）

MoveAndEditObjectsOnSurface
サーフェス上で移動、編集（法線方向にスケール）

1Dｽｹｰﾙモード

サーフェス上に配置したオブジェクトをサーフェスとの位置関係を崩さずにベースサーフェスの法線方向に拡大縮小します。

分かりやすく云うと、サーフェス面に対して、太さはそのままに、長く(短く)なるというイメージです。

リアルタイムにスケール状態、スケール倍率を表示します。

数値入力も可能です。

操作方法:

  1. 一方向スケールをかけるオブジェクトを選択します。

  2. ベースとなるサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。そこからマウスを動かすと、スケールされる様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    数値入力も可能です。

    Tips:

    移動させるそれぞれのオブジェクトの中心を検出し、そこからの基準のサーフェス上との最短距離地点がスケールの原点となります。

    従って、基準のサーフェスにオーバーラップして在るオブジェクトであれば、いくら小さくしても、基準のサーフェスから離れることはありません。

Evance'sScripts>MoveAndEditObjectsOnSurface 1Dｽｹｰﾙモード(右クリック)


サーフェス上で移動、編集（ＵＶ両方向にスケール）

MoveAndEditObjectsOnSurface
サーフェス上で移動、編集（ＵＶ両方向にスケール）

2Dｽｹｰﾙモード

サーフェス上に配置したオブジェクトをサーフェスと位置関係を崩さずにベースサーフェスのUV両方向に2Dスケールします。

2Dスケールとは、基準になるサーフェスのUV両方向にスケールがかかるということです。

非常に分かりやすく云うと、サーフェス面に対して、長さはそのままに、太く(細く)なるというイメージです。

リアルタイムにスケール状態、スケール倍率を表示します。

数値入力も可能です。

操作方法:

  1. ２方向にスケールするオブジェクトを選択します。

  2. ベースとなるサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。そこからマウスを動かすと、スケールされる様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    数値入力も可能です。

Evance'sScripts>MoveAndEditObjectsOnSurface 2Dｽｹｰﾙモード(右クリック)


サーフェス上で移動、編集（ＵＶどちらかの方向にスケール）

MoveAndEditObjectsOnSurface
サーフェス上で移動、編集（ＵＶどちらかの方向にスケール）

UVｽｹｰﾙﾓｰﾄﾞ

サーフェス上に配置したオブジェクトをサーフェスと位置関係を崩さずにベースサーフェスのU方向、または、V方向に1Dスケールします。

リアルタイムにスケール状態、スケール倍率を表示します。

数値入力も可能です。

操作方法:

  1. ベースのサーフェスのUV方向にスケールするオブジェクトを選択します。

  2. ベースとなるサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。

    そこからマウスを動かすと、スケールされる様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    サーフェスのUV方向はコマンドオプションから切り替えます。

Evance'sScripts>MoveAndEditObjectsOnSurface UVｽｹｰﾙﾓｰﾄﾞ(右クリック)


サーフェス上で移動、編集（法線方向に移動）

MoveAndEditObjectsOnSurface
サーフェス上で移動、編集（法線方向に移動）

法線方向移動モード

(ポリ)サーフェスの法線方向(垂直方向)に、オブジェクトを移動します。

数値入力も可能です。

リアルタイムで移動距離も表示されます。

操作方法:

  1. 法線方向に移動させるオブジェクトを選択します。

  2. ベースとなるサーフェスを選択します。

    CPlane上の適当なところを左クリックして、起点にします。そこからマウスを動かすと、移動する様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。数値入力も可能です。

Evance'sScripts>MoveAndEditObjectsOnSurface 法線方向移動モード(右クリック)


サーフェス上で移動（基点を指定）

MoveObjectsToSurface
サーフェス上で移動（基点を指定）

サーフェス上に配置されたオブジェクトを連続して移動することが出来ます。

一度に複数選択することも、グループ選択も可能です。

このコマンドでは選択したオブジェクト群の、基準点が自動認識されないので自身で設定します。

操作方法:

  1. ベースとなるサーフェスをクリックして、選択します。
  2. 移動させたいオブジェクト（点、曲線、サーフェス、ポリサーフェス）を選択します。

    サーフェス上で、移動の起点となるポイントをクリックして、確定します。

    ベースのサーフェスの上をマウスを動かすと、移動のシミュレーションが始まります。

    移動させる位置をマウスがポイントしているときにクリックして、確定します。

Evance'sScripts>MoveObjectsToSurface


指定点に向かって移動

ArrayObjectMoveToPoint
指定点に向かって移動

オブジェクトを任意のポイントに向かって移動させます。

数値入力も可能です。

リアルタイムで移動距離も表示されます。

操作方法:

  1. 移動させたいオブジェクトを選択して、Enterキーを押します。
  2. 移動の起点になる点を左クリックで選択します。数値入力も可能です。オプションから、「Z方向を無視」が選択可能です。

    CPlane上の適当なところを左クリックして、起点にします。

    そこからマウスを動かすと、移動する様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。数値入力も可能です。

Evance'sScripts>ArrayObjectMoveToPoint


マルチプルスケール

ScaleMultiple
マルチプルスケール

サーフェス、およびポリサーフェスをそれぞれのオブジェクトの中心を原点にしてスケールします。

リアルタイムでスケールがかかった状態と、スケール量も表示されます。

数値入力も可能です。

操作方法:

  1. スケールをかけたいサーフェス、または、ポリサーフェスを選択して、Enterキーを押します。
  2. CPlane上の適当なところを左クリックして、起点にします。そこからマウスを動かすと、スケールされる様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    数値入力も可能です。

    3. Tips:

    このコマンドは曲線には対応していません。曲線の拡大・縮小には"OffsetCurveMultiple"、"ScaleCurveMultiple"が利用できます。

Evance'sScripts>ScaleMultiple（右クリック）


サーフェス上でセットで回転

RotateSetObjectsSurfaceNormal
サーフェス上でセットで回転

サーフェス上のオブジェクトをグループの中心を中心に基点に直下のサーフェスの法線軸を中心に回転させます。

操作方法:

  1. 回転させたいオブジェクトセットを選択して、Enterキーを押します。
  2. 基準になるサーフェスを、左クリックで選択します。

    CPlane上の適当なところを左クリックして、起点にします。そこからマウスを動かすと、くるくると回転する様子がシミュレーションされます。

    イメージに合ったところで、マウスを左クリックします。

    角度を数値入力することも出来ます。

    Tips:

    選択したオブジェクト(点、曲線、サーフェス、ポリサーフェス)が、セットとして、一かたまりになって、セットの中心直下のサーフェスの法線軸を中心に回転します。

Evance'sScripts>RotateSetObjectsSurfaceNormal


指定点に移動

MoveObjectsCenterToPoint
指定点に移動

⇒

選択したオブジェクト(点、曲線、サーフェス、ポリサーフェス)を、指定したポイントに、それぞれの中心点を移動するコマンドです。

上の図では、ゼロ地点(0,0,0)を指定した例です。

操作方法:

  1. 移動させるオブジェクト(点、曲線、サーフェス、ポリサーフェス)を選択して、Enterキーを押します。

    複数の選択が可能です。

  2. 移動させたいポイントをクリックすると、そこに選択されたそれぞれのオブジェクトの中心点がポイントへと移動します。

    x,y,z値を数値入力してポイントを指定することも出来ます。

Evance'sScripts>MoveObjectsCenterToPoint


指定点にセットで移動

MoveSetObjectCenterToPoint
指定点にセットで移動

⇒

選択したオブジェクト(点、曲線、サーフェス、ポリサーフェス)セットを、指定したポイントに、全体の位置関係をそのままに、移動するコマンドです。

上の図では、ゼロ地点(0,0,0)を指定した例です。

右の図の全体を囲む立方体は、バウンディングボックスのイメージで、参考のために付け加えたものです。(実際には、存在しません。)

操作方法:

  1. 移動させるオブジェクト(点、曲線、サーフェス、ポリサーフェス)セットを選択して、Enterキーを押します。

    複数の選択が可能です。

  2. 移動させたいポイントをクリックすると、そこに選択されたオブジェクトは、位置関係は、そのままに、全体のの中心がポイントに移動します。

    x,y,z値を数値入力してポイントを指定することも出来ます。

Evance'sScripts>MoveSetObjectCenterToPoint


ランダムに移動

MoveAtRandom
ランダムに移動

⇒

選択した複数のサーフェスおよび、ポリサーフェスを指定した距離だけ任意の方向へ移動させます。

どちらに動くかは、乱数を用いて、決定されますので、どの方向に行くか、分かりません。

ブーリアンがかからないときなどに使うと有効です。

操作方法:

  1. 移動させるサーフェス、または、ポリサーフェスを選択して、Enterキーを押します。
  2. 移動距離を打ち込んで、Enterキーを押します。

    デフォルトは、0.01に設定されています。

Evance'sPlugIns>MoveAtRandom


（Ｗ）幅×（Ｄ）奥行×（Ｈ）高さを揃える

AdjustObjectLength
（Ｗ）幅×（Ｄ）奥行×（Ｈ）高さを揃える

⇒

選択した複数のオブジェクト(曲線、サーフェスおよび、ポリサーフェス、メッシュ)を基準のオブジェクト(曲線、サーフェスおよび、ポリサーフェス、メッシュ)に大きさを揃えるというコマンドです。

脅威の破壊力です。

操作方法:

  1. 基準のオブジェクト(曲線、サーフェスおよび、ポリサーフェス、メッシュ)を選択します。
  2. それに大きさを揃えるオブジェクト(曲線、サーフェスおよび、ポリサーフェス、メッシュ)を選択します。

    コマンドオプションで X方向スケール、Y方向スケール、Z方向スケール、コピーなどのオプションを選択できます。

    Tips:ほぼ、何でも出来てしまいますが、大きさを揃えるオブジェクトに平面状の曲線を選ぶとジオメトリーエラーで破損オブジェクトになるようです。

Evance'sPlugIns>AdjustObjectLength


ポリサーフェス内のサーフェスを一括スケール

ScaleFacesMultiple
ポリサーフェス内のサーフェスを一括スケール

⇒

ポリサーフェス内のサーフェスを同時に複数、それぞれのサーフェスを中心として拡大縮小します。

リアルタイムに変形された様子を表示するので、どのような結果になるか、予測しやすい仕様になっています。

さらには、複数のポリサーフェス内のサーフェスを同時に選択可能です。

操作方法:

  1. ポリサーフェス内のサーフェスを選択します。
  2. 初めに基点を決めます。次の点を選択すると中心点と基点と、中心点と次の点の距離の比率でスケールの係数が決定します。ライノの拡大縮小コマンドと同じ操作方法です。

    Tips:オプションで、「コピー」を選択すると、変形前のオブジェクトを残した状態でコマンドが終了します。

Evance'sPlugIns>ScaleFacesMultiple


ワクワクメーカー

WakuwakuMaker
ワクワクメーカー

石枠を作るダイアログボックスが出て、数値入力で、シミュレーションしながら石枠が作れます。

一段腰、二段腰、テーパーもかけることが、可能です。

爪も、下側を巻き込む設定に出来ます。

操作方法:

  1. ダイアログボックスに、数値を設定して、それぞれのボタンを押すと、設定した規格の石枠がシミュレーションされます。
  2. 終了したら、クローズボタンを押します。

Evance'sScripts>WakuwakuMaker


ワクワクメーカー（パイプ）

WakuwakuMakerByPipes
ワクワクメーカー（パイプ）

石枠を作るダイアログボックスが出て、数値入力で、シミュレーションしながら石枠が作れます。

上の図のような、パイプ枠の石枠が設計できます。

爪も、下側を巻き込む設定に出来ます。

操作方法:

  1. ダイアログボックスに、数値を設定して、それぞれのボタンを押すと、設定した規格の石枠がシミュレーションされます。
  2. 終了したら、クローズボタンを押します。

Evance'sScripts>WakuwakuMakerByPipes


インポートしたメッシュを中央に配置

LocateMeshObjectsCenter
インポートしたメッシュを中央に配置

⇒

スキャンされたSTLデータ(メッシュデータを画面(コンストラクション・プレーン)中央に配置します。

左クリックでは、ライノセラスの"SelLast"コマンドと組み合わされるため、インポートしたすぐ後に左クリックすると、そのまま中央に配置されます。

操作方法:

  1. STLデータを選択します。左クリックでSTLデータのインポート直後では、このプロセスを省くことができます。
  2. Enterキーを押します。左クリックでSTLデータのインポート直後では、このプロセスを省くことができます。

RRAP>LocateMeshObjectsCenter　直前に作成されたオブジェクトを選択してコマンドを実行。

RRAP>LocateMeshObjectsCenter(右クリック)　コマンド単体。


メッシュをオフセット(エヴァンスバージョン)

EvanceOffsetMesh
メッシュをオフセット(エヴァンスバージョン)

ダイアログボックスを出さずに迅速にメッシュをオフセットします。

移動距離が正の値の場合、サーフェスの法線方向にオフセットされます。

操作方法:

  1. メッシュを選択します。
  2. オフセット距離を入力してEnterキーを押します。

RRAP>EvanceOffsetMesh


サーフェスをメッシュにラッピング(水平面の断面指定)

MakeVANetworkSrfOrthoRebuild
サーフェスをメッシュにラッピング(水平面の断面指定)

⇒

メッシュに近似した閉じたシングル・サーフェスを生成します。

閉じたシングル・サーフェスは、その中心点のＺ軸上の上の点と下の点を特異点として設定します。

縦横のレール線は自動的に設定されますので、水平方向の断面線を選択します。

自動的に任意のコントロールポイント数にリビルドします。

操作方法:

  1. メッシュを選択します。

    必要があればオプションから設定を変更します。

  2. 水平方向の断面線を必要な数だけクリックして選択していきます。

    選び終わったら、Enterキーを押します。

RRAP>MakeVANetworkSrfOrthoRebuild


サーフェスをメッシュにラッピング(水平面の断面指定：リビルドなし)

MakeVANetworkSurfaceOrtho
サーフェスをメッシュにラッピング(水平面の断面指定：リビルドなし)

⇒

メッシュに近似した閉じたゆったりとしたシングル・サーフェスを生成します。

閉じたシングル・サーフェスは、その中心点のＺ軸上の上の点と下の点を特異点として設定します。

縦横のレール線は自動的に設定されますので、水平方向の断面線を選択します。

操作方法:

  1. メッシュを選択します。

    必要があればオプションから設定を変更します。

  2. 水平方向の断面線を必要な数だけクリックして選択していきます。

    選び終わったら、Enterキーを押します。

RRAP>MakeVANetworkSurfaceOrtho(右クリック)


サーフェスをメッシュにラッピング(垂直、水平面のフラットな断面指定)

MakeVANetworkSrfPlanerRebuild
サーフェスをメッシュにラッピング(垂直、水平面のフラットな断面指定)

⇒

ソリッドのメッシュから任意の特異点を選択し、そこを基準にレール線と断面線を設定し、それらの曲線からサーフェスを生成します。

このコマンドでは、すべての曲線は平面上の曲線になります。

操作方法:

  1. メッシュを選択し、特異点を二つ選択します。
  2. レール線を三本以上選択したら、右クリックして、断面線を一本以上選択し、Enterキーを押します。

RRAP>MakeVANetworkSrfPlanerRebuild


サーフェスをメッシュにラッピング(垂直、水平面の断面指定)

MakeVANetworkSurfaceRebuild
サーフェスをメッシュにラッピング(垂直、水平面の断面指定)

⇒

ソリッドのメッシュから任意の特異点を選択し、そこを基準にレール線と断面線を設定し、それらの曲線からサーフェスを生成します。

このコマンドでは、レール線は、メッシュの近いところに張り付く平面上にない曲線になり、断面線は平面上の曲線になります。

操作方法:

  1. メッシュを選択し、特異点を二つ選択します。
  2. レール線を三本以上選択したら、右クリックして、断面線を一本以上選択し、Enterキーを押します。

RRAP>MakeVANetworkSurfaceRebuild(右クリック)


サーフェスをメッシュにラッピング(自動)

MakeVAOffSetSurfaceDirZ
サーフェスをメッシュにラッピング(自動)

⇒

メッシュに近似した閉じたシングル・サーフェスを自動生成します。

閉じたシングル・サーフェスは、その中心点のＺ軸上の上の点と下の点を特異点として設定します。

オフセットが必要な場合はオフセット距離も設定できます。

操作方法:

  1. メッシュを選択します。

  2. オフセット距離を入力して、Enterキーを押します。

RRAP>MakeVAOffSetSurfaceDirZ


サーフェスをメッシュにラッピング(自動：二段階オフセット)

MakeDoubleVAOffSetSurfaceDirZ
サーフェスをメッシュにラッピング(自動：二段階オフセット)

⇒

メッシュに近似した閉じたシングル・サーフェスを自動生成します。

閉じたシングル・サーフェスは、その中心点のＺ軸上の上の点と下の点を特異点として設定します。

さらにそこからオフセットしたサーフェスも同時に生成します。

オフセットが必要な場合はオフセット距離も設定でき、さらにそこからまた厚みを設定できます。

操作方法:

  1. メッシュを選択します。

  2. オフセット距離と、厚みを入力して、Enterキーを押します。

RRAP>MakeDoubleVAOffSetSurfaceDirZ


コントロール点のないオブジェクトを選択から除外

UnSelectNoGripsObjects
コントロール点のないオブジェクトを選択から除外

⇒

選択されているオブジェクトのうちコントロール点以外のオブジェクトの選択を解除します。

結果として、コントロール点だけが選択された状態になります。

操作方法:

  1. コマンドを実行します。

RRAP>UnSelectNoGripsObjects


コントロール点のないオブジェクトを非表示

HideNoGripsObjects
コントロール点のないオブジェクトを非表示

⇒

表示されているオブジェクトのうち、コントロール点以外のオブジェクトをハイドします。

結果として、コントロール点が表示されているオブジェクトだけが残っているという状態になります。

操作方法:

  1. コマンドを実行します。

RRAP>HideNoGripsObjects(右クリック)


サーフェスを自動でスムーズ化(メッシュ使用)

SmoozingSurfaceOnMeshAuto
サーフェスを自動でスムーズ化(メッシュ使用)

⇒

メッシュをリファレンスとしてメッシュと近似の形状を保ったままオーバーラップなどのサーフェスの問題を取り除いてエラーのないサーフェスに自動的に修正します。

操作方法:

  1. スムーズ化するサーフェスを選択し、リファレンスのメッシュを選択します。

  2. マックスのループ数、マックスのエラー数、移動距離レシオ、閾値などのオプションを確認、または設定してEnterキーを押します。

RRAP>SmoozingSurfaceOnMeshAuto


サーフェスを自動でスムーズ化(メッシュ使用：コントロール点選択)

SmoozingCVPointsOnMeshAuto
サーフェスを自動でスムーズ化(メッシュ使用：コントロール点選択)

⇒

メッシュをリファレンスとしてメッシュと近似の形状を保ったままオーバーラップなどのサーフェスの問題を取り除いてエラーのないサーフェスに自動的に修正します。

"SmoozingSurfaceOnMeshAuto"と違うのは、サーフェス全体でなく、コントロール点単位で修正を加えたい部分を選択できるところです。

操作方法:

  1. スムーズ化するサーフェス部分コントロール点を選択し、リファレンスのメッシュを選択します。

  2. マックスのループ数、マックスのエラー数、移動距離レシオ、閾値などのオプションを確認、または設定してEnterキーを押します。

RRAP>SmoozingCVPointsOnMeshAuto(右クリック)


サーフェスを自動でスムーズ化

SmoozingSurfaceAR
サーフェスを自動でスムーズ化

⇒

サーフェスのオーバーラップなどの問題を取り除いてエラーのないサーフェスに自動的に修正します。

全体がスムーズ化されるので、サーフェスはゆるく小さくなっていきます。

操作方法:

  1. スムーズ化するサーフェスを選択します。

  2. オプションを設定して、Enterキーを押します。

RRAP>SmoozingSurfaceAR


サーフェスを自動でスムーズ化(コントロール点選択)

SmoozingCVPointsLooserAR
サーフェスを自動でスムーズ化(コントロール点選択)

⇒

サーフェスのオーバーラップなどの問題を取り除いてエラーのないサーフェスに自動的に修正します。

"SmoozingSurfaceAR"と違うのは、サーフェス全体でなく、コントロール点単位で修正を加えたい部分を選択できるところです。

選択されたコントロール点がスムーズ化されるので、その部分のサーフェスはゆるく小さくなっていきます。

操作方法:

  1. スムーズ化するサーフェス部分のコントロール点を選択します。

  2. オプションを設定して、Enterキーを押します。

RRAP>SmoozingCVPointsLooserAR(右クリック)


サーフェスをスムーズ化(エッジ点固定)

SmoozingCVPointsLooserAC
サーフェスをスムーズ化(エッジ点固定)

⇒

選択されたコントロール点をスムーズ化して、サーフェスのオーバーラップなどの問題を取り除いてエラーのないサーフェスへの修正を試みます。

選択されたコントロール点がスムーズ化されるので、その部分のサーフェスはゆるく小さくなっていきます。

このコマンドでは、特異点は、影響を受けません。

操作方法:

  1. スムーズ化するサーフェス部分のコントロール点を選択します。

  2. 前段階のターン数を設定して、Enterキーを押します。

    前段階のターン数を多く設定すればするほど一回当たりのスムーズ化は強力になります。

RRAP>SmoozingCVPointsLooserAC


サーフェスをスムーズ化(エッジ点フリー)

SmoozingCVPointsLooserAP
サーフェスをスムーズ化(エッジ点フリー)

⇒

選択されたコントロール点をスムーズ化して、サーフェスのオーバーラップなどの問題を取り除いてエラーのないサーフェスへの修正を試みます。

選択されたコントロール点がスムーズ化されるので、その部分のサーフェスはゆるく小さくなっていきます。

このコマンドでは、特異点も、スムーズ化されます。

操作方法:

  1. スムーズ化するサーフェス部分のコントロール点を選択します。

  2. 前段階のターン数を設定して、Enterキーを押します。

    前段階のターン数を多く設定すればするほど一回当たりのスムーズ化は強力になります。

RRAP>SmoozingCVPointsLooserAP(右クリック)


サーフェスをスムーズ化(Z方向)

SmoozingCVPointsDirZForGem
サーフェスをスムーズ化(Z方向)

⇒

このコマンドでは、選択されたコントロール点をワールドのＺ軸方向だけにコントロール点を移動させ、スムーズ化します。

形状の編集と同時に、サーフェスのオーバーラップなどの問題を取り除いてエラーのないサーフェスへの修正を試みます。

選択されたコントロール点がスムーズ化されるので、その部分のサーフェスはゆるく小さくなっていきます。

操作方法:

  1. スムーズ化するサーフェス部分のコントロール点を選択します。

  2. Enterキーを押します。

    繰り返しEnterキーを押しつづけることによって、希望する効果が得られるまで連続して使用できます。

RRAP>SmoozingCVPointsDirZForGem


サーフェスをスムーズ化(Z方向以外)

SmoozingCVPointsButDirZ
サーフェスをスムーズ化(Z方向以外)

このコマンドでは、選択されたコントロール点をワールドのＺ軸方向以外、すなわちＸ，Ｙ軸方向だけにコントロール点を移動させ、スムーズ化します。

形状の編集と同時に、サーフェスのオーバーラップなどの問題を取り除いてエラーのないサーフェスへの修正を試みます。

選択されたコントロール点がスムーズ化されるので、その部分のサーフェスはゆるく小さくなっていきます。

操作方法:

  1. スムーズ化するサーフェス部分のコントロール点を選択します。

  2. Enterキーを押します。

    繰り返しEnterキーを押しつづけることによって、希望する効果が得られるまで連続して使用できます。

RRAP>SmoozingCVPointsButDirZ


サーフェスをスムーズ化(V方向)

SmoozingCVPointsLooserDirV_AC
サーフェスをスムーズ化(V方向)

⇒

このコマンドでは、選択されたコントロール点をＵＶ方向のうちＶ方向だけにコントロール点を移動させ、スムーズ化します。

形状の編集と同時に、サーフェスのオーバーラップなどの問題を取り除いてエラーのないサーフェスへの修正を試みます。

選択されたコントロール点がスムーズ化されるので、その部分のサーフェスはゆるく丸まった感じになっていきます。

操作方法:

  1. スムーズ化するサーフェス部分のコントロール点を選択します。

  2. 前段階のターン数を設定して、Enterキーを押します。

    前段階のターン数を多く設定すればするほど一回当たりのスムーズ化は強力になります。

    さらに、繰り返しEnterキーを押しつづけることによって、希望する効果が得られるまで連続して使用できます。

RRAP>SmoozingCVPointsLooserDirV_AC


サーフェスを自動でスムーズ化(形状維持)

SmoozingSrfLHAuto
サーフェスを自動でスムーズ化(形状維持)

⇒

サーフェスのコントロール点を自動的に移動して、サーフェスのオーバーラップなどの問題を取り除いてエラーのないサーフェスへとスムーズ化します。

操作方法:

  1. スムーズ化するサーフェスを選択します。

  2. オプションの前段階のターン数、閾値を確認して修正する必要があれば修正し、Enterキーを押します。

    前段階のターン数を多く設定すればするほど一回当たりのスムーズ化は強力になります。

RRAP>SmoozingSrfLHAuto


サーフェスを自動でスムーズ化(形状維持：コントロール点選択)

SmoozingCVPointsLHAuto
サーフェスを自動でスムーズ化(形状維持：コントロール点選択)

⇒

サーフェスのコントロール点を自動的に移動して、サーフェスのオーバーラップなどの問題を取り除いてエラーのないサーフェスへとスムーズ化します。

操作方法:

  1. スムーズ化するサーフェス部分のコントロール点を選択します。

  2. オプションの前段階のターン数、閾値を確認して修正する必要があれば修正し、Enterキーを押します。

    前段階のターン数を多く設定すればするほど一回当たりのスムーズ化は強力になります。

RRAP>SmoozingCVPointsLHAuto(右クリック)


サーフェスを自動でスムーズ化(Brep使用)

SmoozingCVPointsOnBrepAuto
サーフェスを自動でスムーズ化(Brep使用)

⇒

サーフェスまたはポリサーフェスをリファレンスとして近似の形状を保ったままオーバーラップなどのサーフェスの問題を取り除いてエラーのないサーフェスに自動的に修正します。

サーフェスのコントロール点単位で修正を加えたい部分を選択できるます。

操作方法:

  1. スムーズ化するサーフェス部分のコントロール点を選択し、リファレンスのサーフェスまたはポリサーフェスを選択します。

  2. 一回当たりのﾙｰﾌﾟ回数、移動距離ﾚｼｵ、閾値などのオプションを確認、または設定してEnterキーを押します。

RRAP>SmoozingCVPointsOnBrepAuto


ジェムストーンにアタッチ(法線方向)

AttachSrfPointsToGEM_ND
ジェムストーンにアタッチ(法線方向)

⇒

メッシュにサーフェスを可能な限り正確にアタッチさせます。

このコマンドでは、シンプルにコントロールポイントの移動方向はサーフェス法線方向です。

操作方法:

  1. アタッチさせるサーフェス部分のコントロール点を選択します。

  2. 目標となるメッシュを選択します。

RRAP>AttachSrfPointsToGEM_ND(右クリック)


ジェムストーンにアタッチ(至近ポイント)

AttachSrfPointsToGEM_NP
ジェムストーンにアタッチ(至近ポイント)

⇒

メッシュにサーフェスを可能な限り正確にアタッチさせます。

このコマンドでも、コントロールポイントの移動方向はアタッチするサーフェス法線方向ですが、、"AttachSrfPointsToGEM_ND"とは違った計算方法でコントロールポイントを動かす方向を決定しています。

"AttachSrfPointsToGEM_MixedND"、"AttachSrfPointsToGEM_ND"コマンドが上手く機能しなかった場合に有効ですが、計算スピードは劣ります。

操作方法:

  1. アタッチさせるサーフェス部分のコントロール点を選択します。

  2. 目標となるメッシュを選択します。

RRAP>AttachSrfPointsToGEM_NP


ジェムストーンにアタッチ(Z方向)

AttachSurfacePointsDirZForGEM
ジェムストーンにアタッチ(Z方向)

⇒

メッシュにサーフェスを可能な限り正確にアタッチさせます。

このコマンドでは、ワールドのＺ軸方向にコントロールポイントを動かします。

操作方法:

  1. アタッチさせるサーフェス部分のコントロール点を選択します。

  2. 、目標となるメッシュを選択し、コントロール点の移動方向の上下を指定します。

RRAP>AttachSurfacePointsDirZForGEM(右クリック)


ジェムストーンにアタッチ(別メソッド)

AttachSurfacePointsForGEM
ジェムストーンにアタッチ(別メソッド)

⇒

メッシュにサーフェスを可能な限り正確にアタッチさせます。

このコマンドでは、"AttachSrfPointsToGEM_ND"等とは違った計算方法でコントロールポイントを動かす方向を決定しています。

"AttachSrfPointsToGEM_MixedND"、"AttachSrfPointsToGEM_ND"、さらには"AttachSrfPointsToGEM_NP"コマンドが上手く機能しなかった場合に有効ですが、計算スピードはもっとも劣ります。

操作方法:

  1. アタッチさせるサーフェス部分のコントロール点を選択します。

  2. 目標となるメッシュを選択します。

RRAP>AttachSurfacePointsForGEM


ジェムストーンにアタッチ(中心方向)

AttachSrfPointsToGEMCenter
ジェムストーンにアタッチ(中心方向)

⇒

メッシュにサーフェスを可能な限り正確にアタッチさせます。

"AttachSrfPointsToGEM_ND"等では、コントロールポイントを動かす方向をサーフェス法線方向を基準に決定していますがこのコマンドでは、名前の通りメッシュの中心方向を基準にしています。

"AttachSrfPointsToGEM_MixedND"、"AttachSrfPointsToGEM_ND"、さらには"AttachSrfPointsToGEM_NP"コマンドが上手く機能しなかった場合に使用しますが、メッシュが球形に近い形状ほど有効です。

操作方法:

  1. アタッチさせるサーフェス部分のコントロール点を選択します。

  2. 目標となるメッシュを選択します。

RRAP>AttachSrfPointsToGEMCenter(右クリック)


ジェムストーンにアタッチ(最短距離：バランスド)

AttachSrfPointsToGEM_Balanced
ジェムストーンにアタッチ(最短距離：バランスド)

⇒

メッシュにサーフェスを可能な限り正確にアタッチさせます。

"AttachSrfPointsToGEM_ND"等では、コントロールポイントを動かす方向をサーフェス法線方向を基準に決定していますがこのコマンドでは、最短距離にアタッチします。

したがいまして、サーフェスとメッシュの間の距離が大きい場合、サーフェスのノット間隔が不均一になります。

とくにデコボコした形状でサーフェスとメッシュの間の距離が大きい場合は、著しくサーフェスのノット間隔が不均一になりますので、このコマンドの使用は適しません。

操作方法:

  1. アタッチさせるサーフェス部分のコントロール点を選択します。

  2. 目標となるメッシュを選択します。

RRAP>AttachSrfPointsToGEM_Balanced


ジェムストーンにアタッチ(アベレージ)

AttachSrfPointsToGEM_ND_AV
ジェムストーンにアタッチ(アベレージ)

⇒

メッシュにサーフェスを可能な限り正確にアタッチさせます。

このコマンドでは、シンプルにコントロールポイントの移動方向は基本的にはサーフェス法線方向ですが、"AttachSrfPointsToGEM_MixedND"、"AttachSrfPointsToGEM_ND"、さらには"AttachSrfPointsToGEM_NP"コマンド、いずれとも違った計算方法で移動方向を算出します。

さらには、「移動距離ファクター」が設定できるのでこの値を小さめに設定することで他のコマンドでは難しい形状に対応します。

操作方法:

  1. アタッチさせるサーフェス部分のコントロール点を選択します。

    必要があれば、「移動距離ファクター」を設定します。「1」が標準ですが、この値を変更することで一ターン

    当たりのコントロールポイントの移動量を調整できます。

  2. 目標となるメッシュを選択します。

RRAP>AttachSrfPointsToGEM_ND_AV(右クリック)


Brepにアタッチ(法線方向)

AttachSrfPointsToBrep_ND
Brepにアタッチ(法線方向)

⇒

ターゲットとなるサーフェスまたはポリサーフェスにサーフェスを可能な限り正確にアタッチさせます。

このコマンドでは、シンプルにコントロールポイントの移動方向はアタッチするサーフェス法線方向です。

操作方法:

  1. アタッチさせるサーフェス部分のコントロール点を選択します。

  2. 目標となるサーフェスまたはポリサーフェスを選択します。

RRAP>AttachSrfPointsToBrep_ND


Brepにアタッチ(至近ポイント)

AttachSrfPointsToBrep_NP
Brepにアタッチ(至近ポイント)

⇒

ターゲットとなるサーフェスまたはポリサーフェスにサーフェスを可能な限り正確にアタッチさせます。

このコマンドでも、コントロールポイントの移動方向はアタッチするサーフェス法線方向ですが、"AttachSrfPointsToBrep_ND"とはまた違った計算方法でコントロールポイントの移動方向を決定しています。

操作方法:

  1. アタッチさせるサーフェス部分のコントロール点を選択します。

  2. 目標となるサーフェスまたはポリサーフェスを選択します。

RRAP>AttachSrfPointsToBrep_NP(右クリック)


最薄部の厚みを維持

MoveSrfPTToBrepThresholdsEx
最薄部の厚みを維持

⇒

メッシュに近似した閉じたサーフェス、さらにそこからオフセットしたサーフェスの間の厚みを指定された距離よりも不足する場合、その部分の厚みを指定された距離だけ確保します。

指定された厚み以上ある部分はその状態が維持されます。

操作方法:

  1. 厚みを確保したい部分のコントロールポイントを選択します。

  2. 基準となるサーフェスまたはポリサーフェスを選択し、メッシュを選択します。

    コントロールポイントを基準となるサーフェスまたはポリサーフェスからずらす距離を指定して、Enterキーを押します。

RRAP>MoveSrfPTToBrepThresholdsEx


最薄部の厚みを維持(Z方向)

MoveSrfPTToBrepThresholdsDirZ
最薄部の厚みを維持(Z方向)

⇒

メッシュに近似した閉じたサーフェス、さらにそこからオフセットしたサーフェスの間の厚みを指定された距離よりも不足する場合、その部分の厚みを指定された距離だけ確保します。

指定された厚み以上ある部分はその状態が維持されます。

このコマンドでは、名前の示す通りワールドのＺ軸方向のコントロールポイント移動となります。

操作方法:

  1. 厚みを確保したい部分のコントロールポイントを選択します。

  2. 基準となるサーフェスまたはポリサーフェスを選択し、メッシュを選択します。

    コントロールポイントを基準となるサーフェスまたはポリサーフェスからずらす距離を指定して、Enterキーを押します。

RRAP>MoveSrfPTToBrepThresholdsDirZ(右クリック)


厚みを維持

MoveSrfPTToBrepConstDistance
厚みを維持

⇒

もとのサーフェスからオフセットしたサーフェスの間の厚みを指定された距離に可能な限り近づけます。

"MoveSrfPTToBrepThresholdsEx"コマンドでは、指定された厚み以上ある部分はその状態が維持されますが、このコマンドではすべての選択されたコントロールポイントのサーフェス部分の厚みを一定になるようにコントロールされます。

操作方法:

  1. 厚みを確保したい部分のコントロールポイントを選択します。

  2. 基準となるサーフェスまたはポリサーフェスを選択します。

    コントロールポイントを基準となるサーフェスまたはポリサーフェスからずらす距離を指定して、Enterキーを押します。

    「向きが逆の可能性があります。このまま実行はEnterｷｰ、 反転させる場合は F(lip)ｷｰ」という警告が出た場合は、表示されている赤い矢印が、サーフェスの移動方向を示しているので、これを参考にそのままの方向でよければ、エンターキーを、方向を反転させる場合は'F'キーを押してエンターキーで確定します。

RRAP>MoveSrfPTToBrepConstDistance


コントロール点をBrepにアタッチ

MoveCVPointsToBrep
コントロール点をBrepにアタッチ

曲線、またはサーフェスのコントロールポイントを指定したサーフェス、もしくは、ポリサーフェス上にアタッチさせます。

コントロールポイントの移動方向は、対象オブジェクトとの最短距離です。

操作方法:

  1. サーフェス、もしくは、ポリサーフェス上にアタッチさせるコントロールポイントを選択して、、Enterキーを押します。
  2. 型をとりたいサーフェス、もしくは、ポリサーフェスを選択して、コントロールポイントをオフセットさせる距離を入力して、Enterキーを押します。

    Tips:

    このコマンドは、最短距離に飛びますので、たとえば、球状のサーフェスを左上の星型のポリサーフェスにアタッチさせると、右下の形状になります。(なお、分かりやすいように、それぞれの位置は、あとで、ずらしてあります。)

RRAP>MoveCVPointsToBrep


コントロール点をBrepにアタッチ(法線方向)

MoveSurfacePointsToBrep_ND
コントロール点をBrepにアタッチ(法線方向)

サーフェスのコントロールポイントを指定したサーフェス、もしくは、ポリサーフェス上に配置します。

コントロールポイントの移動方向は、サーフェスの法線方向です。

操作方法:

  1. サーフェス、もしくは、ポリサーフェス上に配置するコントロールポイントを選択して、、Enterキーを押します。
  2. 型をとりたいサーフェス、もしくは、ポリサーフェスを選択して、コントロールポイントをオフセットさせる距離を入力して、Enterキーを押します。その後、追随する距離を入力して、Enterキーを押します。

    Tips:

    このコマンドは、元のサーフェスの法線方向(サーフェスの垂直方向)にコントロールポイントが飛びます。

    従いまして、平面、または、球体などの曲率が平均化しているサーフェスでないと、変形するサーフェスと、リファレンスとなるサーフェスまたは、ポリサーフェスとの間に距離がある場合、コントロールポイントがとんでもない方向に飛んでいくので、とんでもない結果になります。たとえば、球状のサーフェスを左上の星型のポリサーフェスにアタッチさせると、右下の形状になります。(なお、分かりやすいように、それぞれの位置は、あとで、ずらしてあります。)

    尚、追随する距離だけコントロールポイントを移動するサーフェス面を探しに行っても、何もない場合は、コントロールポイントは、元の位置のままです。

RRAP>MoveSurfacePointsToBrep_ND（右クリック）


コントロール点をメッシュにアタッチ(Z方向)

MoveSurfacePointsToMeshDirZ
コントロール点をメッシュにアタッチ(Z方向)

⇒

サーフェスのコントロールポイントを指定したサーフェス、もしくは、ポリサーフェス上に配置します。

コントロールポイントの移動方向は、サーフェスの法線方向です。

操作方法:

  1. サーフェス、もしくは、ポリサーフェス上に配置するコントロールポイントを選択して、、Enterキーを押します。
  2. 型をとりたいサーフェス、もしくは、ポリサーフェスを選択して、コントロールポイントをオフセットさせる距離を入力して、Enterキーを押します。その後、追随する距離を入力して、Enterキーを押します。

    Tips:

    このコマンドは、元のサーフェスの法線方向(サーフェスの垂直方向)にコントロールポイントが飛びます。

    従いまして、平面、または、球体などの曲率が平均化しているサーフェスでないと、変形するサーフェスと、リファレンスとなるサーフェスまたは、ポリサーフェスとの間に距離がある場合、コントロールポイントがとんでもない方向に飛んでいくので、とんでもない結果になります。たとえば、球状のサーフェスを左上の星型のポリサーフェスにアタッチさせると、右下の形状になります。(なお、分かりやすいように、それぞれの位置は、あとで、ずらしてあります。)

    尚、追随する距離だけコントロールポイントを移動するサーフェス面を探しに行っても、何もない場合は、コントロールポイントは、元の位置のままです。

RRAP>MoveSurfacePointsToMeshDirZ


コントロール点をメッシュにアタッチ

MoveCVPointsToMesh
コントロール点をメッシュにアタッチ

サーフェスのコントロールポイントを指定したメッシュ上に配置します。

操作方法:

  1. メッシュ上に配置するコントロールポイントを選択して、、Enterキーを押します。
  2. 型をとりたいメッシュを選択して、コントロールポイントをオフセットさせる距離を入力して、Enterキーを押します。

    Tips:

    このコマンドは、最短距離に飛びますので、たとえば、球状のサーフェスを左上の星型のメッシュにアタッチさせると、右下の形状になります。(なお、分かりやすいように、それぞれの位置は、あとで、ずらしてあります。)

RRAP>MoveCVPointsToMesh


コントロール点をメッシュにアタッチ(法線方向)

MoveSurfacePointsToMesh_ND
コントロール点をメッシュにアタッチ(法線方向)

サーフェスのコントロールポイントを指定したメッシュ上に配置します。

操作方法:

  1. メッシュ上に配置するコントロールポイントを選択して、、Enterキーを押します。
  2. 型をとりたいメッシュを選択して、コントロールポイントをオフセットさせる距離を入力して、Enterキーを押します。その後、追随する距離を入力して、Enterキーを押します。

    Tips:

    このコマンドは、元のサーフェスの法線方向(サーフェスの垂直方向)にコントロールポイントが飛びます。

    従いまして、平面、または、球体などの曲率が平均化しているサーフェスでないと、変形するサーフェスと、リファレンスとなるサメッシュの間に距離がある場合、コントロールポイントがとんでもない方向に飛んでいくので、とんでもない結果になります。たとえば、球状のサーフェスを左上の星型のポメッシュアタッチさせると、右下の形状になります。(なお、分かりやすいように、それぞれの位置は、あとで、ずらしてあります。)

    尚、追随する距離だけコントロールポイントを移動するメッシュを探しにサーフェス面を探しに行っても、何もない場合は、コントロールポイントは、元の位置のままです。

RRAP>MoveSurfacePointsToMesh_ND（右クリック）


サーフェスをクイックリビルド

QuickRebuildSurface
サーフェスをクイックリビルド

⇒

RRAPのコマンド群でコントロール点の編集中にリビルドが必要な時、ダイアログボックスの操作に時間がかかるライノのリビルドコマンドより素早く目的のリビルドができるコマンドです。

一部でもサーフェスのコントロール点が選択されていれば、そのままリビルドコマンドが実行できます。

操作方法:

  1. リビルドしたいサーフェスのコントロール点の一部または、全部を選択する。
  2. コマンドラインから希望のUVそれぞれのコントロールポイント数を入力して、Enterキーを押します。

    Tips:

    エラーがあるコントロール点をコマンド終了時に選択しますので編集、修正の参考にしてください。

RRAP>QuickRebuildSurface


サーフェスをリビルド・リフレッシュ

RebuildAndRefleshSurface
サーフェスをリビルド・リフレッシュ

⇒

RRAPのコマンド群でコントロール点の編集中にリビルドが必要な時、ダイアログボックスの操作に時間がかかるライノのリビルドコマンドより素早く目的のリビルドができるコマンドです。

一部でもサーフェスのコントロール点が選択されていれば、そのままリビルドコマンドが実行できます。

さらにこのサーフェスでは、コントロール点にエラーがあった場合、エラーがなくなるまでコントロールポイント数を削減してエラーを回避します。

操作方法:

  1. リビルドしたいサーフェスのコントロール点の一部または、全部を選択する。
  2. コマンドラインから希望のUVそれぞれのコントロールポイント数を入力して、Enterキーを押します。

    Tips:

    エラーがあるコントロール点をコマンド終了時に選択しコントロール点にエラーがあった場合、エラーがなくなるまでコントロールポイント数を削減します。

    かなり強力なツールなので、極端な単純化が行われる場合があります。

    編集、修正の参考にしてください。

RRAP>RebuildAndRefleshSurface(右クリック)


平均的にリビルド

RebuildAveragingSurface
平均的にリビルド

⇒

ライノのリビルドコマンドより素早く目的のリビルドができるコマンドですが、このコマンドでは、UVのコントロールポイント数のバランスが悪い場合、最適なバランスになるようにUVのコントロールポイント数を調整します。

操作方法:

  1. リビルドしたいサーフェスを選択する。
  2. コマンドラインから希望のUVそれぞれのコントロールポイント数を入力して、Enterキーを押します。

    Tips:

    UVどちらかのコントロールポイント数を変更すると自動的に変更に合わせてUVそれぞれのコントロールポイント数を自動的に調整します。

    単純に指定通りのコントロールポイント数にしたい場合は"QuickRebuildSurface"コマンドを使用してください。

RRAP>RebuildAveragingSurface


平均的にリビルド(コントロール点で選択)

RebuildAveragingSrfSelectPT
平均的にリビルド(コントロール点で選択)

⇒

ライノのリビルドコマンドより素早く目的のリビルドができるコマンドですが、このコマンドでは、UVのコントロールポイント数のバランスが悪い場合、最適なバランスになるようにUVのコントロールポイント数を調整します。

このコマンドでは、サーフェスを選択するのではなく、リビルトするサーフェスのコントロールポイントを選択する仕様になっています。

操作方法:

  1. リビルドしたいサーフェスのコントロール点の一部または、全部を選択する。
  2. コマンドラインから希望のUVそれぞれのコントロールポイント数を入力して、Enterキーを押します。

    Tips:

    UVどちらかのコントロールポイント数を変更すると自動的に変更に合わせてUVそれぞれのコントロールポイント数を自動的に調整します。

    単純に指定通りのコントロールポイント数にしたい場合は"QuickRebuildSurface"コマンドを使用してください。

RRAP>RebuildAveragingSurface


カッティング曲線を生成(メッシュから)

MakeCuttingCurveFromMesh
カッティング曲線を生成(メッシュから)

⇒

選択したメッシュのワールド軸上での最大幅を表わす曲線を作ります。

操作方法:

  1. メッシュを選択します。

  2. オプションを適宜設定して、Enterキーを押します。

RRAP>MakeCuttingCurveFromMesh


厚みを表示(メッシュからサーフェス)

DisplayTicknessSurfaceToMesh
厚みを表示(メッシュからサーフェス)

⇒

サーフェスとメッシュの最短距離をリアルタイムで表示します。

クリックで、その地点の表示をテキストドットで配置します。

操作方法:

  1. サーフェスを選択します。
  2. メッシュを選択します。

    クリックすると、その地点の最短距離がテキストドットで配置されます。

RRAP>DisplayTicknessSurfaceToMesh


厚みをドット表示(メッシュからサーフェス)

PointsOnDistanceSrfToMesh
厚みをドット表示(メッシュからサーフェス)

⇒

サーフェスとメッシュの最短距離をテキストドットで配置します。

計測位置は、サーフェスのコントロールポイントのある位置になります。

操作方法:

  1. サーフェスを選択します。
  2. メッシュを選択します。

    閾値の基準となる距離を入力します。「閾値の基準となる距離」とは、オフセットが設定されている場合、そのオフセット距離です。

    閾値を入力します。閾値とは、許容できる誤差を意味します。

    閾値をはみ出している地点のテキストドットは、グリーン、イエロー、レッドで色分けされます。

    但し、この機能が適切に働くためにはエヴァンスのデフォルトのレイヤー設定がされていることが必要です。

RRAP>PointsOnDistanceSrfToMesh


誤差をドット表示(メッシュからサーフェス318×318)

PointsOnDistanceSrfToMeshHD
誤差をドット表示(メッシュからサーフェス318×318)

⇒

サーフェスとメッシュの最短距離テキストドットで配置します。

計測位置は、どのくらいのリファレンスポイント数にするか設定できます。

操作方法:

  1. サーフェスを選択します。
  2. メッシュを選択します。

    閾値の基準となる距離を入力します。「閾値の基準となる距離」とは、オフセットが設定されている場合、そのオフセット距離です。

    閾値を入力します。閾値とは、許容できる誤差を意味します。

    閾値をはみ出している地点のテキストドットは、グリーン、イエロー、レッドで色分けされます。

    但し、この機能が適切に働くためにはエヴァンスのデフォルトのレイヤー設定がされていることが必要です。

    このコマンドボタンの左クリックでは、計測地点は、U方向318箇所、V方向318箇所で、ソリッドサーフェスであっても計測点は、１０万ポイントを超えます。

    右クリックでそれぞれ、任意の数に設定可能です。

RRAP>PointsOnDistanceSrfToMeshHD 318x318

RRAP>PointsOnDistanceSrfToMeshHD(右クリック)


厚みをドット表示(サーフェスからサーフェス)

PointsOnDistanceBetween2Srf
厚みをドット表示(サーフェスからサーフェス)

⇒

サーフェスとサーフェスの最短距離テキストドットで配置します。

計測位置は、先に選択したサーフェスのコントロールポイントのある位置になります。

操作方法:

  1. ワンセットのサーフェスを選択します。
  2. 閾値を入力します。ここでの閾値とは、許容できるミニマムの厚さを意味します。

    閾値に満たない地点のテキストドットは、グリーン、イエロー、レッドで色分けされます。

    但し、この機能が適切に働くためにはエヴァンスのデフォルトのレイヤー設定がされていることが必要です。

RRAP>PointsOnDistanceBetween2Srf


誤差をドット表示(サーフェスからサーフェス)

PointsOnDistanceBetween2SrfHD
誤差をドット表示(サーフェスからサーフェス)

⇒

サーフェスとサーフェスの最短距離テキストドットで配置します。

計測位置は、どのくらいのリファレンスポイント数にするか設定できます。

操作方法:

  1. ワンセットのサーフェスを選択します。
  2. 閾値を入力します。ここでの閾値とは、許容できるミニマムの厚さを意味します。

    閾値に満たない地点のテキストドットは、グリーン、イエロー、レッドで色分けされます。

    但し、この機能が適切に働くためにはエヴァンスのデフォルトのレイヤー設定がされていることが必要です。

RRAP>PointsOnDistanceBetween2SrfHD


ドット色で選択

SelColorDot Red
ドット色で選択(赤)

レッドカラーのテキストドットを選択します。

この機能が適切に働くためにはエヴァンスのデフォルトのレイヤー設定がされていることが必要です。

操作方法:

  1. コマンドを実行します。レッドカラーになっているテキストドットは、規定の許容誤差から、0.08mm以上 の誤差が更にあるということを示しています。

    RRAP>SelColorDot Red

    SelColorDot Yellow
    ドット色で選択(黄)

    イエローカラーのテキストドットを選択します。

    この機能が適切に働くためにはエヴァンスのデフォルトのレイヤー設定がされていることが必要です。

    操作方法:

    1. コマンドを実行します。イエローカラーになっているテキストドットは、規定の許容誤差から、0.04mm以上 の誤差が更にあるということを示しています。

    RRAP>SelColorDot Yellow(右クリック)


非選択のドットを削除

DeleteUnselectecdDots
非選択のドットを削除

選択されていないテキストドットを削除します。

操作方法:

  1. コマンドを実行します。

    選択されていないテキストドットを削除するので、テキストドットでは選択されているものだけが残ります。

RRAP>DeleteUnselectecdDots


バランスの悪いコントロール点を選択

SelectSurfaceIneptCVPoints
バランスの悪いコントロール点を選択

⇒

サーフェスのコントロールポイント間隔のUV間の比率が指定したアスペクト比よりも大きいときにその部分のコントロール点を選択します。

上の例図では、アスペクト比:2でチェックしています。

操作方法:

  1. アスペクト比をチェックしたいサーフェスを選択します。
  2. 必要があれば、縦横比(アスペクト比)を変更して、Enterキーを押します。

    Tips:

    サーフェスのエッジ部分など近接点が四点に満たないコントロール点は無視されます。

RRAP>SelectSurfaceIneptCVPoints


バランスの悪いコントロール点を選択(コントロール点を選択)

SelectIneptCVPoints
バランスの悪いコントロール点を選択(コントロール点を選択)

⇒

サーフェスのコントロールポイント間隔のUV間の比率が指定したアスペクト比よりも大きいときにその部分のコントロール点を選択します。

このコマンドでは、サーフェス単位で選択するのではなく、コントロール点を選択して、そこの部分だけをチェックします。

上の例図では、アスペクト比:2でチェックしています。

操作方法:

  1. アスペクト比をチェックしたいサーフェスのコントロール点を選択します。
  2. 必要があれば、縦横比(アスペクト比)を変更して、Enterキーを押します。

    Tips:

    サーフェスのエッジ部分など近接点が四点に満たないコントロール点は無視されます。

RRAP>SelectIneptCVPoints(右クリック)


サーフェスのコントロール点をチェック

CheckSurfaceNormal
サーフェスのコントロール点をチェック

⇒

サーフェスのコントロールポイントの状態をチェックして異常な位置にあるコントロールポイントを選択します。

操作方法:

  1. チェックしたいサーフェスを選択します。
  2. 必要があれば、閾値を変更して、Enterキーを押します。

    Tips:

    通常、閾値はデフォルトのままで使用します。

    閾値を小さくするとより敏感に異常を検出します。

    逆に閾値を大きくすればするほどチェックは甘くなります。

RRAP>CheckSurfaceNormal


サーフェスのコントロール点をチェック(コントロール点で選択)

CheckSurfaceNormalSelectPT
サーフェスのコントロール点をチェック(コントロール点で選択)

⇒

サーフェスのコントロールポイントの状態をチェックして異常な位置にあるコントロールポイントを選択します。

このコマンドでは、サーフェス単位ではなく、コントロールポイント単位でチェックする対象を選択します。

操作方法:

  1. チェックしたいサーフェスのコントロールポイントを選択する。
  2. 必要があれば、閾値を変更して、Enterキーを押します。

    Tips:

    通常、閾値はデフォルトのままで使用します。

    閾値を小さくするとより敏感に異常を検出します。

    逆に閾値を大きくすればするほどチェックは甘くなります。

RRAP>CheckSurfaceNormalSelectPT(右クリック)


ダブっているコントロール点を選択

SelCVPointsInnerSurface
ダブっているコントロール点を選択

⇒

上の例図のように、他のサーフェスがオーバーラップしている状態にあるサーフェスのオーバーラップ

部分のコントロールポイントを選択します。

操作方法:

  1. チェックしたいサーフェスを選択します。
  2. 基準のサーフェスを選択します。

    選択部分を反転させる場合はF(Flip)キーを押して、そのままでよければそのまま、Enterキーを押します。

RRAP>SelCVPointsInnerSurface


メッシュ隣接点をマルチプル選択

SelectMeshNeighborGripsMulti
メッシュ隣接点をマルチプル選択

⇒

メッシュのコントロールポイントの選択範囲を拡張します。

操作方法:

  1. メッシュのコントロールポイントが選択されている状態でコマンドを実行します。

  2. 何個目までの周囲のポイントまで選択するか指定します。

    デフォルトでは'1'になっています。

RRAP_EX>SelectMeshNeighborGripsMulti


メッシュ上の点

PointsOnMesh
メッシュ上の点

メッシュ上に複数の点オブジェクトを作成します。

操作方法:

  1. 点を配置するメッシュを選択します。

  2. 点オブジェクトの位置をピックして、Enterキーを押します。

RRAP_EX>PointsOnMesh


直線とメッシュの交点

IntersectLineOnMesh
直線とメッシュの交点

⇒

直線とメッシュの交点に点を配置します。

操作方法:

  1. 直線を選択します。

  2. メッシュを選択します。

RRAP_EX>IntersectLineOnMesh


メッシュ上で補間点指定

EvanceInterpcrvOnMesh
メッシュ上で補間点指定

ライノの"InterpcrvOnSrf"(ｻｰﾌｪｽ上で補間点指定)コマンドのメッシュ版です。

メッシュ上に曲線を描くことができます。

操作方法:

  1. 曲線を描くメッシュを選択します。

    デフォルトでは、ノットの設定が周期的ユニフォーム(以下で列記している"3"です)に設定されます。

    オプションから、ノットの設定を指定できます。

    0　ユニフォーム、1 弦、2 弦の平方根、3 周期的ユニフォーム、4 周期的弦、5 周期的弦の平方根です。

  2. マウスを左クリックして、曲線を描いていきます。

    'U'キーを確定するごとに、ひとつずつアンドゥできます。

    また、閉じるには'C'ｷｰで確定します。

    途中で終了する場合はEnterキーを押します。

RRAP_EX>EvanceInterpcrvOnMesh


曲線のコントロール点をメッシュ上でドラッグ

DragCrvCVPointsOnMesh
曲線のコントロール点をメッシュ上でドラッグ

メッシュ上で曲線をメッシュから離れていかないようにコントロールポイントを移動できます。

操作方法:

  1. ベースとなるメッシュを選択します。

  2. 制御点を選択して、移動させていきますが、連続して作業できます。

    ドラッグするのではないので、マウスの左ボタンを押し続ける必要はありません。

    選択したコントロールポイントは、'D'キーを押してエンターキーで確定することでデリートすることもできます。

RRAP_EX>DragCrvCVPointsOnMesh


曲線をメッシュにアタッチ

AttachCurveToMesh
曲線をメッシュにアタッチ

⇒

曲線をメッシュ上にアタッチします。

ライノのプルコマンドと違い、密着の精度を上げるために、制御点を勝手に増やす。ということはありません。

そのため、制御点の数によっては、角の部分などは、ゆるい感じになります。

単純にコントロールポイントをメッシュ上に持ってきているというわけではなく、曲線が一番メッシュに近くなるように計算します。

操作方法:

  1. メッシュ上にアタッチさせる曲線を選択します。

    複数選択可なので、選び終わったらEnterキーを押します。

  2. メッシュを選択します。

RRAP_EX>AttachCurveToMesh


曲線とメッシュの距離

DisplayCurveToMeshDistance
曲線とメッシュの距離

⇒

曲線とメッシュとの最短距離を計測します。

操作方法:

  1. 曲線を選択します。

  2. メッシュを選択して、つぎに、サンプリング点の数を入力します。

    サンプリング場所は、ほぼ均等に配置され、デフォルトでは100箇所です。

    上の例図のように、もっとも距離が離れているところのテキストドットが選択され、選択された状態で表示されます。

RRAP_EX>DisplayCurveToMeshDistance(右クリック)


サーフェスにノットをマルチプル追加

InsertSrfKnotsMultiple
サーフェスにノットをマルチプル追加

⇒

サーフェスのノット点を一度に指定した数だけ等間隔に追加するコマンドです。

操作方法:

  1. ノットを追加するサーフェスを選択して、Enterキーを押します。
  2. オプションから追加する数を入力をして、サーフェス上で追加する場所を二点選んで確定させます。

    また、オプションで、追加する方向をU方向(U) V方向(V) UV両方向(B) から選択できます。

RRAP_EX>InsertSrfKnotsMultiple


許容誤差を指定して曲線をリビルド

RebuildCrvSpecifiedDeviation
許容誤差を指定して曲線をリビルド

⇒

曲線を指定の最大偏差の範囲内でリビルドします。

右の例図のようにポリサーフェスのボーダー線のポリラインにこのコマンドを用いて、それを立ち上げてサーフェスを作成すると右の例図のように、ポリラインをキンクのない曲線に変換しますが、デフォルトでライノセラスの許容誤差内になっているので、元のポリサーフェスとジョインした場合でも合わせ目にオーブンエッジが出現しません。

最大偏差を小さくするために増やすコントロール点は、1,000個迄でそれ以上は、対応できません。

操作方法:

  1. リビルドする曲線を選択します。
  2. オプションからサンプリングするポイントの数、最大偏差を入力をして、エンターキーを押します。

RRAP_EX>RebuildCrvSpecifiedDeviation


許容誤差を指定して曲線をリビルド(別メソッド)

RebuildCrvSpecifiedDeviation2
許容誤差を指定して曲線をリビルド(別メソッド)

⇒

曲線を指定の最大偏差の範囲内でリビルドします。

右の例図のようにポリサーフェスのボーダー線のポリラインにこのコマンドを用いて、それを立ち上げてサーフェスを作成すると右の例図のように、ポリラインをキンクのない曲線に変換しますが、デフォルトでライノセラスの許容誤差内になっているので、元のポリサーフェスとジョインした場合でも合わせ目にオーブンエッジが出現しません。

このコマンドでは、"RebuildCrvSpecifiedDeviation"とは計算方法が異なるので最大偏差を小さくするために増やすコントロール点は、1,000個を超えても対応可能です。

操作方法:

  1. リビルドする曲線を選択します。
  2. オプションからサンプリングするポイントの数、最大偏差、を入力をして、エンターキーを 押します。

    Tips:

    因みにライノセラスのリビルドコマンドでは、曲線のリビルドの場合「プレビュー」で最大偏差を確認できますが、コントロール点が"997"個以上になると表示されません。

RRAP_EX>RebuildCrvSpecifiedDeviation2


基準の曲線より上のコントロール点を垂直に揃える（Ｚ軸方向）

DressPointsAboveCurve
基準の曲線より上のコントロール点を垂直に揃える（Ｚ軸方向）

⇒

ワールドＺ方向のリファレンス曲線より上にあるサーフェスコントロールポイントを垂直に整列させます。

一番上のコントロールポイントの列は、元のコントロールポイントの一番高い点の高さに並びます。

トリムサーフェスでもトリムを維持したまま編集できます。

操作方法:

  1. リファレンス曲線（選択の閾線）を選択します。
  2. サーフェス（複数選択可能）を選択します。

RRAP_Tools>DressPointsAboveCurve


基準の曲線より上のコントロール点を選択

SelPointsAboveCurve
基準の曲線より上のコントロール点を選択

⇒

ワールドＺ方向のリファレンス曲線より上にあるサーフェスコントロールポイントを選択します。

操作方法:

  1. リファレンス曲線（選択の閾線）を選択します。
  2. サーフェス（複数選択可能）を選択します。

RRAP_Tools>SelPointsAboveCurve(右クリック)


コントロール点の高さを揃える（Ｚ方向）

MoveSurfacePointsAverageDirZ
コントロール点の高さを揃える（Ｚ方向）

⇒

選択されたコントロールポイントの高さをワールドＺ方向で揃えます。

その高さは、選択されたうちで最も高いコントロールポイントに合わされます。

操作方法:

  1. コントロールポイント群を選択して、Enterキーを押します。

RRAP_Tools>MoveSurfacePointsAverageDirZ


サーフェスのコントロール点のエッジを選択

SelSurfaceEdgePoints
サーフェスのコントロール点のエッジを選択

⇒

サーフェスのエッジ部分のコントロールポイントを選択します。

操作方法:

  1. サーフェスを選択して、Enterキーを押します。
  2. コマンドオプションからＵ方向、Ｖ方向、ＵＶ両方の中から方向を選択します。

RRAP_Tools>SelSurfaceEdgePoints


サーフェスのエッジ以外のコントロール点を選択

SelSurfacePointsExceptEdge
サーフェスのエッジ以外のコントロール点を選択

⇒

"SelSurfaceEdgePoints"コマンドと逆に、サーフェスのエッジ部分以外のコントロールポインを選択します。

操作方法:

  1. サーフェスを選択して、Enterキーを押します。
  2. コマンドオプションからＵ方向、Ｖ方向、ＵＶ両方の中から方向を選択します。

RRAP_Tools>SelSurfacePointsExceptEdge


トリム曲線

MakeCuttingCurve
トリム曲線

選択したサーフェスのワールド軸上での最大幅を表わす曲線を作ります。

操作方法:

  1. サーフェスを選択します。

    このコマンドボタンの左クリックは、水平、垂直方向ともに、80ポイントでの計測となります。

    右クリックすると、水平、垂直方向の計測ポイント、それぞれの数を設定できます。

RRAP_Tools>MakeCuttingCurve 80x80

RRAP_Tools>MakeCuttingCurve(右クリック)


トリム曲線（フラット）

MakeFlatCuttingCurve
トリム曲線（フラット）

選択したサーフェスのワールド軸上での最大幅を表わすフラット(水平)な曲線を作ります。

操作方法:

  1. サーフェスを選択します。

    このコマンドボタンの左クリックは、水平、垂直方向ともに、40ポイントでの計測となります。

    右クリックすると、水平、垂直方向の計測ポイント、それぞれの数を設定できます。

RRAP_Tools>MakeFlatCuttingCurve 40x40

RRAP_Tools>MakeFlatCuttingCurve(右クリック)


曲線をストレート化

MakeCurveStraight
曲線をストレート化

選択した曲線をまっすぐに伸ばした長さの直線を配置します。

操作方法:

  1. 曲線を選択します。
  2. マウスを動かして、適当なところに配置します。

RRAP_Tools>MakeCurveStraight


曲線の長さを揃える（Ｘ軸方向）

EvanceAlignProfiles
曲線の長さを揃える（Ｘ軸方向）

⇒

選択した曲線をリファレンス曲線と同じワールドＸ軸方向で、長さを揃えます

操作方法:

  1. 変更する曲線をクリックして選択します。

  2. 次に、リファレンスとなる曲線を選択します。

    オプションで2D(ワールドＹ方向にも長さに合わせてスケールする)も選択できます。

RRAP_Toolss>EvanceAlignProfiles(右クリック)


Brep上で補間点指定

EvanceInterpcrvOnBrep
Brep上で補間点指定

⇒

ライノにはない、ポリサーフェス上に曲線が引けるコマンドです。

サーフェスや、ポリサーフェス上に線を引く目的の多くはそこをトリムするためです。

そのために、あえてぴったり張り付かずゆるく引けるように設計されています。

操作方法:

  1. 曲線を描くサーフェス、または、ポリサーフェスを選択します。

    デフォルトでは、ノットの設定が周期的ユニフォーム(以下で列記している"3"です)に設定されます。

    オプションから、ノットの設定を指定できます。

    0　ユニフォーム、1 弦、2 弦の平方根、3 周期的ユニフォーム、4 周期的弦、5 周期的弦の平方根です。

  2. マウスを左クリックして、曲線を描いていきます。

    'U'キーを確定するごとに、ひとつずつアンドゥできます。

    また、閉じるには'C'ｷｰで確定します。

    途中で終了する場合はEnterキーを押します。

RRAP_Tools>EvanceInterpcrvOnBrep


サーフェス上で補間点指定（エヴァンスバージョン）

EvanceInterpcrvOnSrf
サーフェス上で補間点指定（エヴァンスバージョン）

⇒

ライノの"InterpcrvOnSrf"(ｻｰﾌｪｽ上で補間点指定)コマンドで、回転体のようなサーフェス上では、左のサンプルピクチャーのように渦を巻いてしまい使い物にならなかった経験をお持ちの方も多いと思います。

このコマンドは、そういうことはなくストレスなくサーフェス上に曲線を描くことが出来ますが、このコマンドは最後にサーフェスにプルされませんので描いた時のままのコントロールポイント数は変わりません。

操作方法:

  1. 曲線を描くサーフェスを選択します。

    デフォルトでは、ノットの設定が周期的ユニフォーム(以下で列記している"3"です)に設定されます。

    オプションから、ノットの設定を指定できます。

    0　ユニフォーム、1 弦、2 弦の平方根、3 周期的ユニフォーム、4 周期的弦、5 周期的弦の平方根です。

  2. マウスを左クリックして、曲線を描いていきます。

    'U'キーを確定するごとに、ひとつずつアンドゥできます。

    また、閉じるには'C'ｷｰで確定します。

    途中で終了する場合はEnterキーを押します。

RRAP_Tools>EvanceInterpcrvOnSrf


サーフェス上で補間点指定（エヴァンスバージョン）、プル投影

EvanceInterpcrvOnSrf_Pull
サーフェス上で補間点指定（エヴァンスバージョン）、プル投影

⇒

ライノの"InterpcrvOnSrf"(ｻｰﾌｪｽ上で補間点指定)コマンドで、回転体のようなサーフェス上では、左のサンプルピクチャーのように渦を巻いてしまい使い物にならなかった経験をお持ちの方も多いと思います。

このコマンドは、そういうことはなくストレスなくサーフェス上に曲線を描くことが出来、最後にサーフェスにプルされます。

操作方法:

  1. 曲線を描くサーフェスを選択します。

    デフォルトでは、ノットの設定が周期的ユニフォーム(以下で列記している"3"です)に設定されます。

    オプションから、ノットの設定を指定できます。

    0　ユニフォーム、1 弦、2 弦の平方根、3 周期的ユニフォーム、4 周期的弦、5 周期的弦の平方根です。

  2. マウスを左クリックして、曲線を描いていきます。描き終わると、サーフェス上にプルされます。

    'U'キーを確定するごとに、ひとつずつアンドゥできます。

    また、閉じるには'C'ｷｰで確定します。

    途中で終了する場合はEnterキーを押します。

RRAP_Tools>EvanceInterpcrvOnSrf_Pull


曲線をBrepにアタッチ

AttachCurveToBrep
曲線をBrepにアタッチ

曲線をサーフェス、またはポリサーフェス上にアタッチします。

ライノのプルコマンドと違うのは、ポリサーフェス上でも作動するという点と、制御点を増やさないという点です。

そのため、制御点の数によっては、角の部分などは、ゆるい感じになります。

単純にコントロールポイントを(ポリ)サーフェス上に持ってきているわけではなく、曲線が一番近くなるように計算しています。

操作方法:

  1. 曲線を選択します。

    複数選択可なので、選び終わったらEnterキーを押します。

  2. コマンドオプションからサーフェスか、ポリサーフェスかを選択します。

RRAP_Tools>AttachCurveToBrep


曲線とBrepの距離

DisplayCurveToBrepDistance
曲線とBrepの距離

⇒

(ポリ)サーフェス上にある曲線と(ポリ)サーフェスとの最短距離を計測します。

操作方法:

  1. 曲線を選択します。

  2. サーフェスまたはポリサーフェスを選択して、サンプリングするポイントの数を入力します。

    サンプリング場所はほぼ均等に配置され、デフォルトでは100箇所です。

    もっとも距離が離れているところのテキストドットが選択され、強調表示されます。

RRAP_Tools>DisplayCurveToBrepDistance(右クリック)


曲線をサーフェスの法線方向にオフセット（マルチプル）

OffsetCurvesSrfNormlMultiple
曲線をサーフェスの法線方向にオフセット（マルチプル）

⇒

(ポリ)サーフェス上で曲線を(ポリ)サーフェスの法線方向にオフセットします。

操作方法:

  1. 曲線を選択します。

    複数選択可なので、選び終わったらEnterキーを押します。

  2. コマンドオプションからサーフェスか、ポリサーフェスかを選択します。

    適当なところをクリックしてマウスを移動させると移動距離と移動する曲線のコントロールポイントが見えるので、適当なところでクリックします。または、数値入力も可能です。

RRAP_Tools>OffsetCurvesSrfNormlMultiple


曲線のコントロール点をBrep上で移動

DragCrvCVPointsOnBrep
曲線のコントロール点をBrep上で移動

⇒

(ポリ)サーフェス上で曲線を(ポリ)サーフェスから離れていかないようにコントロールポイントを移動できます。

操作方法:

  1. 曲線を描(ポリ)サーフェスを選択します。

    ベースをサーフェスにするか、ポリサーフェスにするかをコマンドオプションから選択します。

  2. 制御点を選択して、移動させます。

RRAP_Tools>DragCrvCVPointsOnBrep


曲線からトリム用Brepを生成（マルチプル）

MakeSolidTrimmerMultiple
曲線からトリム用Brepを生成（マルチプル）

⇒

(ポリ)サーフェス上で曲線を(ポリ)サーフェスの法線方向に両方向オフセットしていき、その間に(ポリ)サーフェスをトリムできるサーフェスを生成します。

複数の曲線を同時に処理できます。

操作方法:

  1. 曲線を選択します。

    複数選択可なので、選び終わったらEnterキーを押します。

    コマンドオプションからサーフェスか、ポリサーフェスかを選択します。

  2. 適当なところをクリックしてマウスを移動させると移動距離と移動する曲線のコントロールポイントが見えるので、適当なところでクリックします。または、オフセット距離を数値入力も可能です。

    SuperTips:

    ポリサーフェス内のサーフェスの向きによって、サーフェスごとに向きが逆になってしまう場合は、LAP Toolsツールバーの中にある"RemoveFlippedNormals"コマンドを、このコマンドの前に実行してください。

    問題が解決されるでしょう。

RRAP_Tools>MakeSolidTrimmerMultiple


円を選択

SelCircle
円を選択

円を選択します。

操作方法:

  1. 何も選択されていない状態で、このコマンドを実行すると、正確な円だけを選択します。

StoneSets>Select Circle


直径を指定して円を選択

SelCircleEx
直径を指定して円を選択

直径を指定して、円を選択します。

操作方法:

  1. 選択したい円の直径を数字入力して、Enterキーを押します。

StoneSets>SelCircleEx


直径の範囲を指定して円を選択

SelCircleMinMax
直径の範囲を指定して円を選択

何ミリ以上、何ミリ以下という幅を持たせて、直径を指定して円を選択します。

操作方法:

  1. 選択する円の直径の最小値を数字入力して、Enterキーを押します。
  2. 選択する円の直径の最大値を数字入力して、Enterキーを押します。

StoneSets>SelCircleMinMax(右クリック)


Brep上に円を配置、編集（配置モード）

SetAndEditCirclesOnBrep
Brep上に円を配置、編集（配置モード）

(円をセットﾓｰﾄﾞ)

サーフェス、または、ポリサーフェスの上に、自在に指定したサイズの円を配置できます。

途中で、大きさや、レイヤーを自由に変更することが出来ます。

新バージョンでは、サーフェスの表裏を区別する仕様になりました。

これにより、極端な凸面や凹面の場合でもピッタリに石を配置できます。

円の中央に現れる矢印の向いている方向が表側を現しています。

操作方法:

  1. サークルを配置するサーフェス、または、ポリサーフェスをクリックして、選択します。
  2. 配置したい円の直径を入力し、Enterキーを押します。どのタイミングでも、直径を入力して、Enterキーを押せば、配置するサークルの直径を変えることが出来ます。

    円の中心に白い矢印が表示され、方向を示します。矢印の示す方向が表であることを示し、円は、この向きでサーフェスに最適化されます。

    向きを逆にしたい場合はコマンドオプションから、「反転」を選択するか、'F'を入力してエンターキーを押すか、右クリックで確定します。

    また、コマンドオプションから、隣の石との間隔の目安にするガイドサークルとのオフセット距離、サーフェスとの断面線の表示の有無を変更できます。

    配置したいサーフェス上のポイントをクリックします。

    Tips:

    配置される対象として、ポリサーフェスを選択できるので、途中で配置するサーフェスを切替えるためにコマンドをかけなおす煩わしさがなくなりました。

StoneSets>SetAndEditCirclesOnBrep(円をセットﾓｰﾄﾞ)


Brep上に円を配置、編集（編集モード）

SetAndEditCirclesOnBrep
Brep上に円を配置、編集（編集モード）

(円を移動 ﾓｰﾄﾞ)

サーフェス、または、ポリサーフェスの上に配置された円の移動、サイズ変更が行えます。

新バージョンでは、サーフェスの表裏を区別する仕様になりました。

これにより、極端な凸面や凹面の場合でもピッタリに石を配置できます。

円の中央に現れる矢印の向いている方向が表側をあらわしています。

操作方法:

  1. 円を移動するベースとなるサーフェス、または、ポリサーフェスをクリックして選択します。
  2. 再配置したい円をクリックすると、マウスで自由に移動できるようになります。

    円の中心に白い矢印が表示され、方向を示します。矢印の示す方向が表であることを示し、円は、この向きでサーフェスに最適化されます。

    向きを逆にしたい場合はコマンドオプションから、「反転」を選択するか、'F'を入力してエンターキーを押すか、右クリックで確定します。

    どのタイミングでも、直径を入力して、Enterキーを押せば、配置する円の直径を変更することが出来ます。

    また、コマンドオプションから、コピーの有無、隣の石との間隔の目安にするガイドサークルとのオフセット距離、サーフェスとの断面線の表示の有無を変更できます。

    配置したいサーフェス上のポイントをクリックします。

    元の円を残す場合はコマンドオプションから、「コピー」を選択するか、"C"を入力してエンターキーを押すか、右クリックで確定します。

    これを繰り返す移動モードにもどります。

    Tips:

    配置される対象として、ポリサーフェスを選択できるので、途中で配置するサーフェスを切替えるためにコマンドをかけなおす煩わしさがなくなりました。

StoneSets>SetAndEditCirclesOnBrep(円を移動 ﾓｰﾄﾞ)


サーフェス上に円を配置

ArrayCirclesOnSurface
サーフェス上に円を配置

サーフェス上に、自在に指定したサイズの円を配置できます。

途中で、大きさや、レイヤーを自由に変えることが出来ます。

このコマンドは、ポリサーフェスは選択できません。

操作方法:

  1. 円を配置するサーフェスをクリックして、選択します。
  2. 配置したい円の直径を入力し、Enterキーを押します。どのタイミングでも、直径を入力して、Enterキーを押せば、配置するサークルの直径を変えることが出来ます。コマンドオプションから、隣の石との間隔の目安にするガイドサークルとのオフセット距離、サーフェスとの断面線の表示の有無を変更できます。配置したいサーフェス上のポイントをクリックします。

StoneSets>ArrayCirclesOnSurface(右クリック)


サーフェス上の円を編集

MoveCircleOnSurfaceEx
サーフェス上の円を編集

サーフェス、または、ポリサーフェスの上に配置された円の移動、サイズ変更が行えます。

操作方法:

  1. 円を移動するベースとなるサーフェスをクリックして、選択します。
  2. 再配置したい円をクリックすると、マウスで自由に移動できるようになります。どのタイミングでも、直径を入力して、Enterキーを押せば、配置する石の直径を変更することが出来ます。コマンドオプションから、コピーの有無、隣の石との間隔の目安にするガイドサークルとのオフセット距離、サーフェスとの断面線の表示の有無を変更できます。配置したいサーフェス上のポイントをクリックします。

    Tips:

    配置される側のオブジェクトとして、このコマンドはポリサーフェスを選択できません。

StoneSets>MoveCircleOnSurfaceEx（右クリック）


円の直径を変更

SetCirclesDiameter
円の直径を変更

⇒

選択した複数の円を任意の直径に一度に変更します。

操作方法:

  1. 直径を変更したい円を選択します。
  2. 変更する直径を数値入力して、Enterキーを押します。

StoneSets>SetCirclesDiameter


円をサーフェス上に再配置

RemapCirclesOnChangedSurface
円をサーフェス上に再配置

⇒

サーフェス上に配置した円を元と違うサーフェス上に再配置します。

基準のサーフェスに変更を加えた場合など、変更後のサーフェス上にサークルを再配置し、編集すれば並べなおす手間を省くことが可能です。

新バージョンでは、サーフェスの表裏を区別する仕様になりました。

操作方法:

  1. 配置しなおすサークルを選択して、Enterキーを押します。
  2. 配置しなおしたい、変更されたサーフェスをクリックします。

    白い矢印が出現しますが、サーフェスの表側を現しています。

    反転する場合は、コマンドオプションから、「反転」を選択するか、'F'を入力してエンターキーを押します。

    Tips:

    ポリサーフェスに含まれるサーフェスがたくさんあって選びにくいときは、あえて、ジョインされているエッジのところを選ぶと、選択肢が現れるので、かえって間違わずに選択できます。

StoneSets>RemapCirclesOnChangedSurface


円を一括スケール

ArrayCircleScale
円を一括スケール

もとの円を基準として、それをスケーリングした円を同心円状に配置します。

抜き型の基準円として使用できます。

操作方法:

  1. スケールするサークルを選択して、Enterキーを押します。
  2. スケールする倍率を入力して、、Enterキーを押します。

    デフォルトでは、「0.454545」になっています。

StoneSets>ArrayCircleScale


円を法線方向に移動

MoveCirclesNormalDirection
円を法線方向に移動

⇒

サーフェスに配置した円をサーフェスの法線方向(垂直方向)に移動させることが出来ます。

選択した円の中心付近にあるオブジェクト(サーフェス、またはポリサーフェス)を自動検出して、同時に移動できるというオプションもついています。

操作方法:

  1. 移動させるサークルを選択して、Enterキーを押します。オプションからセットのオブジェクトも同時に移動させるかどうか、および、セットのオブジェクトを選定するセンサーの片側の長さを設定します。
  2. CPlane上に基準点を選びます。もしくは移動距離を入力して、Enterキーを押します。
  3. マウスを移動させて移動距離を指定します。数値入力も可能です。

StoneSets>MoveCirclesNormalDirection


メレーダイヤの抜型を配置（自動長さ調整）

ArrayCapedCylinderAH
メレーダイヤの抜型を配置（自動長さ調整）

⇒

(ポリ)サーフェスに配置した円から抜き型となる円柱を生成します。

AHは、"Auto Height"の略です。

円の置かれたポリサーフェスか、サーフェスの中心部分の厚みを自動的に測定しますので、表側、裏側にとび出させる距離を設定することが出来ます。

テーパーの設定も出来、さらには、裏側をラウンド形状にすることもできます。

裏側にとび出させる距離をマイナスに設定して指定すると、指定した厚みだけ残して、貫通させない設定にすることも出来ます。

デフォルトではシングルサーフェスで出力されますが、オプションからポリサーフェスも選べます。

操作方法:

  1. ベースになる円を選択して、Enterキーを押します。
  2. 表側にとび出させる距離、裏側にとび出させる距離、、高さ、テーパーのつけ具合、キャップのRの付け具合をコマンドオプションから選択できます。

    コマンドオプションの数値を変更すると再計算されます。

    SuperTips:

    テーパーは、「1」が、ずん胴で、それより小さな数字だと、先が細くなり、大きな数字だと、先が太くなります。

    ラウンドの設定は、「０」でフラット、「１」で、半球です。

    尚、このコマンドは、ポリサーフェスが選択できて便利ですが、ポリサーフェス内のサーフェスの法線の向きや、サークルとの位置関係によっては、予想外の結果となることがあります。

    とくに、ソリッドとして完成していないただのサーフェス上の円に対してこのコマンドを実行すると、ストッパーとなるサーフェスが存在しないため、長い円柱が出来てしまうので、ご注意ください。

    ポリサーフェス内のサーフェスの向きによって、所々、向きが逆になってしまう場合は、StoneSetsツールバーの中にある、"RemoveFlippedNormals"コマンドを、このコマンドの前に実行してください。

    問題が解決されるでしょう。

StoneSets>ArrayCapedCylinderAH


メレーダイヤの抜型を配置（長さを指定）

ArrayCapedCylinder
メレーダイヤの抜型を配置（長さを指定）

⇒

(ポリ)サーフェスに配置した円から抜き型となる円柱を生成します。

AHとの違いは、長さを自動計算しないので直接指定できるところです。

テーパーの設定も出来、さらには、裏側をラウンド形状にすることもできるなどその他の仕様はAHに準じます。

デフォルトではシングルサーフェスで出力されますが、オプションからポリサーフェスも選べます。

操作方法:

  1. ベースになる円を選択して、Enterキーを押します。 表側にとび出させる距離、内側に入り込む部分の長さ、高さ、テーパーのつけ具合、キャップのRの付け具合をコマンドオプションから選択できます。 コマンドオプションの数値を変更すると再計算されます。

    2. SuperTips:

    テーパーは、「1」が、ずん胴で、それより小さな数字だと、先が細くなり、大きな数字だと、先が太くなります。

    ラウンドの設定は、「０」でフラット、「１」で、半球です。

    尚、このコマンドは、ポリサーフェスが選択できて便利ですが、ポリサーフェス内のサーフェスの法線の向きや、サークルとの位置関係によっては、予想外の結果となることがあります。

    ポリサーフェス内のサーフェスの向きによって、所々、向きが逆になってしまう場合は、StoneSetsツールバーの中にある、"RemoveFlippedNormals"コマンドを、このコマンドの前に実行してください。

    問題が解決されるでしょう。

StoneSets>ArrayCapedCylinder（右クリック）


メレーダイヤの抜型を配置（長さ指定：サーフェス上）

ArrayCapedCylinderOnSurface
メレーダイヤの抜型を配置（長さ指定：サーフェス上）

⇒

(ポリ)サーフェスに配置した円から抜き型となる円柱を生成します。

AHとの違いは、長さを自動計算しないので直接指定できるところです。

"ArrayCapedCylinder"コマンドでは、ベースをBrepとして認識してしまうので、先に抜型でブーリアンなどで、抜いた後の穴や窪みのあるベース上では誤作動してしまうケースが多々見られますが、このコマンドでは、ブールされた形状でもサーフェスとして認識しますので、そのような誤作動が避けられます。

テーパーの設定も出来、さらには、裏側をラウンド形状にすることもできるなどその他の仕様は"ArrayCapedCylinder"コマンドに準じます。

デフォルトではシングルサーフェスで出力されますが、オプションからポリサーフェスも選べます。

操作方法:

  1. ベースになる円を選択して、Enterキーを押します。 表側にとび出させる距離、内側に入り込む部分の長さ、高さ、テーパーのつけ具合、キャップのRの付け具合をコマンドオプションから選択できます。 コマンドオプションの数値を変更すると再計算されます。

    SuperTips:

    テーパーは、「1」が、ずん胴で、それより小さな数字だと、先が細くなり、大きな数字だと、先が太くなります。

    ラウンドの設定は、「０」でフラット、「１」で、半球です。

    尚、このコマンドは、ポリサーフェスが選択できて便利ですが、ポリサーフェス内のサーフェスの法線の向きや、サークルとの位置関係によっては、予想外の結果となることがあります。

    とくに、ソリッドとして完成していないただのサーフェス上の円に対してこのコマンドを実行すると、ストッパーとなるサーフェスが存在しないため、長い円柱

StoneSets>ArrayCapedCylinderOnSurface


爪を配置

RECylinderShallowOnBrep
爪を配置

⇒

(ポリ)サーフェス上に配置した円から爪となる円柱を生成します。

片側は指定された長さだけ反対側は、０．２ｍｍだけ円柱に立ち上げます。

テーパーをかけることも可能です。

自動的にキャプされますが、キャップのRのつけ具会が、数値入力できます。

「0」でフラット、「1」で半球になります。

デフォルトではシングルサーフェスで出力されますが、オプションからポリサーフェスも選べます。

操作方法:

  1. ベースとなる円を選択します。
  2. 基準になるサーフェス、または、ポリサーフェスを選択します。

    立ち上げる向き、高さ、テーパーのつけ具合、キャップ部分のRの付け具合をコマンドオプションから選択できます。

    コマンドオプションの数値を変更すると再計算されます。

    SuperTips:

    テーパーは、「1」が、ずん胴で、それより小さな数字だと、先が細くなり、大きな数字だと、先が太くなります。

    しかし、実は、「1」より大きな数字を入力することが出来ます。

    その結果は。・・・。

    自身で試してみて下さい。

    尚、このコマンドは、ポリサーフェスが選択できて便利ですが、ポリサーフェス内のサーフェスの法線の向きや、サークルとの位置関係によっては、あらぬ結果となることがあります。

    ポリサーフェス内のサーフェスの向きによって、所々、向きが逆になってしまう場合は、StoneSetsツールバーの中にある、"RemoveFlippedNormals"コマンドを、このコマンドの前に実行してください。

    実は、これは、ライノのコマンドなのですが、ヘルプを見るとすでに削除されたことになっていますが、きちんと作動します。

    また、その他の不具合が生じる場合は、その部分だけ、、"CylinderShallowOnSrf"コマンドを利用してください。

StoneSets>RECylinderShallowOnBrep


爪を配置（サーフェス上）

RECylinderShallowOnSurface
爪を配置（サーフェス上）

⇒

サーフェス上に配置した円から爪となる円柱を生成します。

片側は指定された長さだけ反対側は、０．２ｍｍだけ円柱に立ち上げます。

テーパーをかけることも可能です。

自動的にキャプされますが、キャップのRのつけ具会が、数値入力できます。

「0」でフラット、「1」で半球になります。

デフォルトではシングルサーフェスで出力されますが、オプションからポリサーフェスも選べます。

操作方法:

  1. ベースとなるサークルを選択して、、Enterキーを押します。
  2. 基準になるサーフェスを選択します。

    立ち上げる向き、高さ、テーパーのつけ具合、キャップのRの付け具合をコマンドオプションから選択できます。

    コマンドオプションの数値を変更すると再計算されます。

    Tips:

    "RECylinderShallowOnBrep"コマンドと違い、このコマンドは、ベースにサーフェスしか、選択できませんが、"RECylinderShallowOnBrep"コマンドは、ベースの(ポリ)サーフェスがブーリアンなどでトリムされていた場合などに、意図と違う動作をする可能性があります。

    抜き型でブールしたりしてしまった場合、"RECylinderShallowOnBrep"コマンドでは、当然誤作動を起こしますが、このコマンドではベースとなるサーフェスが、トリムされていても、トリムされていない、もとのままのサーフェスとして認識します。

    ケースによって、使い分けてください。

StoneSets>RECylinderShallowOnSurface（右クリック）


爪を配置(一方向に向きを揃えて)

RECylinderShallow_ND
爪を配置(一方向に向きを揃えて)

⇒

サーフェス上に配置した円を押し出し、任意の基準線(円など)の垂直方向に爪となる円柱を生成します。

反対側は、０．２ｍｍだけ立ち上がります。

テーパーをかけることも可能です。

このコマンドは、図のようにそれぞれの円の中心点のサーフェスの法線方向ではなく、一定の方向に向けて作成されます。

自動的にキャプされますが、キャップのRのつけ具会が、数値入力できます。

「0」でフラット、「1」で半球になります。

デフォルトではシングルサーフェスで出力されますが、オプションからポリサーフェスも選べます。

操作方法:

  1. ベースとなるサークルを選択して、、Enterキーを押します。
  2. 基準になるサーフェスを選択します。

    次に、基準になる曲線、またはサーフェスエッジを選択しますが、必ずしも平らな曲線でなくても、自動的におおよその向きを計算するので、問題ありません。

    Tips:コマンドオプションから爪のタイプを選択できます。「平行」を選択すると単純にまっすぐな爪、「スラント」を選択するとしたのサーフェス面とのつながりを考慮した爪になります。「平行」の場合、下のサーフェスが斜めになっていると、爪の一部が浮いてしまうので「内側の長さ」を眺めに調整します。その他、立ち上げる向き、高さ、テーパーのつけ具合、キャップのRの付け具合をコマンドオプションから調整可能です。

    コマンドオプションの数値を変更するとその場で再計算されます。

StoneSets>RECylinderShallow_ND


球の抜型を配置

OffsetRECylinderShallowOnBrep
球の抜型を配置

⇒

(ポリ)サーフェス上に配置された円を押し出して石座等の半球の抜き型形状を生成します。

抜き型を沈める量も設定でき、さらには、その円柱部分の長さも変更可能です。

デフォルトではシングルサーフェスで出力されますが、オプションからポリサーフェスも選べます。

操作方法:

  1. ベースとなる円を選択します。
  2. 基準になるサーフェス、または、ポリサーフェスを選択します。

    必要なら、コマンドオプションで、各種パラメーターを設定します。

    コマンドオプションの各種パラメーターを変更すると再計算されます。

    SuperTips:

    このコマンドは、ベースのオブジェクトにポリサーフェスが選択できて便利ですが、ポリサーフェス内のサーフェスの法線の向きや、サークルとの位置関係によっては、あらぬ結果となることがあります。

    特に、下穴を先に開けてしまって直下にサーフェスが存在しない場合は、著しく誤作動しますので、注意してください。

    また、ポリサーフェス内のサーフェスの向きによって、所々、向きが逆になってしまう場合は、StoneSetsツールバーの中にある、"RemoveFlippedNormals"コマンドを、このコマンドの前に実行してください。

    実は、これは、ライノのコマンドなのですが、ヘルプを見るとすでに削除されたことになっていますが、きちんと作動します。

StoneSets>OffsetRECylinderShallowOnBrep


皿揉みの抜型を配置

ArrayConeCylinderOnBrep
皿揉みの抜型を配置

⇒

(ポリ)サーフェス上に配置された円を押し出して石座等の抜き型形状となるコーンを生成します。

その円柱部分の長さも設定でき、さらには、その部分にテーパーをかけることも可能です。

さらには、このコマンドでは、ポリサーフェスもベースオブジェクトに選択できるようになりました。

デフォルトではシングルサーフェスで出力されますが、オプションからポリサーフェスも選べます。

操作方法:

  1. ベースとなる円を選択します。
  2. 基準になるサーフェス、または、ポリサーフェスを選択します。

    円錐部分の角度、ベースのサーフェスから離す距離、円柱部分の高さ、円柱部分のテーパー係数を、コマンドオプションから選択できます。

    新バージョンでは、オプションでスティルスモードが選べるようになり、「ｽﾃｨﾙｽﾓｰﾄﾞ(S)=はい」にすると石がほぼ面一に沈む設定になります。

    コマンドオプションの数値を変更すると再計算されます。

    SuperTips:

    キューレットの角度は、「1」で、90度、それ以上大きな数字を入れると、角度は広くなり、小さい数字を入れると狭くなります。

    円柱部分のテーパー係数は、デフォルトの「1」で、ずん胴、それより小さな数字だと、先が細くなり、大きな数字だと、先が太くなります。

    ベースのサーフェスから離す距離に、マイナス値を指定すると、伏せ込みなどの設定も作ることが出来ます。

    尚、このコマンドは、ベースのオブジェクトにポリサーフェスが選択できて便利ですが、ポリサーフェス内のサーフェスの法線の向きや、サークルとの位置関係によっては、あらぬ結果となることがあります。

    特に、下穴を先に開けてしまって直下にサーフェスが存在しない場合は、著しく誤作動しますので、注意してください。

    其の場合は、"ArrayConeCylinderOnSurface"コマンドを利用してください。

    ポリサーフェス内のサーフェスの向きによって、所々、向きが逆になってしまう場合は、StoneSetsツールバーの中にある、"RemoveFlippedNormals"コマンドを、このコマンドの前に実行してください。

    実は、これは、ライノのコマンドなのですが、ヘルプを見るとすでに削除されたことになっていますが、きちんと作動します。

StoneSets>ArrayConeCylinderOnBrep


皿揉みの抜型を配置（サーフェス上）

ArrayConeCylinderOnSurface
皿揉みの抜型を配置（サーフェス上）

⇒

サーフェス上に配置された円を押し出して石座等の抜き型形状となるコーンを生成します。

その円柱部分の長さも設定でき、さらには、その部分にテーパーをかけることも可能です。

配置するサーフェスが、ブーリアンなどでトリムされていても、トリムされていないサーフェスとして認識します。

デフォルトではシングルサーフェスで出力されますが、オプションからポリサーフェスも選べます

操作方法:

  1. ベースとなるサークルを選択して、Enterキーを押します。
  2. 基準になるサーフェスを選択します。

    円錐部分の角度、ベースのサーフェスから離す距離、円柱部分の高さ、円柱部分のテーパー係数を、コマンドオプションから選択できます。

    新バージョンでは、オプションでスティルスモードが選べるようになり、「ｽﾃｨﾙｽﾓｰﾄﾞ(S)=はい」にすると石がほぼ面一に沈む設定になります。

    コマンドオプションの数値を変更すると再計算されます。

    Tips:

    キューレットの角度は、「1」で、90度、それ以上大きな数字を入れると、角度は広くなり、小さい数字を入れると狭くなります。

    円柱部分のフーバー係数は、デフォルトの「1」で、寸胴、それより小さな数字だと、先が細くなり、大きな数字だと、先が太くなります。

    このコマンドは、直下のサーフェスがトリム、およびマイナスブールなどされていて存在しなかった場合でも、正確に作動します。

StoneSets>ArrayConeCylinderOnSurface（右クリック）


ダイヤシェープを製作

DiaShapeObject
ダイヤシェープを製作

⇒

ラウンド宝石の石座を抜くための抜き型を生成します。

円を描くコマンドと同様に、２点指定、３点指定など、いろいろな描き方が出来ます。

本物のブリリアンカットのようには、面数を多くしていないので、ダイヤを固定する切り欠きなどを作る際に便利です。

操作方法:

  1. ライノの"Circleコマンド"に準じて操作してください。

    Tips:

    オプションは、Circleコマンドと同様なので、そちらを参照してください。

StoneSets>DiaShapeObject


ダイヤシェープを配置

ArrayDiaShapeOnBrep
ダイヤシェープを配置

⇒

サーフェス上に配置した円からラウンド宝石の石座を抜くための抜き型を生成します。

このコマンドは、ベースとして、サーフェスはもちろん、ポリサーフェスも選択することが出来ます。

新バージョンではシングルサーフェスで出力されます。

操作方法:

  1. ベースとなる円を選択します。
  2. 基準になるサーフェス、または、ポリサーフェス。を選択します。

    円柱部分の角度、ベースのサーフェスから離す距離を、コマンドオプションから選択できます。

    コマンドオプションの数値を変更すると再計算されます。

    Tips:

    キューレットの角度は、「1」で、90度、それ以上大きな数字を入れると、角度は広くなり、小さい数字を入れると狭くなります。

    尚、このコマンドは、ポリサーフェスが選択できて便利ですが、ポリサーフェス内のサーフェスの法線の向きや、サークルとの位置関係によっては、予想と異なる結果となることがあります。

    特に、下穴を先に開けてしまって直下にサーフェスが存在しない場合は、想定外の作動をしますので、注意してください。(直下にサーフェスが存在しないので、動作としては正しいです。)

    其の場合は、"ArrayDiaShapeOnSurface"コマンドを利用してください。

    ポリサーフェス内のサーフェスの向きによって、所々、向きが逆になってしまう場合は、StoneSetsツールバーの中にある、RemoveFlippedNormalsコマンドを、このコマンドの前に実行してください。

StoneSets>ArrayDiaShapeOnBrep


ダイヤシェープを配置（サーフェス上）

ArrayDiaShapeOnSurface
ダイヤシェープを配置（サーフェス上）

⇒

サーフェス上に配置した円からラウンド宝石の石座を抜くための抜き型を生成します。

このコマンドは、ベースとして、ポリサーフェスは選択することが出来ません。

新バージョンではシングルサーフェスで出力されます。

操作方法:

  1. ベースとなる円を選択します。
  2. 基準になるサーフェスを選択します。

    立ち上がる向き、円錐部分の角度、ベースのサーフェスから離す距離を、コマンドオプションから選択できます。

    コマンドオプションの数値を変更すると再計算されます。

    Tips:

    キューレットの角度は、「1」で、90度、それ以上大きな数字を入れると、角度は広くなり、小さい数字を入れると狭くなります。

StoneSets>ArrayDiaShapeOnSurface（右クリック）


ダイヤを製作

MakeDiaObject
ダイヤを製作

⇒

円を画くように、ラウンド宝石形状を生成します。

円を描くコマンドと同様に、２点指定、３点指定など、いろいろな描き方が出来ます。

操作方法:

  1. ライノの"Circle"コマンドと同様に操作してください。

    2. Tips:

    オプションは"、Circle"コマンドと同様なので、そちらを参照してください。

StoneSets>MakeDiaObject


ダイヤを配置

ArrayDiaObjectsOnBrep
ダイヤを配置

⇒

(ポリ)サーフェス上に配置した円から、ラウンド宝石形状を一括生成します。

操作方法:

  1. ベースとなる円を選択します。
  2. 基準になるサーフェス、または、ポリサーフェスを選択します。

    ラウンド宝石形状の向き、ベースのサーフェスから離す距離を、コマンドオプションから選択できます。

    新バージョンでは、オプションでスティルスモードが選べるようになり、「ｽﾃｨﾙｽﾓｰﾄﾞ(S)=はい」にすると石がほぼ面一に沈む設定になります。

    コマンドオプションの数値を変更すると再計算されます。

    SuperTips:

    このコマンドは、ポリサーフェスが選択できて便利ですが、ポリサーフェス内のサーフェスの法線の向きや、サークルとの位置関係によっては、予想外の結果となることがあります。

    特に、下穴を先に開けてしまって直下にサーフェスが存在しない場合は、誤作動と思われる動作をしますので、注意してください。(直下にサーフェスが存在しないので、実は、動作としては正しいです。)

    その場合(とくに、「ｽﾃｨﾙｽﾓｰﾄﾞ(S)=はい」の場合)は、"ArrayDiaObjectsOnSurface"コマンドを利用してください。

    ポリサーフェス内のサーフェスの向きによって、所々、向きが逆になってしまう場合は、StoneSetsツールバーの中にある、"RemoveFlippedNormals"コマンドを、このコマンドの前に実行してください。

StoneSets>ArrayDiaObjectsOnBrep


ダイヤを配置（サーフェス上）

ArrayDiaObjectsOnSurface
ダイヤを配置（サーフェス上）

⇒

サーフェス上に配置した円から、ラウンド宝石形状を一括生成します。

操作方法:

  1. ベースとなる円を選択します。
  2. 基準になるサーフェスを選択します。

    ラウンド宝石形状の向き、ベースのサーフェスから離す距離を、コマンドオプションから選択できます。

    新バージョンでは、オプションでスティルスモードが選べるようになり、「ｽﾃｨﾙｽﾓｰﾄﾞ(S)=はい」にすると石がほぼ面一に沈む設定になります。

    コマンドオプションの数値を変更すると再計算されます。

StoneSets>ArrayDiaObjectsOnSurface（右クリック）


ダイヤ・カラット数に変換

ConvertInDiamondCarat
ダイヤ・カラット数に変換

⇒

宝石オブジェクトをダイヤモンドのキャラット数として計算します。

新しいバージョンでは、対象がメッシュオブジェクトでも機能するようになりました。

結果は、コマンドライン上部に表示されます。

操作方法:

  1. 計算したいサーフェス、ポリサーフェス、メッシュを選択して。Enterキーを押します。

    2. Tips:

    選択したオブジェクトに体積があれば、何でも、ダイヤモンドとして、換算します。

StoneSets>ConvertInDiamondCarat


六角形の抜型を配置（自動長さ調整）

ArrayHexagonalPyramidAH
六角形の抜型を配置（自動長さ調整）

⇒

(ポリ)サーフェスに配置した円から背面サーフェス方向にハニカム孔を抜くための形状を生成します。

AHは、"Auto Height"の略です。サークルの置かれたポリサーフェスか、サーフェスの中心部分の厚みを自動的に測定しますので、飛び出させる距離を設定することが出来ます。

ただし、このコマンドは、上の図のように中穴を抜いたり、石座のもみこみを作ってからで誤作動してしまいますので、パヴェ面を加工する前に作っておく必要があります。（ベースのサーフェスがトリムやブールで加工される以前という意味です。）

操作方法:

  1. サーフェス上に配置した円を選択します。
  2. 基準になるサーフェス、または、ポリサーフェスを選択します。

    生成される六角錐の向き、裏からとび出させる距離、水平方向、垂直方向のスケール倍率をコマンドオプションから選択できます。

    新しいバージョンでは、角度を入力して回転というオプションも追加されました。

    コマンドオプションの数値を変更すると再計算されます。

    Tips:

    配置するサーフェスの形状によって、水平方向、垂直方向のスケール倍率を入力します。

    デフォルトは、「１」です。さらなる編集には、

    さらなる編集には、Evance'sScriptsのツールセットに含まれている、"MoveAndEditObjectsOnBrep"コマンドセットなどを併用するとよいでしょう。

StoneSets>ArrayHexagonalPyramidAH


六角形の抜型を配置（長さを指定）

ArrayHexagonalPyramid
六角形の抜型を配置（長さを指定）

⇒

サーフェスに配置した円から背面サーフェス方向にハニカム孔を抜くための形状を生成します。

操作方法:

  1. サーフェス上に配置したラウンドダイヤに見たてた円を選択します。
  2. 基準になるサーフェスを選択します。

    生成される六角錐の向き、裏からとび出させる距離、水平方向、垂直方向のスケール倍率をコマンドオプションから選択できます。

    新しいバージョンでは、角度を入力して回転というオプションも追加されました。

    コマンドオプションの数値を変更すると再計算されます。

    Tips:

    配置するサーフェスの形状によって、水平方向、垂直方向のスケール倍率を入力します。

    デフォルトは、「１」です。

    さらなる編集には、Evance'sScriptsのツールセットに含まれている、"MoveAndEditObjectsOnSurface"コマンドセットなどを併用するとよいでしょう。

StoneSets>ArrayHexagonalPyramid(右クリック)


円の直径を表示

CircleDiameter
円の直径を表示

⇒

作成した円(ラウンド宝石等)のサイズを計測します。

操作方法:

  1. 配置したラウンド宝石に見たてた円を選択して、Enterキーをおします。

    Tips:

    表示色は、そのときのレイヤーカラーになります。

    見やすい色を選択しておきましょう。

StoneSets>CircleDiameter


円の直径の一覧を表示

CircleSizeSort
円の直径の一覧を表示

⇒

作成した円(ラウンド宝石等)のサイズ、個数を一括計測します。

操作方法:

  1. 配置したラウンド宝石に見たてた円を選択して、Enterキーをおします。

    Tips:

    表示色は、そのときのレイヤーカラーになります。

      見やすい色を選択しておきましょう。

StoneSets>CircleSizeSort


Evance Help

EVANCEコマンドリスト

WakuwakuMaker_JS

AddRingBaseCylinder

AdjustObjectLength

AnalyzeBrep

ArrayCapedCylinder

ArrayCapedCylinderAH

ArrayCapedCylinderOnSurface

ArrayCircleScale

ArrayCirclesOnSurface

ArrayConeCylinderOnBrep

ArrayConeCylinderOnSurface

ArrayDiaObjectsOnBrep

ArrayDiaObjectsOnSurface

ArrayDiaShapeOnBrep

ArrayDiaShapeOnSurface

ArrayEvancePlong

ArrayHexagonalPyramid

ArrayHexagonalPyramidAH

ArrayObjectMoveToPoint

ArrayRingProfiles

ArraySphereAroundPoint

ArraySphereBasedOnCircles

AttachCurveToBrep

AttachCurveToMesh

AttachSrfPointsToBrep_ND

AttachSrfPointsToBrep_NP

AttachSrfPointsToGEM_Balanced

AttachSrfPointsToGEM_MixedND

AttachSrfPointsToGEM_ND

AttachSrfPointsToGEM_ND_AV

AttachSrfPointsToGEM_NP

AttachSrfPointsToGEMCenter

AttachSurfacePointsDirZForGEM

AttachSurfacePointsForGEM

AvarageCurveEx_Loft

AverageCurveOfEvance

CheckSurfaceNormal

CheckSurfaceNormalSelectPT

CircleDiameter

CircleSizeSort

ClearShadingIndividual

ConvertInDiamondCarat

DeleteCurveKinks_Rebuild

DeleteCurveKinksForRRAP

DeleteUnselectecdDots

DiaShapeObject

DisplayCurveKnotInfomation

DisplayCurveLengths

DisplayCurveToBrepDistance

DisplayCurveToMeshDistance

DisplaySurfaceCVIndex

DisplayTickness

DisplayTicknessSurfaceToMesh

DragCrvCVPointsOnBrep

DragCrvCVPointsOnMesh

DressPointsAboveCurve

EditEvancePlong

EditObjectByCenterPassCurve

EditObjectsOnBrepND

EditObjectsOnSurfaceND

EditSolidSurfaces

EVANCE_JS_2

EVANCE_JS_3

EVANCE_JS_REGISTER

EvanceAlignProfiles

EvanceCap

EvanceCapDegree3

EvanceExtCrvStraightRebuild

EvanceExtrudeCrv

EvanceExtrudeCrvByArc

EvanceExtrudeCrvByArcRebuild

EvanceExtrudeCrvRebuild

EvanceInsertCurveKink

EvanceInterpcrvOnBrep

EvanceInterpcrvOnMesh

EvanceInterpcrvOnSrf

EvanceInterpcrvOnSrf_Pull

EvanceOffsetMesh

ExchangeCVPoints

ExchangeCVPointsSetSelect

ExchangeCVPtSetSelectHyper

ExtrudeBordersToPoints

ExtrudeBrepBordersToPoints

ExtrudeCrvD3MultiDirTP

ExtrudeCrvDegree3

ExtrudeCrvDegree3MultiDir

flattenCurvesSimple

GetNeighborGripsTogether

GetNeighborGripsTogetherSL

GetParametersPoint

HideLockedObjects

HideNoGripsObjects

ImproveHelix

ImproveHelix_Y_RingUse

ImproveHelix_Y_RingUse_Ex

ImproveHelix_YZ

ImproveHelix_YZ_Ex

ImproveHelix_Z

ImproveHelix_Z_Ex

InsertSrfKnotsMultiple

IntersectLineOnMesh

LocateMeshObjectsCenter

Make2RailCrossSection

Make2RailCrossSectionAuto

MakeCurveStraight

MakeCuttingCurve

MakeCuttingCurveFromMesh

MakeDiaObject

MakeDoubleVAOffSetSurfaceDirZ

MakeFlatCuttingCurve

MakePartsFrom2Curves

MakeSolidTrimmerMultiple

MakeSurfaceCenterPass

MakeVANetworkSrfOrthoRebuild

MakeVANetworkSrfPlanerRebuild

MakeVANetworkSurfaceOrtho

MakeVANetworkSurfaceRebuild

MakeVAOffSetSurfaceDirZ

MergeBreps

MillInParallelCrosses

MillOnEdgeSrf

MirrorSurfaceCVPoints

MoveAndEditCurveAroundPass-Move

MoveAndEditCurveAroundPass-Scale

MoveAndEditCurveAroundPass-Rotate

MoveAndEditCurveAroundPass-MoveOnRingPath

MoveAndEditCurveAroundPass-MoveOnRingPath-Free

MoveAndEditObjectsOnBrep-Move

MoveAndEditObjectsOnBrep-Scale

MoveAndEditObjectsOnBrep-Rotate

MoveAndEditObjectsOnBrep-1D

MoveAndEditObjectsOnBrep-2D

MoveAndEditObjectsOnBrep-UVScale

MoveAndEditObjectsOnBrep-MoveNormal

MoveAndEditObjectsOnBrep-FlipNormal

MoveAndEditObjectsOnSurface-Move

MoveAndEditObjectsOnSurface-Scale

MoveAndEditObjectsOnSurface-Rotate

MoveAndEditObjectsOnSurface-1D

MoveAndEditObjectsOnSurface-2D

MoveAndEditObjectsOnSurface-UVScale

MoveAndEditObjectsOnSurface-MoveNormal

MoveAtRandom

MoveCircleOnSurfaceEx

MoveCirclesNormalDirection

MoveCVPointsToBrep

MoveCVPointsToMesh

MoveCVPointsToPoint

MoveCVPointsToPoint1DirEachObj

MoveCVPointsToPointsCenter

MoveCVPtsToPtsCenter1DirEachObj

MoveCVPtsToPtsCenterEachObj

MoveObjectsCenterToPoint

MoveObjectsToSurface

MoveSetObjectCenterToPoint

MoveSrfPointsGradually_RS

MoveSrfPointsPN_RS

MoveSrfPTsPartlyParamNormal

MoveSrfPTToBrepConstDistance

MoveSrfPTToBrepThresholdsDirZ

MoveSrfPTToBrepThresholdsEx

MoveSurfacePointGradually_W_Y

MoveSurfacePointsAVector

MoveSurfacePointsAverageDirZ

MoveSurfacePointsGradually

MoveSurfacePointsToBrep_ND

MoveSurfacePointsToMesh_ND

MoveSurfacePointsToMeshDirZ

MoveSurfacePointsToPoint2D_JS

MoveSurfacePointsToRingSize_M

MoveSurfacePointsToRingSizeBM

MoveSurfacePointSymmetry

MultipleBooleanDif_Ultima

MultipleBooleanUnion_Ultima

MultipleSelPointsInvertEndEx

NumberGripOwnersCVIndices

NumberSurfaceCVIndices

OffsetCurveMultiple

OffsetCrvOnSrfMultiple

OffsetCurvesSrfNormlMultiple

OffsetRECylinderShallowOnBrep

PointsOnDistanceBetween2Srf

PointsOnDistanceBetween2SrfHD

PointsOnDistanceSrfToMesh

PointsOnDistanceSrfToMeshHD

PointsOnMesh

QuickRebuildSurface

RebuildAndRefleshSurface

RebuildAveragingSrfSelectPT

RebuildAveragingSurface

RebuildControlCurve

RebuildControlSurface

RebuildCrvSpecifiedDeviation

RebuildCrvSpecifiedDeviation2

RECylinderShallow_ND

RECylinderShallowOnBrep

RECylinderShallowOnSurface

RemapCirclesOnChangedSurface

RenderingIndividualObjects

RenderingInvertSelectObjects

ReturnToSurface

RingControlCurve

RingControlSurfaceY_axis

RingResize

RingSizeDialog

RingSurfaceControllerYDirJS3

RingSurfaceControllerYDirJS2

RotateCurve3D

RotateSetObjectsSurfaceNormal

RotateSurfacePointsFlat

RotateSurfacePointsGradually

RotateSurfacePointsUV

RoundDiaSet

RS

ScaleCurveMultiple

ScaleCurves1DAlong2RailCurves

ScaleMultiple

ScaleFacesMultiple

ScaleSurfacePoints_RingSize

ScaleSurfacePointsGradually

ScaleSurfacePointsUV

ScaleSurfacePointsWorld_Y

SearchCurveCenterPoint

SearchSurfaceCVPoint

SeekCirclesCenterPoints

SelCircle

SelCircleEx

SelCircleMinMax

SelColorDot

SelCVPointsInnerSurface

SelectCurveEndPoints

SelectIneptCVPoints

SelectMeshNeighborGripsMulti

SelectNeighborGripsMultiple

SelectOnlyNeighborGrips

SelectSurfaceIneptCVPoints

SelfIntersectionCurveCheck

SelPointsAboveCurve

SelSurfaceEdgePoints

SelSurfacePointsExceptEdge

SelSurfacePointsInvertEndEx

SelUorV

SelVolumeProblemObjects

SetAndEditCirclesOnBrep

SetAndEditCirclesOnBrep-Move

SetCirclesDiameter

SetCPlanFor2RailSweep

SetCPlanToCrossSectionCurve

SetCurvesZFactor

SetCVPointsBetween

SetCVPointsBetweenEx

SetCVPointsBetweenMultiple

SetDiaCarat

SetProfileCurvesWidthAndHight

SetStoneSize

SetSurfacePointsPlan

ShadingIndividualObjects

ShadingInvertSelectObjects

SmoozingCVPointsButDirZ

SmoozingCVPointsDirZForGem

SmoozingCVPointsLHAuto

SmoozingCVPointsLooserAC

SmoozingCVPointsLooserAP

SmoozingCVPointsLooserAR

SmoozingCVPointsLooserDirV_AC

SmoozingCVPointsLooserUVDir

SmoozingCVPointsOnBrepAuto

SmoozingCVPointsOnMeshAuto

SmoozingSrfLHAuto

SmoozingSurfaceAR

SmoozingSurfaceOnMeshAuto

TotalAvarageCurve

TwoObjectsBooleanDif_Ultima

UnSelectNoGripsObjects

UnshadingIndividualObjects

UnshadingInvertSelectObjects

VolumeDisplay

VolumeDisplaySelected

WakuwakuMaker

WakuwakuMaker_JS

WakuwakuMakerByPipes